Uploaded image for project: 'James Server'
  1. James Server
  2. JAMES-1224

STLS in POP3 does not seem to work

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: Trunk, 3.0-beta3
    • Fix Version/s: 3.0-beta3
    • Component/s: POP3Server
    • Labels:
      None

      Description

      Maybe I misunderstand something, but:

      in pop3server.xml I have:

      <pop3server enabled="true">
      <bind>0.0.0.0:110</bind>
      <connectionBacklog>200</connectionBacklog>
      <tls socketTLS="false" startTLS="true">
      <keystore>file://conf/file.jks</keystore>
      <secret>password</secret>
      </tls>
      <connectiontimeout>1200</connectiontimeout>
      <connectionLimit> 0 </connectionLimit>
      <connectionLimitPerIP> 0 </connectionLimitPerIP>
      <handlerchain enableJmx="true">
      <handler class="org.apache.james.pop3server.core.CoreCmdHandlerLoader"/>
      </handlerchain>
      </pop3server>

      In smtpserver.xml I have identical tls section.

      When I connect to pop3:

      • CAPA command does not return anything about TLS,
      • STLS command gives ERR
      • STARTTLS command gives ERR.

      To check if the keystore, password etc. are correct, I am checking against SMTP server, and:

      • EHLO response includes 250-STARTTLS
      • STARTTLS response is 220 2.0.0 Ready to start TLS

      I do not see anything suspicious in the logs.

        Attachments

          Activity

            People

            • Assignee:
              norman Norman Maurer
              Reporter:
              arusin Andrzej Rusin
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: