Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.1.0
    • Fix Version/s: 2.0.0.alpha1
    • Component/s: None
    • Labels:
      None
    • Environment:

      Eclipse 3.2 WinXP Java 5

      Description

      I can't find the debug information in the IvyConsole.

      I need it to investigate why Ivy doesn't find my stuff on my local repo.

      1. ASF.LICENSE.NOT.GRANTED--IVYDE-39.patch
        3 kB
        Eugene Goldfarb
      2. IVYDE-39-r595956.patch
        2 kB
        Nicolas Lalevée

        Issue Links

          Activity

          Maarten Coene added a comment -

          Same problem with Eclipse 3.2.1, windows 2000 and Java 1.4

          Maarten

          Xavier Hanin added a comment -

          I'm also investigating on this issue, and it seems that the problem is the same with eclipse 3.1. I think it's related to Ivy change itself, because now Message try to use ant task for logging, and this may cause the problem. I should have time this afternoon to investigate more and find a fix.

          For moving ivyde to svn, the problem is that IvyDE still uses a build which can be used only in jayasoft environment. So I have to adapt the build to a public environment, and I'll certainly also lose our internal continuous build with that. But this is something that needs to be done, so I hope I'll find enough motivation soon! It would really help the development, so I'll do my best.

          Xavier Hanin added a comment -

          I finally decided to take time to move IvyDE to SVN. The build is very basic for the moment, but it will help further contributions.

          Xavier Hanin added a comment -

          The problem was actually due to changes in Ivy, but it was possible to fix it in IvyDE only. Actually tools using Ivy in multiple threads need to set the IvyContext in each thread for Ivy to work properly. According to my tests the version I just checked in fix this problem.

          easyproglife added a comment -

          I downgraded to IveDE 1.0.3 and now the IvyConsole is full of details as expected

          I don't know what went wrong between versions but IvyDE 1.1.0 definitely doesn't outputs so much.

          I suspect that some caching is used. I have to look at the source code.

          Xavier, why isn't it a simple task to publish the IvyDE SVN as Ivy and IvyCruise? The public SVN already exists. Right?

          Eugene Goldfarb added a comment -

          I am not able to reopen this issue, but it is still not fully fixed.
          Actually, even with IvyDE 1.2.0, there is still a lot of logging going to standard out/error. There were a few spots where new threads are created but the console is not bound to the IvyContext. I made the necessary changes and now everything is going to the ivy console. I also cleaned up exception handlers which were just doing e.printStackTrace(). Don't we all love Eclipse's auto-generated catch blocks?

          Patch file against IvyDE 1.2.0 (SVN rev. 605) is attached. Please consider adding to next release.

          Xavier Hanin added a comment -

          Thanks for your patch and your investigations! I reopen the issue, will apply the patch soon.

          Nicolas Lalevée added a comment -

          Patch updated against the trunk

          Xavier Hanin added a comment -

          With the latest trunk version and the new logging API, I don't think the context/logging mismatch which you nicely fixed can still happen, since the IvyConsole is now registered as a default logger to which all Ivy operations should finally delegate their logging work.

          So I think this issue can be marked as resolved, but I haven't enough time to make more tests right now, so I let it open for a while. If you see any problem with the trunk version, feel free to comment on this issue or on the dev list.

          Nicolas Lalevée added a comment -

          well, at least works for me

          Nicolas Lalevée added a comment -

          There were no complain since a while, so I assume it is fixed.


            People

            • Assignee:
              Xavier Hanin
              Reporter:
              easyproglife
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development