IvyDE
  1. IvyDE
  2. IVYDE-335

IvyDERuntimeClasspathResolver does not resolve entries that don't implement IRuntimeClasspathEntry2

    Details

      Description

      IvyDERuntimeClasspathResolver.resolveRuntimeClasspathEntry(IRuntimeClasspathEntry entry, IJavaProject project) does not resolve the provided IRuntimeClasspathEntry if it does not implement IRuntimeClasspathEntry2. This leads to GWT issue 6225 and probably other issues.

      1. ivyde.patch
        2 kB
        Nathan Summers

        Activity

        Nathan Summers created issue -
        Nathan Summers added a comment -

        Fix for resolver.

        Nathan Summers made changes -
        Field Original Value New Value
        Attachment ivyde.patch [ 12568446 ]
        Nathan Summers made changes -
        Description IvyDERuntimeClasspathResolver.resolveRuntimeClasspathEntry(IRuntimeClasspathEntry entry, IJavaProject project) does not resolve the provided IRuntimeClasspathEntry if it does not implement IRuntimeClasspathEntry. This leads to [GWT issue 6225|http://code.google.com/p/google-web-toolkit/issues/detail?id=6225] and probably other issues. IvyDERuntimeClasspathResolver.resolveRuntimeClasspathEntry(IRuntimeClasspathEntry entry, IJavaProject project) does not resolve the provided IRuntimeClasspathEntry if it does not implement IRuntimeClasspathEntry2. This leads to [GWT issue 6225|http://code.google.com/p/google-web-toolkit/issues/detail?id=6225] and probably other issues.
        Stephen Kestle added a comment -

        I believe this is also the cause for infinitest's ivy classpath issue

        Nicolas Lalevée added a comment -

        I have applied the patch. Thank you very much.

        Nicolas Lalevée made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Assignee Nicolas Lalevée [ hibou ]
        Fix Version/s trunk [ 12320552 ]
        Resolution Fixed [ 1 ]
        Daniel Bonniot de Ruisselet added a comment -

        Thanks for the fix! What version contains the fix?

        Stephen Kestle added a comment -

        Not sure if it's related, but infinitest cannot see ivy classpaths exported from another project. This forces me to duplicate dependencies in different projects in ivy.

        Is this something that would be technically related to this issue?

        Daniel Bonniot de Ruisselet: Clicking on "trunk" shows us that the previous release is 2.2.0.beta1 - presumably this will be in 2.2.0. You can get it from the nightly update site if you want to live on the wild side

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        47d 18m 1 Nicolas Lalevée 26/Mar/13 19:55

          People

          • Assignee:
            Nicolas Lalevée
            Reporter:
            Nathan Summers
          • Votes:
            4 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development