IvyDE
  1. IvyDE
  2. IVYDE-313

org.eclipse.swt.SWTException: Invalid thread access with Eclipse Juno

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.2.0.beta1
    • Fix Version/s: 2.2.0.final
    • Component/s: ivy editor
    • Labels:
      None
    • Environment:

      Win32, Eclipse 4.2

      Description

      There is an org.eclipse.swt.SWTException: Invalid thread access with Eclispe 4.2. The StackTrace is:

      eclipse.buildId=I20120608-1400
      java.version=1.6.0_29
      java.vendor=Sun Microsystems Inc.
      BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=de_DE
      Framework arguments: -product org.eclipse.platform.ide
      Command-line arguments: -product org.eclipse.platform.ide -data C:\devenv/../server_runtime2 -dev file:C:/devenv/.metadata/.plugins/org.eclipse.pde.core/Launch Runtime Eclipse/dev.properties -os win32 -ws win32 -arch x86

      !ENTRY org.apache.ivyde.eclipse 1 0 2012-07-04 17:22:48.748
      !MESSAGE starting IvyDE plugin

      !ENTRY org.eclipse.osgi 4 0 2012-07-04 17:22:48.757
      !MESSAGE An error occurred while automatically activating bundle org.apache.ivyde.eclipse (3113).
      !STACK 0
      org.osgi.framework.BundleException: Exception in org.apache.ivyde.eclipse.IvyPlugin.start() of bundle org.apache.ivyde.eclipse.
      at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:734)
      at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:683)
      at org.eclipse.osgi.framework.internal.core.BundleHost.startWorkeIvyr(BundleHost.java:381)
      at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:300)
      at org.eclipse.osgi.framework.util.SecureAction.start(SecureAction.java:440)
      at org.eclipse.osgi.internal.loader.BundleLoader.setLazyTrigger(BundleLoader.java:263)
      at org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter.postFindLocalClass(EclipseLazyStarter.java:107)
      at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClass(ClasspathManager.java:469)
      at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.findLocalClass(DefaultClassLoader.java:216)
      at org.eclipse.osgi.internal.loader.BundleLoader.findLocalClass(BundleLoader.java:395)
      at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:464)
      at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:421)
      at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:412)
      at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:107)
      at java.lang.ClassLoader.loadClass(Unknown Source)
      at org.eclipse.osgi.internal.loader.BundleLoader.loadClass(BundleLoader.java:340)
      at org.eclipse.osgi.framework.internal.core.BundleHost.loadClass(BundleHost.java:229)
      at org.eclipse.osgi.framework.internal.core.AbstractBundle.loadClass(AbstractBundle.java:1212)
      at org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI.createExecutableExtension(RegistryStrategyOSGI.java:174)
      at org.eclipse.core.internal.registry.ExtensionRegistry.createExecutableExtension(ExtensionRegistry.java:905)
      at org.eclipse.core.internal.registry.ConfigurationElement.createExecutableExtension(ConfigurationElement.java:243)
      at org.eclipse.core.internal.registry.ConfigurationElementHandle.createExecutableExtension(ConfigurationElementHandle.java:55)
      at org.eclipse.jdt.core.JavaCore.computeClasspathContainerInitializer(JavaCore.java:3175)
      at org.eclipse.jdt.core.JavaCore.getClasspathContainerInitializer(JavaCore.java:3151)
      at org.eclipse.jdt.internal.core.JavaModelManager.initializeContainer(JavaModelManager.java:2824)
      at org.eclipse.jdt.internal.core.JavaModelManager.getClasspathContainer(JavaModelManager.java:1878)
      at org.eclipse.jdt.core.JavaCore.getClasspathContainer(JavaCore.java:3128)
      at org.eclipse.jdt.internal.core.JavaProject.resolveClasspath(JavaProject.java:2691)
      at org.eclipse.jdt.internal.core.JavaProject.resolveClasspath(JavaProject.java:2855)
      at org.eclipse.jdt.internal.core.JavaProject.getResolvedClasspath(JavaProject.java:1960)
      at org.eclipse.jdt.internal.core.JavaProject.computeExpandedClasspath(JavaProject.java:508)
      at org.eclipse.jdt.internal.core.JavaProject.getExpandedClasspath(JavaProject.java:1565)
      at org.eclipse.jdt.internal.core.builder.NameEnvironment.computeClasspathLocations(NameEnvironment.java:96)
      at org.eclipse.jdt.internal.core.builder.NameEnvironment.<init>(NameEnvironment.java:44)
      at org.eclipse.jdt.internal.core.builder.JavaBuilder.initializeBuilder(JavaBuilder.java:603)
      at org.eclipse.jdt.internal.core.builder.JavaBuilder.build(JavaBuilder.java:167)
      at org.eclipse.core.internal.events.BuildManager$2.run(BuildManager.java:728)
      at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
      at org.eclipse.core.internal.events.BuildManager.basicBuild(BuildManager.java:199)
      at org.eclipse.core.internal.events.BuildManager.basicBuild(BuildManager.java:239)
      at org.eclipse.core.internal.events.BuildManager$1.run(BuildManager.java:292)
      at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
      at org.eclipse.core.internal.events.BuildManager.basicBuild(BuildManager.java:295)
      at org.eclipse.core.internal.events.BuildManager.basicBuildLoop(BuildManager.java:351)
      at org.eclipse.core.internal.events.BuildManager.build(BuildManager.java:374)
      at org.eclipse.core.internal.events.AutoBuildJob.doBuild(AutoBuildJob.java:143)
      at org.eclipse.core.internal.events.AutoBuildJob.run(AutoBuildJob.java:241)
      at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
      Caused by: java.lang.ExceptionInInitializerError
      at org.apache.ivyde.eclipse.ui.editors.xml.ColorManager.rebind(ColorManager.java:107)
      at org.apache.ivyde.eclipse.ui.editors.xml.ColorManager.refreshFromStore(ColorManager.java:98)
      at org.apache.ivyde.eclipse.IvyPlugin.start(IvyPlugin.java:122)
      at org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(BundleContextImpl.java:711)
      at java.security.AccessController.doPrivileged(Native Method)
      at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:702)
      ... 47 more
      Caused by: org.eclipse.swt.SWTException: Invalid thread access
      at org.eclipse.swt.SWT.error(SWT.java:4361)
      at org.eclipse.swt.SWT.error(SWT.java:4276)
      at org.eclipse.swt.SWT.error(SWT.java:4247)
      at org.eclipse.swt.widgets.Display.error(Display.java:1258)
      at org.eclipse.swt.widgets.Display.checkDevice(Display.java:764)
      at org.eclipse.swt.widgets.Display.getSystemFont(Display.java:2459)
      at org.eclipse.jface.preference.PreferenceConverter.<clinit>(PreferenceConverter.java:84)
      ... 53 more
      Root exception:
      java.lang.ExceptionInInitializerError
      at org.apache.ivyde.eclipse.ui.editors.xml.ColorManager.rebind(ColorManager.java:107)
      at org.apache.ivyde.eclipse.ui.editors.xml.ColorManager.refreshFromStore(ColorManager.java:98)
      at org.apache.ivyde.eclipse.IvyPlugin.start(IvyPlugin.java:122)
      at org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(BundleContextImpl.java:711)
      at java.security.AccessController.doPrivileged(Native Method)
      at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:702)
      at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:683)
      at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:381)
      at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:300)
      at org.eclipse.osgi.framework.util.SecureAction.start(SecureAction.java:440)
      at org.eclipse.osgi.internal.loader.BundleLoader.setLazyTrigger(BundleLoader.java:263)
      at org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter.postFindLocalClass(EclipseLazyStarter.java:107)
      at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClass(ClasspathManager.java:469)
      at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.findLocalClass(DefaultClassLoader.java:216)
      at org.eclipse.osgi.internal.loader.BundleLoader.findLocalClass(BundleLoader.java:395)
      at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:464)
      at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:421)
      at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:412)
      at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:107)
      at java.lang.ClassLoader.loadClass(Unknown Source)
      at org.eclipse.osgi.internal.loader.BundleLoader.loadClass(BundleLoader.java:340)
      at org.eclipse.osgi.framework.internal.core.BundleHost.loadClass(BundleHost.java:229)
      at org.eclipse.osgi.framework.internal.core.AbstractBundle.loadClass(AbstractBundle.java:1212)
      at org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI.createExecutableExtension(RegistryStrategyOSGI.java:174)
      at org.eclipse.core.internal.registry.ExtensionRegistry.createExecutableExtension(ExtensionRegistry.java:905)
      at org.eclipse.core.internal.registry.ConfigurationElement.createExecutableExtension(ConfigurationElement.java:243)
      at org.eclipse.core.internal.registry.ConfigurationElementHandle.createExecutableExtension(ConfigurationElementHandle.java:55)
      at org.eclipse.jdt.core.JavaCore.computeClasspathContainerInitializer(JavaCore.java:3175)
      at org.eclipse.jdt.core.JavaCore.getClasspathContainerInitializer(JavaCore.java:3151)
      at org.eclipse.jdt.internal.core.JavaModelManager.initializeContainer(JavaModelManager.java:2824)
      at org.eclipse.jdt.internal.core.JavaModelManager.getClasspathContainer(JavaModelManager.java:1878)
      at org.eclipse.jdt.core.JavaCore.getClasspathContainer(JavaCore.java:3128)
      at org.eclipse.jdt.internal.core.JavaProject.resolveClasspath(JavaProject.java:2691)
      at org.eclipse.jdt.internal.core.JavaProject.resolveClasspath(JavaProject.java:2855)
      at org.eclipse.jdt.internal.core.JavaProject.getResolvedClasspath(JavaProject.java:1960)
      at org.eclipse.jdt.internal.core.JavaProject.computeExpandedClasspath(JavaProject.java:508)
      at org.eclipse.jdt.internal.core.JavaProject.getExpandedClasspath(JavaProject.java:1565)
      at org.eclipse.jdt.internal.core.builder.NameEnvironment.computeClasspathLocations(NameEnvironment.java:96)
      at org.eclipse.jdt.internal.core.builder.NameEnvironment.<init>(NameEnvironment.java:44)
      at org.eclipse.jdt.internal.core.builder.JavaBuilder.initializeBuilder(JavaBuilder.java:603)
      at org.eclipse.jdt.internal.core.builder.JavaBuilder.build(JavaBuilder.java:167)
      at org.eclipse.core.internal.events.BuildManager$2.run(BuildManager.java:728)
      at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
      at org.eclipse.core.internal.events.BuildManager.basicBuild(BuildManager.java:199)
      at org.eclipse.core.internal.events.BuildManager.basicBuild(BuildManager.java:239)
      at org.eclipse.core.internal.events.BuildManager$1.run(BuildManager.java:292)
      at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
      at org.eclipse.core.internal.events.BuildManager.basicBuild(BuildManager.java:295)
      at org.eclipse.core.internal.events.BuildManager.basicBuildLoop(BuildManager.java:351)
      at org.eclipse.core.internal.events.BuildManager.build(BuildManager.java:374)
      at org.eclipse.core.internal.events.AutoBuildJob.doBuild(AutoBuildJob.java:143)
      at org.eclipse.core.internal.events.AutoBuildJob.run(AutoBuildJob.java:241)
      at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
      Caused by: org.eclipse.swt.SWTException: Invalid thread access
      at org.eclipse.swt.SWT.error(SWT.java:4361)
      at org.eclipse.swt.SWT.error(SWT.java:4276)
      at org.eclipse.swt.SWT.error(SWT.java:4247)
      at org.eclipse.swt.widgets.Display.error(Display.java:1258)
      at org.eclipse.swt.widgets.Display.checkDevice(Display.java:764)
      at org.eclipse.swt.widgets.Display.getSystemFont(Display.java:2459)
      at org.eclipse.jface.preference.PreferenceConverter.<clinit>(PreferenceConverter.java:84)
      ... 53 more

        Issue Links

          Activity

          Carsten Pfeiffer added a comment -

          Whoops, sorry for temporarily adding the patch from IVYDE-351 here – the new Jira is a little weird. Removed the patch again.


            People

            • Assignee:
              Nicolas Lalevée
              Reporter:
              Marcel Wagner
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development