IvyDE
  1. IvyDE
  2. IVYDE-218

Ivy settings file cannot be loaded via http url

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.0.final
    • Fix Version/s: 2.1.0
    • Component/s: classpath container
    • Labels:
      None
    • Environment:

      Eclipse SDK Version: 3.5.1 (64 bit), Windows 7 (64 bit)

      Description

      How to reproduce:

      The Ivy settings file:

      myivysettings.xml
      <!-- This is a copy of the ivy-2.1.0.jar/org/apache/ivy/core/settings/ivyconf.xml -->
      <ivysettings>
        <settings defaultResolver="default" /> 
        <include url="${ivy.default.settings.dir}/ivysettings-public.xml" /> 
        <include url="${ivy.default.settings.dir}/ivysettings-shared.xml" /> 
        <include url="${ivy.default.settings.dir}/ivysettings-local.xml" /> 
        <include url="${ivy.default.settings.dir}/ivysettings-main-chain.xml" /> 
        <include url="${ivy.default.settings.dir}/ivysettings-default-chain.xml" /> 
      </ivysettings>
      

      is uploaded to my webserver: http://lesc.se/ivy/myivysettings.xml

      Create a new Java project in Eclipse: "ivyde-bug"

      Add a simple ivy.xml file:

      ivy.xml
      <ivy-module version="2.0">
        <info organisation="se.lesc" module="ivybug" revision="1.0" /> 
      </ivy-module>
      

      In the Navigator view right click on ivy.xml and select "Add Ivy library...".
      Check the checkbox "Enable project specific settings"
      Enter the URL in "Ivy settings path:": http://lesc.se/ivy/myivysettings.xml
      Press "Finish".

      Actual:
      An error message is displayed:

      Error while resolving the ivy instance for ivy.xml in 'ivyde-bug':
        The Ivy settings file 'project:///ivy/myivysettings.xml' cannot be found
      

      Expected:
      The ivy settings on should be downloaded from the webserver and used.

        Activity

        Lennart Schedin added a comment -

        I guess that the problem is in IvyClasspathContainerConfiguration.readOldIvySettings(). This method has not been created to account for a http://.

        It could be possible that IVYDE-94 caused this problem.


          People

          • Assignee:
            Nicolas Lalevée
            Reporter:
            Lennart Schedin
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development