Uploaded image for project: 'Ivy'
  1. Ivy
  2. IVY-992

Ivy retrieve does not honor validate="false" from ivysettings

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.0-RC2, 2.0
    • Fix Version/s: 2.1.0-RC1
    • Component/s: Ant
    • Labels:
      None

      Description

      I tested this against rc2 and current trunk.

      If you call <ivy:retrieve> and one of the modules to retireve contains custom attributes within the default namespace ivy fails, although the ivysetting have the validate flag set to false.

      Howto Reproduce:
      Download the zip file an extract the files. Put an ivy jar in the same directory or change the path withing build.xml.
      run 'ant publish'. Afterwards run 'ant retrieve'. The retrieve fails.

      1. ivybug.zip
        1 kB
        Martin Eigenbrodt

        Activity

        Hide
        martineigenbrodt Martin Eigenbrodt added a comment -

        Files to reproduce the bug

        Show
        martineigenbrodt Martin Eigenbrodt added a comment - Files to reproduce the bug
        Hide
        maartenc Maarten Coene added a comment -

        I could reproduce it with 2.0 release

        Show
        maartenc Maarten Coene added a comment - I could reproduce it with 2.0 release
        Hide
        maartenc Maarten Coene added a comment -

        Fixed the problem (and added junit test) in SVN trunk.

        Thanks for the report!
        Maarten

        Show
        maartenc Maarten Coene added a comment - Fixed the problem (and added junit test) in SVN trunk. Thanks for the report! Maarten

          People

          • Assignee:
            maartenc Maarten Coene
            Reporter:
            martineigenbrodt Martin Eigenbrodt
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development