Ivy
  1. Ivy
  2. IVY-987

Error message: "impossible to get artifacts when data has not been loaded" , on certain modules only

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 2.1.0-RC1
    • Component/s: None
    • Labels:
      None
    • Environment:

      ubuntu 8.04, java .1.6.0_06 Java HotSpot(TM) Client VM, calling external ant 1.7 from netbeans 6.1 IDE, ivy ant task in ants home lib dir

      Description

      I found a similiar post here:

      http://www.mail-archive.com/ivy-user@ant.apache.org/msg01766.html

      Everything worked fine with 2.0.0 beta .

      >
      > It's just a simple test and dom4j seems to cause the problem with
      > standard ivysettings :

      > <dependencies>
      > <dependency org="dom4j" name="dom4j" rev="1.6.1"/>
      > <dependency org="log4j" name="log4j" rev="1.2.9"/>
      > <dependency org="junit" name="junit" rev="4.5"/>
      > </dependencies>
      > </ivy-module>

      Removing dom4j makes it work again.
      So I dont know, is it dom4j or ivy causing the problem?

      > output:
      >
      > init:
      > deps-jar:
      > ivy-retrieve:
      > No ivy:settings found for the default reference 'ivy.instance'. A
      > default instance will be used
      > no settings file found, using default...
      > :: loading settings :: url =
      > jar:file:/home/kostja/VZG/soa-workarea-ref/tools/ant/lib/ivy-2.0.0-rc2.jar!/org/apache/ivy/core/settings/ivysettings.xml
      > :: resolving dependencies :: gbv.de#test;working@myhome
      > confs: [default]
      > found dom4j#dom4j;1.6.1 in public
      > found xml-apis#xml-apis;1.0.b2 in public
      > found jaxme#jaxme-api;0.3 in public
      > found jaxen#jaxen;1.1-beta-6 in public
      > found jdom#jdom;1.0 in public
      > found xerces#xmlParserAPIs;2.6.2 in public
      > found xerces#xercesImpl;2.6.2 in public
      > found xom#xom;1.0b3 in public
      > found com.ibm.icu#icu4j;2.6.1 in public
      > found org.ccil.cowan.tagsoup#tagsoup;0.9.7 in public
      > found msv#xsdlib;20030807 in public
      > found msv#relaxngDatatype;20030807 in public
      > found pull-parser#pull-parser;2 in public
      > found xpp3#xpp3;1.1.3.3 in public
      > found stax#stax-api;1.0 in public
      > found log4j#log4j;1.2.9 in public
      > found junit#junit;4.5 in public
      >
      > :: problems summary ::
      > :::: ERRORS
      > impossible to get artifacts when data has not been loaded.
      > IvyNode = xalan#xalan;2.5.1
      > :: USE VERBOSE OR DEBUG MESSAGE LEVEL FOR MORE DETAILS
      > /home/kostja/VZG/soa-workarea-ref/projects/Test/build.xml:15: impossible
      > to resolve dependencies:
      > java.lang.IllegalStateException: impossible to get artifacts
      > when data has not been loaded. IvyNode = xalan#xalan;2.5.1
      > BUILD FAILED (total time: 0 seconds)

        Issue Links

          Activity

          Jack Frosch added a comment -

          This was happening for me using Ivy 2.0.0 when a hsqldb transitive dependency was encountered during resolve. Tried 2.1.0-rc1 and it worked fine. Thanks

          rednix added a comment -

          Thank you for fixing this one! At least for the artifact org.apache.struts#struts2-spring-plugin;2.1.6 I can confirm that it's working with Ivy 2.1.0-rc1 again.

          Maarten Coene added a comment -

          I couldn't create a junit test neither.
          I did try, but had too little time to setup an environment which reproduced the problem.

          So I'll mark this as fixed for the next release. Please reopen if you still encounter problems.

          Maarten Coene added a comment -

          Great job Xavier, I'll try to create a junit test.

          Xavier Hanin added a comment -

          I've investigated using the dependencies description provided here, I've reproduced and fixed the bug (at least in this case). I haven't changed how forced dependencies are handled in conflict managers, so there may still need some investigation in this area, I'm not really sure. What I've changed is just the way * configurations is resolved during conflict management, to be consistent with how they are handled in fetchDependencies. I haven't had time to add a junit test, so I don't mark the bug resolved now. I don't think I'll have much time in the coming weeks, so if someone can submit or commit a junit test it would be really nice. Otherwise we may also decide to mark this as resolved without a unit test to release 2.0.1.

          Xavier Hanin added a comment -

          Sorry for the delay on this issue, too hard to find free time ATM. Maarten (or anybody), maybe you already have a unit test reproducing the problem? It would help me to investigate and hopefully fix this bug.

          Carlo de Wolf added a comment -

          It looks like dependencies from non-public profiles are not being excluded by default, so this:
          <ivy-module version="2.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
          xsi:noNamespaceSchemaLocation="http://ant.apache.org/ivy/schemas/ivy.xsd">
          <info organisation="org.jboss.ejb3" module="jboss-ejb3-ivy"/>
          <dependencies>
          <dependency org="org.apache.ivy" name="ivy" rev="2.0.0"/>
          </dependencies>
          </ivy-module>
          fails with:
          /home/carlo/work/ejb3/ivy/build.xml:14: impossible to resolve dependencies:
          java.lang.IllegalStateException: impossible to get artifacts when data has not been loaded. IvyNode = junit#junit;3.8.2

          While this works out fine:
          <ivy-module version="2.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
          xsi:noNamespaceSchemaLocation="http://ant.apache.org/ivy/schemas/ivy.xsd">
          <info organisation="org.jboss.ejb3" module="jboss-ejb3-ivy"/>
          <dependencies>
          <dependency org="org.apache.ivy" name="ivy" rev="2.0.0" conf="default->compile"/>
          </dependencies>
          </ivy-module>

          Xavier Hanin added a comment -

          I'll try to find some time, but I'm currently overbooked with my job, so I can't promise anything, at least in the coming weeks...

          Maarten Coene added a comment -

          I didn't find a solution to the problem yet, although it's easy to reproduce.

          I tried to modify the LatestConflictManager to handle the situation where more than 1 revision of the same module is forced, but it's not that easy because each module can have more dependency-descriptors and is maybe isn't forced in all configurations... After modifying the LatestConflictManager, some of the junit tests started to fail (but maybe the tests are wrong?). The problem is that I don't have enough knowledge of this part of Ivy to understand exactly what's going on here, Xavier: could you also take a look at it if you have some time?

          rednix added a comment -

          Any news on this issue? Sorry to be impatient on this... but if I can help to make some progress on this (be it testing a trunk version or anything else) just let me know.
          The pom of org.apache.struts#struts2-spring-plugin is as follows:

          <project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
          <modelVersion>4.0.0</modelVersion>
          <parent>
          <groupId>org.apache.struts</groupId>
          <artifactId>struts2-plugins</artifactId>
          <version>2.1.6</version>
          </parent>
          <groupId>org.apache.struts</groupId>
          <artifactId>struts2-spring-plugin</artifactId>
          <packaging>jar</packaging>
          <name>Struts 2 Spring Plugin</name>

          <scm>
          <connection>scm:svn:http://svn.apache.org/repos/asf/struts/struts2/tags/STRUTS_2_1_6/plugins/spring</connection>
          <developerConnection>scm:svn:https://svn.apache.org/repos/asf/struts/struts2/tags/STRUTS_2_1_6/plugins/spring</developerConnection>
          <url>http://svn.apache.org/viewcvs.cgi/struts/struts2/tags/STRUTS_2_1_6/plugins/spring</url>
          </scm>

          <properties>
          <spring.version>2.5.3</spring.version>
          </properties>

          <dependencies>
          <dependency>
          <groupId>org.springframework</groupId>
          <artifactId>spring-beans</artifactId>
          <version>$

          {spring.version}</version>
          </dependency>

          <dependency>
          <groupId>org.springframework</groupId>
          <artifactId>spring-core</artifactId>
          <version>${spring.version}

          </version>
          </dependency>

          <dependency>
          <groupId>org.springframework</groupId>
          <artifactId>spring-context</artifactId>
          <version>$

          {spring.version}</version>
          </dependency>

          <dependency>
          <groupId>org.springframework</groupId>
          <artifactId>spring-web</artifactId>
          <version>${spring.version}

          </version>
          </dependency>

          <dependency>
          <groupId>org.springframework</groupId>
          <artifactId>spring-test</artifactId>
          <version>$

          {spring.version}

          </version>
          <scope>test</scope>
          </dependency>

          <dependency>
          <groupId>junit</groupId>
          <artifactId>junit</artifactId>
          <scope>test</scope>
          <version>3.8.2</version>
          </dependency>
          </dependencies>
          </project>

          Xavier Hanin added a comment -

          Maybe in this situation the conflict manager should resolve the conflict as if they were not forced. I mean, the conflict manager could first check if there is at least one revision being forced, if it is the case it ignores non forced revision and do its usual job with the forced revisions only.

          Does it make sense?

          Maarten Coene added a comment -

          The problem still exists in the 2.0.0 release.

          I think it is caused because all the dependencies defined in a pom are forced to the revision in the pom.
          It seems to me that the latest-revision ConflictManager doesn't handle the situation correctly when there is more than 1 forced version of the same module requested.

          Xavier: what should the conflict manager do in this situation?

          rednix added a comment - - edited

          It's most likely not dom4j - because I got the error with a different package as well:

          BUILD FAILED
          C:\workspaces\eclipseGanymede\TEST IVY\build.xml:125: impossible to install org.apache.struts#struts2-spring-plugin;2.1.6: java.lang.IllegalStateException: impossible to get artifacts when data has not been loaded. IvyNode = org.springframework#spring-test;2.5.3
          at org.apache.ivy.ant.IvyInstall.doExecute(IvyInstall.java:109)
          at org.apache.ivy.ant.IvyTask.execute(IvyTask.java:277)
          at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
          at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
          at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
          at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
          at java.lang.reflect.Method.invoke(Method.java:585)
          at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:105)
          at org.apache.tools.ant.Task.perform(Task.java:348)
          at org.apache.tools.ant.Target.execute(Target.java:357)
          at org.apache.tools.ant.Target.performTasks(Target.java:385)
          at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1329)
          at org.apache.tools.ant.Project.executeTarget(Project.java:1298)
          at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
          at org.eclipse.ant.internal.ui.antsupport.EclipseDefaultExecutor.executeTargets(EclipseDefaultExecutor.java:32)
          at org.apache.tools.ant.Project.executeTargets(Project.java:1181)
          at org.eclipse.ant.internal.ui.antsupport.InternalAntRunner.run(InternalAntRunner.java:423)
          at org.eclipse.ant.internal.ui.antsupport.InternalAntRunner.main(InternalAntRunner.java:137)
          Caused by: java.lang.IllegalStateException: impossible to get artifacts when data has not been loaded. IvyNode = org.springframework#spring-test;2.5.3
          at org.apache.ivy.core.resolve.IvyNode.getArtifacts(IvyNode.java:756)
          at org.apache.ivy.core.resolve.IvyNode.getSelectedArtifacts(IvyNode.java:733)
          at org.apache.ivy.core.report.ResolveReport.setDependencies(ResolveReport.java:235)
          at org.apache.ivy.core.install.InstallEngine.install(InstallEngine.java:120)
          at org.apache.ivy.Ivy.install(Ivy.java:526)
          at org.apache.ivy.ant.IvyInstall.doExecute(IvyInstall.java:101)
          ... 17 more
          — Nested Exception —
          java.lang.IllegalStateException: impossible to get artifacts when data has not been loaded. IvyNode = org.springframework#spring-test;2.5.3
          at org.apache.ivy.core.resolve.IvyNode.getArtifacts(IvyNode.java:756)
          at org.apache.ivy.core.resolve.IvyNode.getSelectedArtifacts(IvyNode.java:733)
          at org.apache.ivy.core.report.ResolveReport.setDependencies(ResolveReport.java:235)
          at org.apache.ivy.core.install.InstallEngine.install(InstallEngine.java:120)
          at org.apache.ivy.Ivy.install(Ivy.java:526)
          at org.apache.ivy.ant.IvyInstall.doExecute(IvyInstall.java:101)
          at org.apache.ivy.ant.IvyTask.execute(IvyTask.java:277)
          at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
          at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
          at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
          at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
          at java.lang.reflect.Method.invoke(Method.java:585)
          at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:105)
          at org.apache.tools.ant.Task.perform(Task.java:348)
          at org.apache.tools.ant.Target.execute(Target.java:357)
          at org.apache.tools.ant.Target.performTasks(Target.java:385)
          at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1329)
          at org.apache.tools.ant.Project.executeTarget(Project.java:1298)
          at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
          at org.eclipse.ant.internal.ui.antsupport.EclipseDefaultExecutor.executeTargets(EclipseDefaultExecutor.java:32)
          at org.apache.tools.ant.Project.executeTargets(Project.java:1181)
          at org.eclipse.ant.internal.ui.antsupport.InternalAntRunner.run(InternalAntRunner.java:423)
          at org.eclipse.ant.internal.ui.antsupport.InternalAntRunner.main(InternalAntRunner.java:137)

          Even if I resolve org.springframework#spring-test;2.5.3 before on its own - it still don't work.

          The bug is still there in the proposed final build.


            People

            • Assignee:
              Xavier Hanin
              Reporter:
              K. Rekk
            • Votes:
              3 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development