Ivy
  1. Ivy
  2. IVY-977

error message is not clear when specifying an invalid value for checksums

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0.0-beta-2
    • Fix Version/s: 2.1.0-RC1
    • Component/s: None
    • Labels:
      None
    • Environment:

      Description

      When setting the property ivy.checksums in a property file, each publish operation failed with the following error:

      publish:package:
      [echo] >>> Publishing main package to local repository
      [ivy:publish] :: publishing :: com.bene_system#common2-message
      [ivy:publish] publish aborted: deleted R:\ext950_r_costa_INCEPTION_int_dn\devtools\oobs\var\my_local_repo\com.bene_system\common2-message\20081125153702.part

      BUILD FAILED
      R:\ext950_r_costa_INCEPTION_int_dn\devtools\oobs\oobs-java.xml:786: The following error occurred while executing this line:
      R:\ext950_r_costa_INCEPTION_int_dn\devtools\oobs\oobs-java.xml:787: impossible to publish artifacts for com.bene_system#common2-message;working@PO060001737: java.io.IOException: The filename, directory name, or volume label syntax is incorrect

      Total time: 3 seconds

      My ivysettings-file looked as follow:
      <ivysettings>
      <properties file="$

      {ivy.settings.dir}/var/default.properties"/>
      ....
      </ivysettings>

      In the property file default.properties ivy.checksums was defined as follows:
      ivy.checksums = ""

      Even when setting ivy.checksums="md5, sha1" or any other value, the build still failed.

      I then tried to set the property directly in the ivysettings file:
      <ivysettings>
      <properties file="${ivy.settings.dir}

      /var/default.properties"/>
      <property name="ivy.checksums" value="" />

      And that worked fine.
      So there is a workaround, but it took me a very long time to find out the root cause of this failure. So I propose that at least this is documented somewhere.

      1. ant_stdout.txt
        21 kB
        Marc De Boeck

        Activity

        Maarten Coene added a comment -

        Marc,

        just to be sure, but did you specify the ivy.checksums property in the properties file without the double quotest like this?

        ivy.checksums=
        
        Marc De Boeck added a comment -

        Maarten,
        No, I did put double quotes.
        I tried the following settings in my property file (only one at a time of course):

        ivy.checksums=""
        ivy.checksums="md5"
        ivy.checsums="sha1, md5"
        

        In all cases, I had the same BUILD FAILED error.

        As soon as I comment out the definition of ivy.checksums in my properties file, the publish is successful. So it is very reproducable for me.
        By the way, I also have some other ivy-properties set in this properties file, and they don't cause any problems:
        e.g. my ivy.cache.dir and and ivy.validate are set in that file.
        Thanks,
        Marc

        Maarten Coene added a comment -

        Marc,

        can you give it a try without the double quotes?
        If that doesn't work, could you post the console log when running ant in debug mode (ant -d), together with your settings.xml and your properties file?

        Maarten

        Marc De Boeck added a comment -

        Hi Maarten,
        Sorry, I misunderstood your original question.
        You are right: I now did some tests without the quotes, and it worked.
        All of the three following options work:

        ivy.checksums=
        ivy.checksums=md5
        ivy.checksums=sha1, md5
        

        Actually, I should have seen this, because all other properties are also specified in the properties file without quotes.
        Don't know if it is possible to output a more meaningful error message for this ? Or to generate already an error when reading in the settings file ? Now all other ivy-tasks were executed fine (without any warning) and so I spent a long time investigating and changing the resolvers, looking at the stack trace, trying the find out why windows complained that the fileformat was invalid etc.

        Thanks a lot for your help.
        Marc

        Maarten Coene added a comment -

        I've updated the code in SVN trunk in an attempt to provide a more meaningfull error message.
        Could you give it a try to see if the message is more clear now?

        Marc De Boeck added a comment -

        Maarten,
        I am afraid I still have the same error message:
        [ivy:publish] :: Marc is publishing :: com.bene_system#common2-message
        [ivy:publish] publish aborted: deleted R:\ext950_r_costa_INCEPTION_int_dn\devtools\oobs\var\my_local_repo\com.bene_system\common2-message\C2.0\20081127150815.part

        BUILD FAILED
        R:\ext950_r_costa_INCEPTION_int_dn\devtools\oobs\oobs-java.xml:786: The following error occurred while executing this line:
        R:\ext950_r_costa_INCEPTION_int_dn\devtools\oobs\oobs-java.xml:787: impossible to publish artifacts for com.bene_system#common2-message#C2.0;working@PO060001737: java.io.IOException: The filename, directory name, or volume label syntax is incorrect

        I had first rebuilt ivy using SVN-revision 721019. I think I got the right version because the CHANGES.txt file included also this issue. I am also sure I have used the rebuilt ivy.jar (because I added "Marc is publishing" in the publish message).

        Anyhow, for me this issue is not so important. But if you would consider making another change, I don't mind retesting it.
        Marc

        Maarten Coene added a comment -

        Marc,

        Can you paste the stacktrace here when running ant in verbose mode (ant -v) ?

        Maarten

        Marc De Boeck added a comment -

        Below is the stacktrace. I'll also attach the stdout from ant as an attachment to this issue.

        R:\ext950_r_costa_INCEPTION_int_dn\costa\common2\mod\common2-message>cat ant_stderr.txt

        BUILD FAILED
        R:\ext950_r_costa_INCEPTION_int_dn\devtools\oobs\oobs-java.xml:786: The following error occurred while executing this line:
        R:\ext950_r_costa_INCEPTION_int_dn\devtools\oobs\oobs-java.xml:787: impossible to publish artifacts for com.bene_system#common2-message#C2.0;working@PO060001737: java.io.IOException: The filename, directory name, or volume label syntax is incorrect
        at org.apache.tools.ant.ProjectHelper.addLocationToBuildException(ProjectHelper.java:541)
        at org.apache.tools.ant.taskdefs.MacroInstance.execute(MacroInstance.java:394)
        at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
        at sun.reflect.GeneratedMethodAccessor2.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:585)
        at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:105)
        at org.apache.tools.ant.Task.perform(Task.java:348)
        at org.apache.tools.ant.Target.execute(Target.java:357)
        at org.apache.tools.ant.Target.performTasks(Target.java:385)
        at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1329)
        at org.apache.tools.ant.Project.executeTarget(Project.java:1298)
        at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
        at org.apache.tools.ant.Project.executeTargets(Project.java:1181)
        at org.apache.tools.ant.Main.runBuild(Main.java:698)
        at org.apache.tools.ant.Main.startAnt(Main.java:199)
        at org.apache.tools.ant.launch.Launcher.run(Launcher.java:257)
        at org.apache.tools.ant.launch.Launcher.main(Launcher.java:104)
        Caused by: R:\ext950_r_costa_INCEPTION_int_dn\devtools\oobs\oobs-java.xml:787: impossible to publish artifacts for com.bene_system#common2-message#C2.0;working@PO060001737: java.io.IOException: The filename, directory name, or volume label syntax is incorrect
        at org.apache.ivy.ant.IvyPublish.doExecute(IvyPublish.java:318)
        at org.apache.ivy.ant.IvyTask.execute(IvyTask.java:277)
        at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
        at sun.reflect.GeneratedMethodAccessor2.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:585)
        at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:105)
        at org.apache.tools.ant.Task.perform(Task.java:348)
        at org.apache.tools.ant.taskdefs.Sequential.execute(Sequential.java:62)
        at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
        at sun.reflect.GeneratedMethodAccessor2.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:585)
        at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:105)
        at org.apache.tools.ant.Task.perform(Task.java:348)
        at org.apache.tools.ant.taskdefs.MacroInstance.execute(MacroInstance.java:391)
        ... 16 more
        Caused by: java.io.IOException: The filename, directory name, or volume label syntax is incorrect
        at java.io.WinNTFileSystem.createFileExclusively(Native Method)
        at java.io.File.checkAndCreate(File.java:1345)
        at java.io.File.createTempFile(File.java:1434)
        at java.io.File.createTempFile(File.java:1471)
        at org.apache.ivy.plugins.resolver.RepositoryResolver.putChecksum(RepositoryResolver.java:228)
        at org.apache.ivy.plugins.resolver.RepositoryResolver.put(RepositoryResolver.java:222)
        at org.apache.ivy.plugins.resolver.RepositoryResolver.publish(RepositoryResolver.java:209)
        at org.apache.ivy.core.publish.PublishEngine.publish(PublishEngine.java:282)
        at org.apache.ivy.core.publish.PublishEngine.publish(PublishEngine.java:261)
        at org.apache.ivy.core.publish.PublishEngine.publish(PublishEngine.java:170)
        at org.apache.ivy.Ivy.publish(Ivy.java:600)
        at org.apache.ivy.ant.IvyPublish.doExecute(IvyPublish.java:299)
        ... 31 more
        — Nested Exception —
        R:\ext950_r_costa_INCEPTION_int_dn\devtools\oobs\oobs-java.xml:787: impossible to publish artifacts for com.bene_system#common2-message#C2.0;working@PO060001737: java.io.IOException: The filename, directory name, or volume label syntax is incorrect
        at org.apache.ivy.ant.IvyPublish.doExecute(IvyPublish.java:318)
        at org.apache.ivy.ant.IvyTask.execute(IvyTask.java:277)
        at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
        at sun.reflect.GeneratedMethodAccessor2.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:585)
        at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:105)
        at org.apache.tools.ant.Task.perform(Task.java:348)
        at org.apache.tools.ant.taskdefs.Sequential.execute(Sequential.java:62)
        at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
        at sun.reflect.GeneratedMethodAccessor2.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:585)
        at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:105)
        at org.apache.tools.ant.Task.perform(Task.java:348)
        at org.apache.tools.ant.taskdefs.MacroInstance.execute(MacroInstance.java:391)
        at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
        at sun.reflect.GeneratedMethodAccessor2.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:585)
        at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:105)
        at org.apache.tools.ant.Task.perform(Task.java:348)
        at org.apache.tools.ant.Target.execute(Target.java:357)
        at org.apache.tools.ant.Target.performTasks(Target.java:385)
        at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1329)
        at org.apache.tools.ant.Project.executeTarget(Project.java:1298)
        at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
        at org.apache.tools.ant.Project.executeTargets(Project.java:1181)
        at org.apache.tools.ant.Main.runBuild(Main.java:698)
        at org.apache.tools.ant.Main.startAnt(Main.java:199)
        at org.apache.tools.ant.launch.Launcher.run(Launcher.java:257)
        at org.apache.tools.ant.launch.Launcher.main(Launcher.java:104)
        Caused by: java.io.IOException: The filename, directory name, or volume label syntax is incorrect
        at java.io.WinNTFileSystem.createFileExclusively(Native Method)
        at java.io.File.checkAndCreate(File.java:1345)
        at java.io.File.createTempFile(File.java:1434)
        at java.io.File.createTempFile(File.java:1471)
        at org.apache.ivy.plugins.resolver.RepositoryResolver.putChecksum(RepositoryResolver.java:228)
        at org.apache.ivy.plugins.resolver.RepositoryResolver.put(RepositoryResolver.java:222)
        at org.apache.ivy.plugins.resolver.RepositoryResolver.publish(RepositoryResolver.java:209)
        at org.apache.ivy.core.publish.PublishEngine.publish(PublishEngine.java:282)
        at org.apache.ivy.core.publish.PublishEngine.publish(PublishEngine.java:261)
        at org.apache.ivy.core.publish.PublishEngine.publish(PublishEngine.java:170)
        at org.apache.ivy.Ivy.publish(Ivy.java:600)
        at org.apache.ivy.ant.IvyPublish.doExecute(IvyPublish.java:299)
        ... 31 more
        — Nested Exception —
        java.io.IOException: The filename, directory name, or volume label syntax is incorrect
        at java.io.WinNTFileSystem.createFileExclusively(Native Method)
        at java.io.File.checkAndCreate(File.java:1345)
        at java.io.File.createTempFile(File.java:1434)
        at java.io.File.createTempFile(File.java:1471)
        at org.apache.ivy.plugins.resolver.RepositoryResolver.putChecksum(RepositoryResolver.java:228)
        at org.apache.ivy.plugins.resolver.RepositoryResolver.put(RepositoryResolver.java:222)
        at org.apache.ivy.plugins.resolver.RepositoryResolver.publish(RepositoryResolver.java:209)
        at org.apache.ivy.core.publish.PublishEngine.publish(PublishEngine.java:282)
        at org.apache.ivy.core.publish.PublishEngine.publish(PublishEngine.java:261)
        at org.apache.ivy.core.publish.PublishEngine.publish(PublishEngine.java:170)
        at org.apache.ivy.Ivy.publish(Ivy.java:600)
        at org.apache.ivy.ant.IvyPublish.doExecute(IvyPublish.java:299)
        at org.apache.ivy.ant.IvyTask.execute(IvyTask.java:277)
        at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
        at sun.reflect.GeneratedMethodAccessor2.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:585)
        at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:105)
        at org.apache.tools.ant.Task.perform(Task.java:348)
        at org.apache.tools.ant.taskdefs.Sequential.execute(Sequential.java:62)
        at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
        at sun.reflect.GeneratedMethodAccessor2.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:585)
        at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:105)
        at org.apache.tools.ant.Task.perform(Task.java:348)
        at org.apache.tools.ant.taskdefs.MacroInstance.execute(MacroInstance.java:391)
        at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
        at sun.reflect.GeneratedMethodAccessor2.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:585)
        at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:105)
        at org.apache.tools.ant.Task.perform(Task.java:348)
        at org.apache.tools.ant.Target.execute(Target.java:357)
        at org.apache.tools.ant.Target.performTasks(Target.java:385)
        at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1329)
        at org.apache.tools.ant.Project.executeTarget(Project.java:1298)
        at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
        at org.apache.tools.ant.Project.executeTargets(Project.java:1181)
        at org.apache.tools.ant.Main.runBuild(Main.java:698)
        at org.apache.tools.ant.Main.startAnt(Main.java:199)
        at org.apache.tools.ant.launch.Launcher.run(Launcher.java:257)
        at org.apache.tools.ant.launch.Launcher.main(Launcher.java:104)

        Total time: 4 seconds

        Marc De Boeck added a comment -

        Attached also stdout output (when running ant -v)

        Maarten Coene added a comment -

        Thank you for the extra information.
        I've committed an additional fix into SVN trunk.
        Could you give it another try?

        thanks,
        Maarten

        Marc De Boeck added a comment -

        Tested this issue with revision 721304. I now get the right error-message, so I closed this issue (I suppose it's ok that I close it myself ?).

        For example, here is the output I got now when using the double quotes in a property file:

        ivy.checksums=""

        BUILD FAILED
        R:\ext950_r_costa_INCEPTION_int_dn\devtools\oobs\oobs-java.xml:786: The following error occurred while executing this line:
        R:\ext950_r_costa_INCEPTION_int_dn\devtools\oobs\oobs-java.xml:787: impossible to publish artifacts for com.bene_system#common2-message#C2.0;working@PO060001737: java.lang.IllegalArgumentException: Unknown checksum algorithm: ""

        ivy.checksums="md5" (set via the properties file)

        BUILD FAILED
        R:\ext950_r_costa_INCEPTION_int_dn\devtools\oobs\oobs-java.xml:786: The following error occurred while executing this line:
        R:\ext950_r_costa_INCEPTION_int_dn\devtools\oobs\oobs-java.xml:787: impossible to publish artifacts for com.bene_system#common2-message#C2.0;working@PO060001737: java.lang.IllegalArgumentException: Unknown checksum algorithm: "md5"

        Thanks !


          People

          • Assignee:
            Maarten Coene
            Reporter:
            Marc De Boeck
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development