Ivy
  1. Ivy
  2. IVY-783

Headless environment + SFTP resolver = java.awt.HeadlessException

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.0.0-beta-2
    • Fix Version/s: None
    • Component/s: Core
    • Labels:
      None
    • Environment:

      Mac OS X w/ Sun Java 1.6, Linux w/ Sun Java 1.6

      Description

      This used to work with prior versions of Ivy, but simply setting -Djava.awt.headless=true now causes the following exception. I'm using this from an automated build server, so I can't use Swing for publishing. I have SSH configured (supposedly) correctly, but can't confirm easily (it works from the command line, and used to work as well, without changes).

      /Users/mreynolds/Documents/Source Control/os.loopysoft.com/bojangles/build.xml:18: The following error occurred while executing this line:
      /Users/mreynolds/Documents/Source Control/os.loopysoft.com/bojangles/packages/ivy/build.xml:44: impossible to publish artifacts for com.loopysoft.os#bojangles;working@matt.hom3: java.awt.HeadlessException
      at org.apache.tools.ant.ProjectHelper.addLocationToBuildException(ProjectHelper.java:541)
      at org.apache.tools.ant.taskdefs.MacroInstance.execute(MacroInstance.java:394)
      at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
      at sun.reflect.GeneratedMethodAccessor2.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:105)
      at org.apache.tools.ant.Task.perform(Task.java:348)
      at org.apache.tools.ant.Target.execute(Target.java:357)
      at org.apache.tools.ant.Target.performTasks(Target.java:385)
      at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1329)
      at org.apache.tools.ant.Project.executeTarget(Project.java:1298)
      at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
      at org.apache.tools.ant.Project.executeTargets(Project.java:1181)
      at org.apache.tools.ant.Main.runBuild(Main.java:698)
      at org.apache.tools.ant.Main.startAnt(Main.java:199)
      at org.apache.tools.ant.launch.Launcher.run(Launcher.java:257)
      at org.apache.tools.ant.launch.Launcher.main(Launcher.java:104)
      Caused by: /Users/mreynolds/Documents/Source Control/os.loopysoft.com/bojangles/packages/ivy/build.xml:44: impossible to publish artifacts for com.loopysoft.os#bojangles;working@matt.hom3: java.awt.HeadlessException
      at org.apache.ivy.ant.IvyPublish.doExecute(IvyPublish.java:311)
      at org.apache.ivy.ant.IvyTask.execute(IvyTask.java:275)
      at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:105)
      at org.apache.tools.ant.Task.perform(Task.java:348)
      at org.apache.tools.ant.taskdefs.Sequential.execute(Sequential.java:62)
      at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
      at sun.reflect.GeneratedMethodAccessor2.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:105)
      at org.apache.tools.ant.Task.perform(Task.java:348)
      at org.apache.tools.ant.taskdefs.MacroInstance.execute(MacroInstance.java:391)
      ... 16 more
      Caused by: java.awt.HeadlessException
      at java.awt.GraphicsEnvironment.checkHeadless(GraphicsEnvironment.java:159)
      at java.awt.Window.<init>(Window.java:318)
      at java.awt.Frame.<init>(Frame.java:419)
      at java.awt.Frame.<init>(Frame.java:384)
      at javax.swing.SwingUtilities$SharedOwnerFrame.<init>(SwingUtilities.java:1671)
      at javax.swing.SwingUtilities.getSharedOwnerFrame(SwingUtilities.java:1748)
      at javax.swing.JOptionPane.getRootFrame(JOptionPane.java:1624)
      at javax.swing.JOptionPane.showOptionDialog(JOptionPane.java:836)
      at org.apache.ivy.util.CredentialsUtil.promptCredentials(CredentialsUtil.java:104)
      at org.apache.ivy.plugins.repository.ssh.SshCache$CfUserInfo.getPassphrase(SshCache.java:398)
      at com.jcraft.jsch.UserAuthPublicKey.start(Unknown Source)
      at com.jcraft.jsch.Session.connect(Unknown Source)
      at com.jcraft.jsch.Session.connect(Unknown Source)
      at org.apache.ivy.plugins.repository.ssh.SshCache.getSession(SshCache.java:326)
      at org.apache.ivy.plugins.repository.ssh.AbstractSshBasedRepository.getSession(AbstractSshBasedRepository.java:103)
      at org.apache.ivy.plugins.repository.sftp.SFTPRepository.getSftpChannel(SFTPRepository.java:223)
      at org.apache.ivy.plugins.repository.sftp.SFTPRepository.put(SFTPRepository.java:134)
      at org.apache.ivy.plugins.repository.AbstractRepository.put(AbstractRepository.java:130)
      at org.apache.ivy.plugins.resolver.RepositoryResolver.put(RepositoryResolver.java:197)
      at org.apache.ivy.plugins.resolver.RepositoryResolver.publish(RepositoryResolver.java:187)
      at org.apache.ivy.core.publish.PublishEngine.publish(PublishEngine.java:242)
      at org.apache.ivy.core.publish.PublishEngine.publish(PublishEngine.java:211)
      at org.apache.ivy.core.publish.PublishEngine.publish(PublishEngine.java:156)
      at org.apache.ivy.Ivy.publish(Ivy.java:606)
      at org.apache.ivy.ant.IvyPublish.doExecute(IvyPublish.java:289)
      ... 32 more
      — Nested Exception —
      /Users/mreynolds/Documents/Source Control/os.loopysoft.com/bojangles/packages/ivy/build.xml:44: impossible to publish artifacts for com.loopysoft.os#bojangles;working@matt.hom3: java.awt.HeadlessException
      at org.apache.ivy.ant.IvyPublish.doExecute(IvyPublish.java:311)
      at org.apache.ivy.ant.IvyTask.execute(IvyTask.java:275)
      at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:105)
      at org.apache.tools.ant.Task.perform(Task.java:348)
      at org.apache.tools.ant.taskdefs.Sequential.execute(Sequential.java:62)
      at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
      at sun.reflect.GeneratedMethodAccessor2.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:105)
      at org.apache.tools.ant.Task.perform(Task.java:348)
      at org.apache.tools.ant.taskdefs.MacroInstance.execute(MacroInstance.java:391)
      at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
      at sun.reflect.GeneratedMethodAccessor2.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:105)
      at org.apache.tools.ant.Task.perform(Task.java:348)
      at org.apache.tools.ant.Target.execute(Target.java:357)
      at org.apache.tools.ant.Target.performTasks(Target.java:385)
      at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1329)
      at org.apache.tools.ant.Project.executeTarget(Project.java:1298)
      at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
      at org.apache.tools.ant.Project.executeTargets(Project.java:1181)
      at org.apache.tools.ant.Main.runBuild(Main.java:698)
      at org.apache.tools.ant.Main.startAnt(Main.java:199)
      at org.apache.tools.ant.launch.Launcher.run(Launcher.java:257)
      at org.apache.tools.ant.launch.Launcher.main(Launcher.java:104)
      Caused by: java.awt.HeadlessException
      at java.awt.GraphicsEnvironment.checkHeadless(GraphicsEnvironment.java:159)
      at java.awt.Window.<init>(Window.java:318)
      at java.awt.Frame.<init>(Frame.java:419)
      at java.awt.Frame.<init>(Frame.java:384)
      at javax.swing.SwingUtilities$SharedOwnerFrame.<init>(SwingUtilities.java:1671)
      at javax.swing.SwingUtilities.getSharedOwnerFrame(SwingUtilities.java:1748)
      at javax.swing.JOptionPane.getRootFrame(JOptionPane.java:1624)
      at javax.swing.JOptionPane.showOptionDialog(JOptionPane.java:836)
      at org.apache.ivy.util.CredentialsUtil.promptCredentials(CredentialsUtil.java:104)
      at org.apache.ivy.plugins.repository.ssh.SshCache$CfUserInfo.getPassphrase(SshCache.java:398)
      at com.jcraft.jsch.UserAuthPublicKey.start(Unknown Source)
      at com.jcraft.jsch.Session.connect(Unknown Source)
      at com.jcraft.jsch.Session.connect(Unknown Source)
      at org.apache.ivy.plugins.repository.ssh.SshCache.getSession(SshCache.java:326)
      at org.apache.ivy.plugins.repository.ssh.AbstractSshBasedRepository.getSession(AbstractSshBasedRepository.java:103)
      at org.apache.ivy.plugins.repository.sftp.SFTPRepository.getSftpChannel(SFTPRepository.java:223)
      at org.apache.ivy.plugins.repository.sftp.SFTPRepository.put(SFTPRepository.java:134)
      at org.apache.ivy.plugins.repository.AbstractRepository.put(AbstractRepository.java:130)
      at org.apache.ivy.plugins.resolver.RepositoryResolver.put(RepositoryResolver.java:197)
      at org.apache.ivy.plugins.resolver.RepositoryResolver.publish(RepositoryResolver.java:187)
      at org.apache.ivy.core.publish.PublishEngine.publish(PublishEngine.java:242)
      at org.apache.ivy.core.publish.PublishEngine.publish(PublishEngine.java:211)
      at org.apache.ivy.core.publish.PublishEngine.publish(PublishEngine.java:156)
      at org.apache.ivy.Ivy.publish(Ivy.java:606)
      at org.apache.ivy.ant.IvyPublish.doExecute(IvyPublish.java:289)
      ... 32 more
      — Nested Exception —
      java.awt.HeadlessException
      at java.awt.GraphicsEnvironment.checkHeadless(GraphicsEnvironment.java:159)
      at java.awt.Window.<init>(Window.java:318)
      at java.awt.Frame.<init>(Frame.java:419)
      at java.awt.Frame.<init>(Frame.java:384)
      at javax.swing.SwingUtilities$SharedOwnerFrame.<init>(SwingUtilities.java:1671)
      at javax.swing.SwingUtilities.getSharedOwnerFrame(SwingUtilities.java:1748)
      at javax.swing.JOptionPane.getRootFrame(JOptionPane.java:1624)
      at javax.swing.JOptionPane.showOptionDialog(JOptionPane.java:836)
      at org.apache.ivy.util.CredentialsUtil.promptCredentials(CredentialsUtil.java:104)
      at org.apache.ivy.plugins.repository.ssh.SshCache$CfUserInfo.getPassphrase(SshCache.java:398)
      at com.jcraft.jsch.UserAuthPublicKey.start(Unknown Source)
      at com.jcraft.jsch.Session.connect(Unknown Source)
      at com.jcraft.jsch.Session.connect(Unknown Source)
      at org.apache.ivy.plugins.repository.ssh.SshCache.getSession(SshCache.java:326)
      at org.apache.ivy.plugins.repository.ssh.AbstractSshBasedRepository.getSession(AbstractSshBasedRepository.java:103)
      at org.apache.ivy.plugins.repository.sftp.SFTPRepository.getSftpChannel(SFTPRepository.java:223)
      at org.apache.ivy.plugins.repository.sftp.SFTPRepository.put(SFTPRepository.java:134)
      at org.apache.ivy.plugins.repository.AbstractRepository.put(AbstractRepository.java:130)
      at org.apache.ivy.plugins.resolver.RepositoryResolver.put(RepositoryResolver.java:197)
      at org.apache.ivy.plugins.resolver.RepositoryResolver.publish(RepositoryResolver.java:187)
      at org.apache.ivy.core.publish.PublishEngine.publish(PublishEngine.java:242)
      at org.apache.ivy.core.publish.PublishEngine.publish(PublishEngine.java:211)
      at org.apache.ivy.core.publish.PublishEngine.publish(PublishEngine.java:156)
      at org.apache.ivy.Ivy.publish(Ivy.java:606)
      at org.apache.ivy.ant.IvyPublish.doExecute(IvyPublish.java:289)
      at org.apache.ivy.ant.IvyTask.execute(IvyTask.java:275)
      at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:105)
      at org.apache.tools.ant.Task.perform(Task.java:348)
      at org.apache.tools.ant.taskdefs.Sequential.execute(Sequential.java:62)
      at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
      at sun.reflect.GeneratedMethodAccessor2.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:105)
      at org.apache.tools.ant.Task.perform(Task.java:348)
      at org.apache.tools.ant.taskdefs.MacroInstance.execute(MacroInstance.java:391)
      at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
      at sun.reflect.GeneratedMethodAccessor2.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:105)
      at org.apache.tools.ant.Task.perform(Task.java:348)
      at org.apache.tools.ant.Target.execute(Target.java:357)
      at org.apache.tools.ant.Target.performTasks(Target.java:385)
      at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1329)
      at org.apache.tools.ant.Project.executeTarget(Project.java:1298)
      at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
      at org.apache.tools.ant.Project.executeTargets(Project.java:1181)
      at org.apache.tools.ant.Main.runBuild(Main.java:698)
      at org.apache.tools.ant.Main.startAnt(Main.java:199)
      at org.apache.tools.ant.launch.Launcher.run(Launcher.java:257)
      at org.apache.tools.ant.launch.Launcher.main(Launcher.java:104)

        Activity

        Xavier Hanin added a comment -

        This may be related to IVY-734, which has been fixed in trunk. Could you try out the trunk version?

        Maarten Coene added a comment -

        Are you sure you did specify a password to connect to the SSH server?

        Xavier Hanin added a comment -

        I mark this as cannot reproduce since it seems we already fixed it in trunk. Please reopen with more details if you still have problem with trunk version.


          People

          • Assignee:
            Unassigned
            Reporter:
            Matt Reynolds
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development