Ivy
  1. Ivy
  2. IVY-429

ivy.revision property not set correctly for second resolve

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.4.1
    • Fix Version/s: 2.0.0-alpha-1
    • Component/s: Ant
    • Labels:
      None

      Description

      When you call <ivy:resolve /> twice, the ivy.revision property still contains the revision of the first resolve.

        Activity

        Xavier Hanin added a comment -

        OK, if the ivy.module is modified it's much better to be consistent.

        Maarten Coene added a comment -

        Ant properties are modifiable as long as the user doesn't set them manually.

        Assume the ivy.revision property is not set before calling ivy:resolve:
        <ivy:resolve file="/path/to/module-1.2-ivy.xml" />

        Now the ivy.resolve property has value "1.2", the ivy.module property is "module"
        When I execute another resolve:
        <ivy:resolve file="/path/to/module2-1.3-ivy.xml" />

        The ivy.resolve property should now be 1.3, to be consistent with the ivy.module property which will be "module2"

        Xavier Hanin added a comment -

        The problem is that ant properties are not modifiable, so I don't see that as a bug. Maybe we should provide another way to get the version?


          People

          • Assignee:
            Maarten Coene
            Reporter:
            Maarten Coene
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development