Uploaded image for project: 'Ivy'
  1. Ivy
  2. IVY-239

value of confmappingoverride from imported configurations is lost when writing Ivy file

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.3.1
    • Fix Version/s: 1.4-RC1
    • Component/s: None
    • Labels:
      None

      Description

      If you import an external configurations-file which specifies the value of the confmappingoverride attribute, this value doesn't appear in the Ivy file produced by the the deliver task.

      The problem is in the XmlModuleDescriptorUpdater class.
      I don't see an easy way to do this in a clean way, except if we also support this attribute on the dependencies element (like the defaultconfmapping attribute).
      What do you think?

        Activity

        xavier Xavier Hanin added a comment -

        I've included your patch, it should be ok now. Thanks for your contribution.

        maartenc Maarten Coene added a comment -

        Required resource for the junit test

        maartenc Maarten Coene added a comment -

        Required resource for the junit test.

        maartenc Maarten Coene added a comment -

        Please ignore the change to Ivy.java in the previous patch.
        The other changes in the uploaded patch are still valid though!

        maartenc Maarten Coene added a comment -

        This patch bundles the previous patches, includes a junit test and some other changes to XmlModuleDescriptorParser to make the testing easier.

        maartenc Maarten Coene added a comment -

        Patch for ivy.xsd to allow the confmappingoverride attribute to appear on the dependencies element.

        maartenc Maarten Coene added a comment -

        Xavier,
        will this be included in the 1.4 release as well?

        xavier Xavier Hanin added a comment -

        Yes! sorry for the mistake.

        maartenc Maarten Coene added a comment -

        I'll try to upload a junit test later (not sure if I'll have the time to create one)
        However, I've tested the patch manually and it seems to work

        regards,
        Maarten

        maartenc Maarten Coene added a comment -

        Patch for XmlModuleDescriptorUpdater.java

        maartenc Maarten Coene added a comment -

        Patch for XmlModuleDescriptorParser.java

        xavier Xavier Hanin added a comment -

        adding it on the dependency element seems to be a not too bad idea (not really elegant, but at least it's consistent with defaultconfmapping ).


          People

          • Assignee:
            xavier Xavier Hanin
            Reporter:
            maartenc Maarten Coene
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Due:
              Created:
              Updated:
              Resolved:

              Development