Uploaded image for project: 'Ivy'
  1. Ivy
  2. IVY-1603

Latest version matcher fails when found branch is empty

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 2.5.0-rc1
    • Fix Version/s: None
    • Component/s: Core
    • Labels:
      None

      Description

      Resolving a latest.integration revision fails when the found dependency contains an empty string for a branch. The cryptic error message looks something like:

      [ivy:resolve]   java.text.ParseException: inconsistent module descriptor file found in '[redacted]ivy-3.1.4-rc5.xml': bad revision: expected='3.1.4-rc5' found='3.1.4-rc5';
      

       
      This issue doesn't appear to be present in 2.4.0.

        Attachments

        1. IVY-1603.patch
          0.9 kB
          Simon Wade
        2. IVY-1603.zip
          3 kB
          Simon Wade

          Activity

            People

            • Assignee:
              jaikiran Jaikiran Pai
              Reporter:
              Simon Wade Simon Wade
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated: