Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Not A Problem
    • Affects Version/s: 2.0
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:

      Solaris10 and windows SVN repository on CollabNet Teamforge

      Description

      While retrieving artefacts thought IVY I'm getting internal server error. when I access the link directly via browser the artefact is present.
      please find below error

      CLIENT ERROR:
      Authorization Required
      url=https://scm-coconet.capgemini.com/svn/repos/fsa_irr2_prod/Resource/branches/release2/artifact........HTTP
      response status: 401=Authorization Required
      url=https://scm-coconet.capgemini.com/svn/repos/fsa_irr2_prod/Resource/branches/release2/

      also below might be helpful

      26-Mar-2012 19:49:16 org.apache.commons.httpclient.auth.AuthChallengeProcessor selectAuthScheme
      [ivy:retrieve] INFO: Basic authentication scheme selected
      [ivy:retrieve] WARN: SERVER ERROR: Internal Server Error url=https://scm-coconet.capgemini.com/svn/repos/fsa_irr2_prod/Resource/branches/release2/artifact/bea/dsp/jar/dsp-1.0.jar

      1. ASF.LICENSE.NOT.GRANTED--logs.txt
        152 kB
        Sandeep Borgaonkar
      2. ASF.LICENSE.NOT.GRANTED--ivysettings.xml
        1 kB
        Sandeep Borgaonkar
      3. ASF.LICENSE.NOT.GRANTED--ivysettings.xml
        1 kB
        Sandeep Borgaonkar
      4. ASF.LICENSE.NOT.GRANTED--ivysettings.xml
        1 kB
        Sandeep Borgaonkar
      5. ASF.LICENSE.NOT.GRANTED--ivy.logs
        378 kB
        Sandeep Borgaonkar
      6. ASF.LICENSE.NOT.GRANTED--errorHttpclient.txt
        2 kB
        Sandeep Borgaonkar

        Activity

        Maarten Coene added a comment -

        Could you also attach your ivysettings.xml?

        Sandeep Borgaonkar added a comment -

        Hi Maarten,

        Please find attachment for ivysettings.xml

        With Regards,
        Sandeep Borgaonkar

        On Mon, Mar 26, 2012 at 9:20 PM, Maarten Coene (Commented) (JIRA) <

        Maarten Coene added a comment -

        You must specify username/password in your settings.xml using the <credentials> subelement. Cfr. http://ant.apache.org/ivy/history/latest-milestone/settings/credentials.html

        Sandeep Borgaonkar added a comment -

        Hi Maarten,

        I've added the attribute still the following error is observed
        when I access the url via browser the jar file is present.

        SERVER ERROR: Internal Server Error url=
        https://scm-coconet.capgemini.com/svn/repos/fsa_irr2_prod/Resource/branches/release2/artifact/bea/dsp/ivy-1.0.xml
        [ivy:retrieve] SERVER ERROR: Internal Server Error url=
        https://scm-coconet.capgemini.com/svn/repos/fsa_irr2_prod/Resource/branches/release2/artifact/bea/dsp/jar/dsp-1.0.jar
        [ivy:retrieve] module not found: [ bea | dsp | 1.0 ]
        [ivy:retrieve] ==== fsa: tried

        Thanks,
        Sandeep.

        With Regards,
        Sandeep Borgaonkar

        On Sun, Apr 1, 2012 at 11:06 PM, Maarten Coene (Resolved) (JIRA) <

        Maarten Coene added a comment -

        could you please post your updated ivysettings.xml
        (don't forget to remove your username/pasword to something)

        Sandeep Borgaonkar added a comment -

        Hi Maarten,

        PFA for attached ivysettings .xml

        following are the attribute values other than credentials.

        subversion.hostname=scm-coconet.capgemini.com
        subversion.realm=Authorization Realm

        With Regards,
        Sandeep Borgaonkar

        On Mon, Apr 2, 2012 at 9:45 PM, Maarten Coene (Commented) (JIRA) <

        Maarten Coene added a comment -

        Could you try again with 'passwd' instead of 'paswd' in your <credentials> element?

        Sandeep Borgaonkar added a comment -

        Hi Maarten,

        No luck

        I've tried after changing along with the existing error following is
        observed.

        [ivy:retrieve] 02-Apr-2012 22:25:49
        org.apache.commons.httpclient.HttpMethodBase readResponseBody
        [ivy:retrieve] INFO: Response content length is not known
        [ivy:retrieve] 02-Apr-2012 22:25:49
        org.apache.commons.httpclient.auth.AuthChallengeProcessor selectAuthScheme
        [ivy:retrieve] INFO: Basic authentication scheme selected

        With Regards,
        Sandeep Borgaonkar

        On Mon, Apr 2, 2012 at 10:15 PM, Maarten Coene (Commented) (JIRA) <

        Maarten Coene added a comment -

        Can you run ant in verbose mode (ant -v) and post the output here?
        (if possible without using commons-httpclient)

        Sandeep Borgaonkar added a comment -

        Hi Maarten,

        please find attachment (logs.txt) for the verbose logs
        I tried executing without commons-httpclient but there were
        errors(errorHttpclient.txt).
        With Regards,
        Sandeep Borgaonkar

        On Mon, Apr 2, 2012 at 10:55 PM, Maarten Coene (Commented) (JIRA) <

        Maarten Coene added a comment -

        I see this in the logs:

        [ivy:retrieve] :: Ivy 2.0.0-alpha2-incubating - 20070712142751 :: http://incubator.apache.org/ivy/ ::
        [ivy:retrieve] Loading jar:file:/data/cruisecontrol/projects/data-management-hourly-psd/ivy/ivy-2.0.0-alpha2-incubating.jar!/org/apache/ivy/core/settings/ivy.properties

        Could you try again with Ivy 2.2.0 (or latest snapshot)?

        Sandeep Borgaonkar added a comment -

        Hi Maarten,

        After adding the latest jar, following error is observed.
        please let me know the jar name to be included.
        java.lang.NoClassDefFoundError:
        org/apache/ivy/ant/IvyAntSettings$Credentials
        at
        org.apache.tools.ant.ProjectHelper.addLocationToBuildException(ProjectHelper.java:539)
        at org.apache.tools.ant.taskdefs.Ant.execute(Ant.java:388)
        at
        org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:275)
        at org.apache.tools.ant.Task.perform(Task.java:364)
        at org.apache.tools.ant.Target.execute(Target.java:341)
        at org.apache.tools.ant.Target.performTasks(Target.java:369)
        at org.apache.tools.ant.Project.executeTarget(Project.java:1214)
        at org.apache.tools.ant.Project.executeTargets(Project.java:1062)
        at org.apache.tools.ant.Main.runBuild(Main.java:673)
        at org.apache.tools.ant.Main.startAnt(Main.java:188)
        at org.apache.tools.ant.launch.Launcher.run(Launcher.java:196)
        at org.apache.tools.ant.launch.Launcher.main(Launcher.java:55)
        Caused by: java.lang.NoClassDefFoundError:
        org/apache/ivy/ant/IvyAntSettings$Credentials
        at org.apache.tools.ant.Project.executeTarget(Project.java:1223)
        at org.apache.tools.ant.taskdefs.Ant.execute(Ant.java:386)
        ... 10 more
        Caused by: java.lang.NoClassDefFoundError:
        org/apache/ivy/ant/IvyAntSettings$Credentials
        at java.lang.Class.getDeclaredMethods0(Native Method)
        at java.lang.Class.privateGetDeclaredMethods(Class.java:2365)
        at java.lang.Class.privateGetPublicMethods(Class.java:2488)
        at java.lang.Class.getMethods(Class.java:1406)

        With Regards,
        Sandeep Borgaonkar

        On Tue, Apr 3, 2012 at 12:40 PM, Maarten Coene (Commented) (JIRA) <

        Maarten Coene added a comment -

        Could you please attach a new log when running in verbose mode?

        Sandeep Borgaonkar added a comment -

        I've resolved the Credentials class error.
        I've removed HttpClient jar and following error is observed.

        don't use cache for bea#wlst;1.0: checkModified=true
        [ivy:retrieve] tried
        https://scm-coconet.capgemini.com/svn/repos/fsa_irr2_prod/Resource/branches/release2/artifact/bea/wlst/ivy-1.0.xml
        [ivy:retrieve] CLIENT ERROR: Bad Request url=
        https://scm-coconet.capgemini.com/svn/repos/fsa_irr2_prod/Resource/branches/release2/artifact/bea/wlst/ivy-1.0.xml
        [ivy:retrieve] tried
        https://scm-coconet.capgemini.com/svn/repos/fsa_irr2_prod/Resource/branches/release2/artifact/bea/wlst/jar/wlst-1.0.jar
        [ivy:retrieve] CLIENT ERROR: Bad Request url=
        https://scm-coconet.capgemini.com/svn/repos/fsa_irr2_prod/Resource/branches/release2/artifact/bea/wlst/jar/wlst-1.0.jar

        With Regards,
        Sandeep Borgaonkar

        On Tue, Apr 3, 2012 at 10:28 PM, Maarten Coene (Commented) (JIRA) <

        Sandeep Borgaonkar added a comment -

        Also with HttpClient its getting hanged while retrieving the jars.

        With Regards,
        Sandeep Borgaonkar

        On Tue, Apr 3, 2012 at 10:28 PM, Maarten Coene (Commented) (JIRA) <

        Maarten Coene added a comment -

        Could you try to disable Ivy sending HTTP HEAD requests?
        To accomplish this, specify httpRequestMethod='GET' in your ivysettings.xml, cfr http://ant.apache.org/ivy/history/latest-milestone/settings/settings.html

        If that doesn't work, could you attach the debug logging when running (without commons-httpclient) in Ant (ant -d). (check the logfile before attaching it, it could contain usernames/passwords!)

        Sandeep Borgaonkar added a comment -

        Hi Maarten,

        Accept my apology, could not revert back to you immediately.

        it didn't work, please find attachment for debug logs.
        Also find attachment for ivysettings.xml

        With Regards,
        Sandeep Borgaonkar

        On Wed, Apr 4, 2012 at 10:49 PM, Maarten Coene (Commented) (JIRA) <

        Maarten Coene added a comment -

        I don't see a reason why it fails.
        Any chance I could get a login on your server to do some more debugging myself?

        Sandeep Borgaonkar added a comment -

        Hi Maarten,

        Yes you can, is there any web conference facility available?

        With Regards,
        Sandeep Borgaonkar

        Maarten Coene added a comment -

        No, I'm afraid there isn't at the moment ...

        Sandeep Borgaonkar added a comment -

        then will you access our system?

        With Regards,
        Sandeep Borgaonkar

        Sandeep Borgaonkar added a comment -

        I mean to say how...

        With Regards,
        Sandeep Borgaonkar

        On Mon, Apr 23, 2012 at 10:48 PM, Sandeep Borgaonkar (JIRA) <jira@apache.org


          People

          • Assignee:
            Maarten Coene
            Reporter:
            Sandeep Borgaonkar
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development