Ivy
  1. Ivy
  2. IVY-1240

Only the last dependency descriptor is taken into account on the same module

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.2.0
    • Fix Version/s: 2.3.0-RC1
    • Component/s: None
    • Labels:
      None

      Description

      In some of our project we had:

      <dependency org="org" name="mymodule" rev="1.0" conf="compile,runtime->conf1" />
      <dependency org="org" name="mymodule" rev="1.0" conf="compile,runtime->conf2" />
      <dependency org="org" name="mymodule" rev="1.0" conf="compile,runtime->conf3" />
      

      When resolving dependencies with the conf "*", the resulting "compile" conf report did contain dependencies of the conf1, conf2 and conf3 of mymodule. But the resulting "runtime" conf report, contained only the configuration of conf3 of mymodule.

      Changing the dependency into the following one fixed it:

      <dependency org="org" name="mymodule" rev="1.0" conf="compile,runtime->conf1,conf2,conf3" />
      

        Activity

        Nicolas Lalevée added a comment -

        I did try to make a unit test, but I was not able to reproduce the issue. I think I have found the culprit though by debugging while resolving on my project.
        So I will commit the fix and the unit test, even if the unit test didn't actually fail before the apply of the fix.


          People

          • Assignee:
            Nicolas Lalevée
            Reporter:
            Nicolas Lalevée
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development