Ivy
  1. Ivy
  2. IVY-1058

PomModuleDescriptorBuilder does not resolve ejb type dependencies to jar extension.

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 2.1.0-RC2
    • Component/s: Maven Compatibility
    • Labels:
      None

      Description

      During of parsing POM module dependency with type ejb, method PomModuleDescriptorBuilder#addDependency should use
      PomModuleDescriptorBuilder#JAR_PACKAGINGS List as well as PomModuleDescriptorBuilder#addMainArtifact method.
      For example if I use following code

       
      <dependency org="org.jboss.seam" name="jboss-seam-ui" rev="2.1.1.GA" conf="compile,production->default"/> 
      

      in ivy.xml, dependency
      org.jboss.seam#jboss-seam;2.1.1.GA!jboss-seam.ejb module will be tried to load instead of org.jboss.seam#jboss-seam;2.1.1.GA!jboss-seam.jar module.
      In the pom.xml this dependency is described like:

       
      <dependency>
            <groupId>org.jboss.seam</groupId>
            <artifactId>jboss-seam</artifactId>
            <type>ejb</type>
      </dependency>
      

        Activity

        Maarten Coene made changes -
        Fix Version/s 2.1.0-RC2 [ 12314062 ]
        Fix Version/s trunk [ 12313426 ]
        Jason Porter added a comment -

        The problem is when an ejb type is resolved as a transitive dependency when you don't have control over it unless you explicitly tell it what to do.

        Maarten Coene added a comment -

        Maybe you could use the [ext] token instead of the [type] token in your retrieve pattern?

        Stephane Epardaud added a comment -

        I can confirm it fixes it for me although I didn't find a way to make the jar go into my "[type]/" folder with type==jar (it goes in ejb/)

        Maarten Coene made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Fix Version/s trunk [ 12313426 ]
        Resolution Fixed [ 1 ]
        Maarten Coene added a comment -

        Thanks for the contribution Andrey! I've applied your patch into SVN trunk + added a junit test. Could you give it a try?

        Maarten Coene made changes -
        Assignee Maarten Coene [ maartenc ]
        Andrey Lomakin made changes -
        Field Original Value New Value
        Attachment IVY-1058_2009_04_07.patch [ 12404818 ]
        Andrey Lomakin created issue -

          People

          • Assignee:
            Maarten Coene
            Reporter:
            Andrey Lomakin
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development