Ivy
  1. Ivy
  2. IVY-1009

Ivy Standalone hangs after publishing to SSH resolver

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0-RC2, 2.0
    • Fix Version/s: 2.1.0-RC1
    • Component/s: Core
    • Labels:
      None
    • Environment:

      Windows XP, standalone ivy. SSH server running on CentOS 5

      Description

      I'm using Ivy in standalone mode to manage DLLs for a C# project. I have an SSH repository set up, which works fine for retrieving artifacts, but not for publishing them.

      When I publish a module, everything succeeds as expected, however ivy doesn't exit and return to the command prompt. If ivy is run with -verbose or -debug, the last thing it prints to the console is "publish done (12273ms)".

        Activity

        Hide
        Maarten Coene added a comment -

        I think I solved it be adding an explicit System.exit(0) at the end of the main-method.
        There was probably something still hanging around...

        Could you give it a try, since I couldn't test it to see if it is really solved.

        Show
        Maarten Coene added a comment - I think I solved it be adding an explicit System.exit(0) at the end of the main-method. There was probably something still hanging around... Could you give it a try, since I couldn't test it to see if it is really solved.
        Hide
        Nathan Tomkins added a comment -

        Also, it doesn't hang using the same settings file via ant.

        Show
        Nathan Tomkins added a comment - Also, it doesn't hang using the same settings file via ant.

          People

          • Assignee:
            Maarten Coene
            Reporter:
            Nathan Tomkins
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development