Uploaded image for project: 'Isis'
  1. Isis
  2. ISIS-1618

Action Button with Confirmation Dialog ignores second shot

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: 1.14.0
    • Fix Version/s: 1.15.0
    • Component/s: Core: Viewer: Wicket
    • Labels:
      None

      Description

      Click on any action button (that has a confirmation dialog) and cancel the dialog. The immediate next click on the button does nothing (will not fire a click event). Click again and the confirmation dialog pops up as intended.

      This is a confusing behavior.

      Steps to reproduce: Take the simple-app artifact 1.14 and play with the SimpleObject's delete button.

        Activity

        danhaywood Dan Haywood added a comment -

        yep, this is a known issue; not introduced in the 1.15.0 refactorings, was there in 1.14.0 and 1.13.x too, I think.

        danhaywood Dan Haywood added a comment -

        hmm, seems to have resolved itself; perhaps because of ISIS-1615 change is preventing interference.

        hobrom Andi Huber added a comment -

        I can confirm that. It's no longer an issue.
        (Tested against master 1.15.0-SNAPSHOT)


          People

          • Assignee:
            Unassigned
            Reporter:
            hobrom Andi Huber
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development