Uploaded image for project: 'Isis'
  1. Isis
  2. ISIS-1615

Tooltip for Actions not always shown ... @ActionLayout.describedAs

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.14.0
    • Fix Version/s: 1.15.0
    • Component/s: Core: Viewer: Wicket
    • Labels:
      None

      Description

      Regarding ActionLayout annotation, the text specified with the 'describedAs' feature will sometimes not show up.

      Reason: bootstrap (on the client-side) will modify the DOM such that HTML links will no longer work as intended. (ISIS Actions/Buttons are HTML links.)

      Details:
      1) Server sends ...
      <li title="described as"><a ... /></li>

      2) bootstrap makes changes (adds the 'title' attribute, where there was non provided by the server)
      <li title="described as"><a title="" ... /></li>

      3) now when we mouse-over the link, no tooltip is shown


      For a possible solution see:
      http://stackoverflow.com/questions/27235776/can-i-still-use-the-title-attribute-on-bootstrap-popovers

      1. Screenshot-1.png
        13 kB
        Andi Huber
      2. Screenshot-2.png
        48 kB
        Andi Huber

        Activity

        hobrom Andi Huber added a comment -

        I've added a pull-request:
        https://github.com/apache/isis/pull/77

        hobrom Andi Huber added a comment -

        To reproduce the issue, take the simple-app artifact 1.14 and add an @ActionLayout to the SimpleObject's delete action.

        hobrom Andi Huber added a comment -

        Now, if we mouse-over the 'delete' button, no tooltip is shown.

        jira-bot ASF subversion and git services added a comment -

        Commit 9d2aea00ee9db082de56d0e8035c5a9cc1bd2880 in isis's branch refs/heads/master from Andi Huber
        [ https://git-wip-us.apache.org/repos/asf?p=isis.git;h=9d2aea0 ]

        ISIS-1615: prevent bootstrap from changing the HTML link's 'title' attribute on client-side

        see https://issues.apache.org/jira/browse/ISIS-1615

        jira-bot ASF subversion and git services added a comment -

        Commit 9d2aea00ee9db082de56d0e8035c5a9cc1bd2880 in isis's branch refs/heads/master from Andi Huber
        [ https://git-wip-us.apache.org/repos/asf?p=isis.git;h=9d2aea0 ]

        ISIS-1615: prevent bootstrap from changing the HTML link's 'title' attribute on client-side

        see https://issues.apache.org/jira/browse/ISIS-1615

        jira-bot ASF subversion and git services added a comment -

        Commit f9cca94b83fa78c130718b2d8726b7226db7b14f in isis's branch refs/heads/master from Dan Haywood
        [ https://git-wip-us.apache.org/repos/asf?p=isis.git;h=f9cca94 ]

        ISIS-1615: updates simpleapp to demonstrate the issue

        jira-bot ASF subversion and git services added a comment -

        Commit 8669d92cdde650f1f7668aa67961906ea7c5e85e in isis's branch refs/heads/master from Dan Haywood
        [ https://git-wip-us.apache.org/repos/asf?p=isis.git;h=8669d92 ]

        Merge branch 'patch-2' of https://github.com/hobrom/isis into ISIS-1615_pr-77

        jira-bot ASF subversion and git services added a comment -

        Commit 34489731f182aa77e115f6e74eff9fe81237a663 in isis's branch refs/heads/master from Dan Haywood
        [ https://git-wip-us.apache.org/repos/asf?p=isis.git;h=3448973 ]

        Merge branch 'ISIS-1615_pr-77'

        jira-bot ASF subversion and git services added a comment -

        Commit 9d2aea00ee9db082de56d0e8035c5a9cc1bd2880 in isis's branch refs/heads/ISIS-1613 from Andi Huber
        [ https://git-wip-us.apache.org/repos/asf?p=isis.git;h=9d2aea0 ]

        ISIS-1615: prevent bootstrap from changing the HTML link's 'title' attribute on client-side

        see https://issues.apache.org/jira/browse/ISIS-1615

        jira-bot ASF subversion and git services added a comment -

        Commit 9d2aea00ee9db082de56d0e8035c5a9cc1bd2880 in isis's branch refs/heads/ISIS-1613 from Andi Huber
        [ https://git-wip-us.apache.org/repos/asf?p=isis.git;h=9d2aea0 ]

        ISIS-1615: prevent bootstrap from changing the HTML link's 'title' attribute on client-side

        see https://issues.apache.org/jira/browse/ISIS-1615

        jira-bot ASF subversion and git services added a comment -

        Commit f9cca94b83fa78c130718b2d8726b7226db7b14f in isis's branch refs/heads/ISIS-1613 from Dan Haywood
        [ https://git-wip-us.apache.org/repos/asf?p=isis.git;h=f9cca94 ]

        ISIS-1615: updates simpleapp to demonstrate the issue

        jira-bot ASF subversion and git services added a comment -

        Commit 8669d92cdde650f1f7668aa67961906ea7c5e85e in isis's branch refs/heads/ISIS-1613 from Dan Haywood
        [ https://git-wip-us.apache.org/repos/asf?p=isis.git;h=8669d92 ]

        Merge branch 'patch-2' of https://github.com/hobrom/isis into ISIS-1615_pr-77

        jira-bot ASF subversion and git services added a comment -

        Commit 34489731f182aa77e115f6e74eff9fe81237a663 in isis's branch refs/heads/ISIS-1613 from Dan Haywood
        [ https://git-wip-us.apache.org/repos/asf?p=isis.git;h=3448973 ]

        Merge branch 'ISIS-1615_pr-77'

        danhaywood Dan Haywood added a comment -

        Unfortunately, this breaks the "are you sure?" dialog for no-arg actions. Therefore gonna back it out until understand solution better.

        In any case, it might be preferable to instead use a bit of JQuery to add a tooltip.

        jira-bot ASF subversion and git services added a comment -

        Commit c256984b9af5f2fd5bca1004933f6e3d36fb50dd in isis's branch refs/heads/ISIS-1613 from Dan Haywood
        [ https://git-wip-us.apache.org/repos/asf?p=isis.git;h=c256984 ]

        ISIS-1615: reverts change, since interferes with 'are you sure' semantics on no-arg actions.

        hobrom Andi Huber added a comment -

        I'm sorry for that. The stack-overflow solution (as proposed above) seems to have unwanted side-effects.

        We are preparing a fix ...

        jira-bot ASF subversion and git services added a comment -

        Commit c256984b9af5f2fd5bca1004933f6e3d36fb50dd in isis's branch refs/heads/master from Dan Haywood
        [ https://git-wip-us.apache.org/repos/asf?p=isis.git;h=c256984 ]

        ISIS-1615: reverts change, since interferes with 'are you sure' semantics on no-arg actions.

        jira-bot ASF subversion and git services added a comment -

        Commit 431294388ed4ea52a00bcf6f44b3fb778f05b997 in isis's branch refs/heads/master from Andi Huber
        [ https://git-wip-us.apache.org/repos/asf?p=isis.git;h=4312943 ]

        Fix ISIS-1615

        https://issues.apache.org/jira/browse/ISIS-1615

        jira-bot ASF subversion and git services added a comment -

        Commit 431294388ed4ea52a00bcf6f44b3fb778f05b997 in isis's branch refs/heads/master from Andi Huber
        [ https://git-wip-us.apache.org/repos/asf?p=isis.git;h=4312943 ]

        Fix ISIS-1615

        https://issues.apache.org/jira/browse/ISIS-1615

        jira-bot ASF subversion and git services added a comment -

        Commit 78b31dbe4263a16b1d07d49b96ba403188f54bda in isis's branch refs/heads/master from Dan Haywood
        [ https://git-wip-us.apache.org/repos/asf?p=isis.git;h=78b31db ]

        Merge branch 'master' of https://github.com/hobrom/isis into ISIS-1615_pr-78

        Fixes trivial conflicts.


          People

          • Assignee:
            danhaywood Dan Haywood
            Reporter:
            hobrom Andi Huber
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development