Uploaded image for project: 'Isis'
  1. Isis
  2. ISIS-1577

The transactionId within a command XML does not correspond with the transactionId of the command's metadata.

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.13.2.1
    • Fix Version/s: 1.14.0
    • Component/s: Core
    • Labels:
      None

      Description

      To reproduce, using Estatio-ECP

      • Invoice > Calculate ... choose OXF-MEDIAX-002
      • Activity > Recent Changes to inspect the command.

      The command and corresponding published event are both persisted and associated with the same xactn Id. But the xactn Id of the command's XML is different.

      This is probably because there are two xactns for commands.... really, there should in the happy case be only one xactn, with a 2nd xactn created if there was a probably executing thecommand.

        Activity

        jira-bot ASF subversion and git services added a comment -

        Commit b2b41a971c30b9a5bbc10a03382ee6638a6aed53 in isis's branch refs/heads/maint-1.14.0 from Dan Haywood
        [ https://git-wip-us.apache.org/repos/asf?p=isis.git;h=b2b41a9 ]

        ISIS-1577: when populating the command DTO (XML), use the transactionId of the existing CommandContext if available.


          People

          • Assignee:
            danhaywood Dan Haywood
            Reporter:
            danhaywood Dan Haywood
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development