Uploaded image for project: 'Isis'
  1. Isis
  2. ISIS-1574

Throws exception if layout.xml references unknown property.

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.13.2
    • Fix Version/s: 1.14.0
    • Component/s: Core: Viewer: Wicket
    • Labels:
      None

      Description

      Caused by: java.lang.reflect.InvocationTargetException
      	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
      	at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
      	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
      	at java.lang.reflect.Constructor.newInstance(Constructor.java:423)
      	at org.apache.wicket.session.DefaultPageFactory.newPage(DefaultPageFactory.java:171)
      	... 48 more
      Caused by: org.apache.isis.core.metamodel.spec.ObjectSpecificationException: No association called 'notes' in 'Doc Fragment'
      	at org.apache.isis.core.metamodel.specloader.specimpl.ObjectSpecificationAbstract.getAssociation(ObjectSpecificationAbstract.java:684)
      	at org.apache.isis.viewer.wicket.ui.components.entity.fieldset.PropertyGroup$2.apply(PropertyGroup.java:109)
      	at org.apache.isis.viewer.wicket.ui.components.entity.fieldset.PropertyGroup$2.apply(PropertyGroup.java:106)
      	at com.google.common.collect.Iterators$8.transform(Iterators.java:817)
      	at com.google.common.collect.TransformedIterator.next(TransformedIterator.java:48)
      	at com.google.common.collect.Iterators$7.computeNext(Iterators.java:674)
      	at com.google.common.collect.AbstractIterator.tryToComputeNext(AbstractIterator.java:143)
      	at com.google.common.collect.AbstractIterator.hasNext(AbstractIterator.java:138)
      	at com.google.common.collect.ImmutableList.copyOf(ImmutableList.java:253)
      	at com.google.common.collect.ImmutableList.copyOf(ImmutableList.java:209)
      	at com.google.common.collect.FluentIterable.toList(FluentIterable.java:484)
      	at org.apache.isis.viewer.wicket.ui.components.entity.fieldset.PropertyGroup.buildGui(PropertyGroup.java:99)
      	at org.apache.isis.viewer.wicket.ui.components.entity.fieldset.PropertyGroup.<init>(PropertyGroup.java:74)
      	at org.apache.isis.viewer.wicket.ui.components.layout.bs3.col.Col.buildGui(Col.java:243)
      	at org.apache.isis.viewer.wicket.ui.components.layout.bs3.col.Col.<init>(Col.java:79)
      	at org.apache.isis.viewer.wicket.ui.components.layout.bs3.row.Row.buildGui(Row.java:69)
      	at org.apache.isis.viewer.wicket.ui.components.layout.bs3.row.Row.<init>(Row.java:54)
      	at org.apache.isis.viewer.wicket.ui.components.layout.bs3.tabs.TabPanel.newRows(TabPanel.java:88)
      	at org.apache.isis.viewer.wicket.ui.components.layout.bs3.tabs.TabGroupPanel.tabsFor(TabGroupPanel.java:63)
      	at org.apache.isis.viewer.wicket.ui.components.layout.bs3.tabs.TabGroupPanel.<init>(TabGroupPanel.java:89)
      	at org.apache.isis.viewer.wicket.ui.components.layout.bs3.col.Col.buildGui(Col.java:212)
      	at org.apache.isis.viewer.wicket.ui.components.layout.bs3.col.Col.<init>(Col.java:79)
      	at org.apache.isis.viewer.wicket.ui.components.layout.bs3.row.Row.buildGui(Row.java:69)
      	at org.apache.isis.viewer.wicket.ui.components.layout.bs3.row.Row.<init>(Row.java:54)
      	at org.apache.isis.viewer.wicket.ui.components.layout.bs3.BS3GridPanel.buildGui(BS3GridPanel.java:56)
      	at org.apache.isis.viewer.wicket.ui.components.layout.bs3.BS3GridPanel.<init>(BS3GridPanel.java:42)
      	at org.apache.isis.viewer.wicket.ui.components.entity.selector.links.EntityLinksSelectorPanelFactory.createComponent(EntityLinksSelectorPanelFactory.java:57)
      	at org.apache.isis.viewer.wicket.ui.ComponentFactoryAbstract.createComponent(ComponentFactoryAbstract.java:98)
      	at org.apache.isis.viewer.wicket.viewer.registries.components.ComponentFactoryRegistryDefault.createComponent(ComponentFactoryRegistryDefault.java:121)
      	at org.apache.isis.viewer.wicket.viewer.registries.components.ComponentFactoryRegistryDefault.addOrReplaceComponent(ComponentFactoryRegistryDefault.java:106)
      	at org.apache.isis.viewer.wicket.ui.pages.PageAbstract.addComponent(PageAbstract.java:346)
      	at org.apache.isis.viewer.wicket.ui.pages.PageAbstract.addChildComponents(PageAbstract.java:341)
      	at org.apache.isis.viewer.wicket.ui.pages.entity.EntityPage.buildPage(EntityPage.java:195)
      	at org.apache.isis.viewer.wicket.ui.pages.entity.EntityPage.<init>(EntityPage.java:114)
      	at org.apache.isis.viewer.wicket.ui.pages.entity.EntityPage.<init>(EntityPage.java:82)
      	at org.apache.isis.viewer.wicket.ui.pages.entity.EntityPage.<init>(EntityPage.java:63)
      	... 53 more
      

        Activity

        danhaywood Dan Haywood added a comment - - edited

        Can't reproduce ... but have decided to add a guard anyway, just in case.

        jira-bot ASF subversion and git services added a comment -

        Commit 5e247641ed45735d1e8bf20271737ff4bff5a7b8 in isis's branch refs/heads/maint-1.14.0 from Dan Haywood
        [ https://git-wip-us.apache.org/repos/asf?p=isis.git;h=5e24764 ]

        ISIS-1574: adds guard when iterating over PropertyGroup


          People

          • Assignee:
            danhaywood Dan Haywood
            Reporter:
            danhaywood Dan Haywood
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development