Uploaded image for project: 'Isis'
  1. Isis
  2. ISIS-1564

Attempt to invoke no-arg bookmarked action, throws stacktraceexception.

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.13.2
    • Fix Version/s: 1.14.0
    • Component/s: None
    • Labels:
      None

      Description

      to reproduce:

      • run up simpleapp archetype for 1.13.2.
      • invoke SimpleObjects > listAll (so added to bookmarks)
      • then try to click on the bookmark

      Will get this stack trace:

      Stack trace:
      org.apache.wicket.WicketRuntimeException
      Unable to create page from class org.apache.isis.viewer.wicket.ui.pages.actionprompt.ActionPromptPage. Class does not have a visible default constructor.
      org.apache.wicket.session.DefaultPageFactory#newPage(DefaultPageFactory.java:80)
      org.apache.wicket.session.DefaultPageFactory#newPage(DefaultPageFactory.java:103)
      org.apache.wicket.DefaultMapperContext#newPageInstance(DefaultMapperContext.java:137)
      org.apache.wicket.core.request.handler.PageProvider#resolvePageInstance(PageProvider.java:268)
      org.apache.wicket.core.request.handler.PageProvider#getPageInstance(PageProvider.java:166)
      org.apache.wicket.request.handler.render.PageRenderer#getPage(PageRenderer.java:78)
      org.apache.wicket.request.handler.render.WebPageRenderer#renderPage(WebPageRenderer.java:117)
      org.apache.wicket.request.handler.render.WebPageRenderer#respond(WebPageRenderer.java:229)
      org.apache.wicket.core.request.handler.RenderPageRequestHandler#respond(RenderPageRequestHandler.java:175)
      org.apache.wicket.request.cycle.RequestCycle$HandlerExecutor#respond(RequestCycle.java:890)
      org.apache.wicket.request.RequestHandlerStack#execute(RequestHandlerStack.java:64)
      org.apache.wicket.request.cycle.RequestCycle#execute(RequestCycle.java:261)
      org.apache.wicket.request.cycle.RequestCycle#processRequest(RequestCycle.java:218)
      org.apache.wicket.request.cycle.RequestCycle#processRequestAndDetach(RequestCycle.java:289)
      org.apache.wicket.protocol.http.WicketFilter#processRequestCycle(WicketFilter.java:259)
      org.apache.wicket.protocol.http.WicketFilter#processRequest(WicketFilter.java:201)
      org.apache.wicket.protocol.http.WicketFilter#doFilter(WicketFilter.java:282)
      org.eclipse.jetty.servlet.ServletHandler$CachedChain#doFilter(ServletHandler.java:1668)
      org.apache.isis.core.webapp.diagnostics.IsisLogOnExceptionFilter#doFilter(IsisLogOnExceptionFilter.java:52)
      org.eclipse.jetty.servlet.ServletHandler$CachedChain#doFilter(ServletHandler.java:1668)
      org.apache.shiro.web.servlet.AbstractShiroFilter#executeChain(AbstractShiroFilter.java:449)
      org.apache.shiro.web.servlet.AbstractShiroFilter$1#call(AbstractShiroFilter.java:365)
      org.apache.shiro.subject.support.SubjectCallable#doCall(SubjectCallable.java:90)
      org.apache.shiro.subject.support.SubjectCallable#call(SubjectCallable.java:83)
      org.apache.shiro.subject.support.DelegatingSubject#execute(DelegatingSubject.java:383)
      org.apache.shiro.web.servlet.AbstractShiroFilter#doFilterInternal(AbstractShiroFilter.java:362)
      org.apache.shiro.web.servlet.OncePerRequestFilter#doFilter(OncePerRequestFilter.java:125)
      org.eclipse.jetty.servlet.ServletHandler$CachedChain#doFilter(ServletHandler.java:1668)
      org.eclipse.jetty.servlet.ServletHandler#doHandle(ServletHandler.java:581)
      org.eclipse.jetty.server.handler.ScopedHandler#handle(ScopedHandler.java:143)
      org.eclipse.jetty.security.SecurityHandler#handle(SecurityHandler.java:548)
      org.eclipse.jetty.server.session.SessionHandler#doHandle(SessionHandler.java:226)
      org.eclipse.jetty.server.handler.ContextHandler#doHandle(ContextHandler.java:1158)
      org.eclipse.jetty.servlet.ServletHandler#doScope(ServletHandler.java:511)
      org.eclipse.jetty.server.session.SessionHandler#doScope(SessionHandler.java:185)
      org.eclipse.jetty.server.handler.ContextHandler#doScope(ContextHandler.java:1090)
      org.eclipse.jetty.server.handler.ScopedHandler#handle(ScopedHandler.java:141)
      org.eclipse.jetty.server.handler.ContextHandlerCollection#handle(ContextHandlerCollection.java:213)
      org.eclipse.jetty.server.handler.HandlerCollection#handle(HandlerCollection.java:109)
      org.eclipse.jetty.server.handler.HandlerWrapper#handle(HandlerWrapper.java:119)
      org.eclipse.jetty.server.Server#handle(Server.java:517)
      org.eclipse.jetty.server.HttpChannel#handle(HttpChannel.java:306)
      org.eclipse.jetty.server.HttpConnection#onFillable(HttpConnection.java:242)
      org.eclipse.jetty.io.AbstractConnection$ReadCallback#succeeded(AbstractConnection.java:261)
      org.eclipse.jetty.io.FillInterest#fillable(FillInterest.java:95)
      org.eclipse.jetty.io.SelectChannelEndPoint$2#run(SelectChannelEndPoint.java:75)
      org.eclipse.jetty.util.thread.strategy.ExecuteProduceConsume#produceAndRun(ExecuteProduceConsume.java:213)
      org.eclipse.jetty.util.thread.strategy.ExecuteProduceConsume#run(ExecuteProduceConsume.java:147)
      org.eclipse.jetty.util.thread.QueuedThreadPool#runJob(QueuedThreadPool.java:654)
      org.eclipse.jetty.util.thread.QueuedThreadPool$3#run(QueuedThreadPool.java:572)
      java.lang.Thread#run(Thread.java:745)
      Caused by:
      java.lang.NoSuchMethodException
      org.apache.isis.viewer.wicket.ui.pages.actionprompt.ActionPromptPage.<init>()
      java.lang.Class#getConstructor0(Class.java:3082)
      java.lang.Class#getDeclaredConstructor(Class.java:2178)
      org.apache.wicket.session.DefaultPageFactory#newPage(DefaultPageFactory.java:65)
      org.apache.wicket.session.DefaultPageFactory#newPage(DefaultPageFactory.java:103)
      org.apache.wicket.DefaultMapperContext#newPageInstance(DefaultMapperContext.java:137)
      org.apache.wicket.core.request.handler.PageProvider#resolvePageInstance(PageProvider.java:268)
      org.apache.wicket.core.request.handler.PageProvider#getPageInstance(PageProvider.java:166)
      org.apache.wicket.request.handler.render.PageRenderer#getPage(PageRenderer.java:78)
      org.apache.wicket.request.handler.render.WebPageRenderer#renderPage(WebPageRenderer.java:117)
      org.apache.wicket.request.handler.render.WebPageRenderer#respond(WebPageRenderer.java:229)
      org.apache.wicket.core.request.handler.RenderPageRequestHandler#respond(RenderPageRequestHandler.java:175)
      org.apache.wicket.request.cycle.RequestCycle$HandlerExecutor#respond(RequestCycle.java:890)
      org.apache.wicket.request.RequestHandlerStack#execute(RequestHandlerStack.java:64)
      org.apache.wicket.request.cycle.RequestCycle#execute(RequestCycle.java:261)
      org.apache.wicket.request.cycle.RequestCycle#processRequest(RequestCycle.java:218)
      org.apache.wicket.request.cycle.RequestCycle#processRequestAndDetach(RequestCycle.java:289)
      org.apache.wicket.protocol.http.WicketFilter#processRequestCycle(WicketFilter.java:259)
      org.apache.wicket.protocol.http.WicketFilter#processRequest(WicketFilter.java:201)
      org.apache.wicket.protocol.http.WicketFilter#doFilter(WicketFilter.java:282)
      org.eclipse.jetty.servlet.ServletHandler$CachedChain#doFilter(ServletHandler.java:1668)
      org.apache.isis.core.webapp.diagnostics.IsisLogOnExceptionFilter#doFilter(IsisLogOnExceptionFilter.java:52)
      org.eclipse.jetty.servlet.ServletHandler$CachedChain#doFilter(ServletHandler.java:1668)
      org.apache.shiro.web.servlet.AbstractShiroFilter#executeChain(AbstractShiroFilter.java:449)
      org.apache.shiro.web.servlet.AbstractShiroFilter$1#call(AbstractShiroFilter.java:365)
      org.apache.shiro.subject.support.SubjectCallable#doCall(SubjectCallable.java:90)
      org.apache.shiro.subject.support.SubjectCallable#call(SubjectCallable.java:83)
      org.apache.shiro.subject.support.DelegatingSubject#execute(DelegatingSubject.java:383)
      org.apache.shiro.web.servlet.AbstractShiroFilter#doFilterInternal(AbstractShiroFilter.java:362)
      org.apache.shiro.web.servlet.OncePerRequestFilter#doFilter(OncePerRequestFilter.java:125)
      org.eclipse.jetty.servlet.ServletHandler$CachedChain#doFilter(ServletHandler.java:1668)
      org.eclipse.jetty.servlet.ServletHandler#doHandle(ServletHandler.java:581)
      org.eclipse.jetty.server.handler.ScopedHandler#handle(ScopedHandler.java:143)
      org.eclipse.jetty.security.SecurityHandler#handle(SecurityHandler.java:548)
      org.eclipse.jetty.server.session.SessionHandler#doHandle(SessionHandler.java:226)
      org.eclipse.jetty.server.handler.ContextHandler#doHandle(ContextHandler.java:1158)
      org.eclipse.jetty.servlet.ServletHandler#doScope(ServletHandler.java:511)
      org.eclipse.jetty.server.session.SessionHandler#doScope(SessionHandler.java:185)
      org.eclipse.jetty.server.handler.ContextHandler#doScope(ContextHandler.java:1090)
      org.eclipse.jetty.server.handler.ScopedHandler#handle(ScopedHandler.java:141)
      org.eclipse.jetty.server.handler.ContextHandlerCollection#handle(ContextHandlerCollection.java:213)
      org.eclipse.jetty.server.handler.HandlerCollection#handle(HandlerCollection.java:109)
      org.eclipse.jetty.server.handler.HandlerWrapper#handle(HandlerWrapper.java:119)
      org.eclipse.jetty.server.Server#handle(Server.java:517)
      org.eclipse.jetty.server.HttpChannel#handle(HttpChannel.java:306)
      org.eclipse.jetty.server.HttpConnection#onFillable(HttpConnection.java:242)
      org.eclipse.jetty.io.AbstractConnection$ReadCallback#succeeded(AbstractConnection.java:261)
      org.eclipse.jetty.io.FillInterest#fillable(FillInterest.java:95)
      org.eclipse.jetty.io.SelectChannelEndPoint$2#run(SelectChannelEndPoint.java:75)
      org.eclipse.jetty.util.thread.strategy.ExecuteProduceConsume#produceAndRun(ExecuteProduceConsume.java:213)
      org.eclipse.jetty.util.thread.strategy.ExecuteProduceConsume#run(ExecuteProduceConsume.java:147)
      org.eclipse.jetty.util.thread.QueuedThreadPool#runJob(QueuedThreadPool.java:654)
      org.eclipse.jetty.util.thread.QueuedThreadPool$3#run(QueuedThreadPool.java:572)
      java.lang.Thread#run(Thread.java:745)
      

        Activity

        jira-bot ASF subversion and git services added a comment -

        Commit cd6cd6eba9d642810b61979c9d6f10a5bd5b8a4d in isis's branch refs/heads/maint-1.14.0 from Dan Haywood
        [ https://git-wip-us.apache.org/repos/asf?p=isis.git;h=cd6cd6e ]

        ISIS-1564: reinstates constructor that accepts just PageParameters.


          People

          • Assignee:
            danhaywood Dan Haywood
            Reporter:
            danhaywood Dan Haywood
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development