Uploaded image for project: 'Isis'
  1. Isis
  2. ISIS-1550

Remove metamodel validation that insists on at least one @PersistenceCapable class.

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.13.1
    • Fix Version/s: 1.13.2
    • Component/s: Core
    • Labels:
      None

      Description

      As per JdoMetaModelValidator:

                      if(!found) {
                          validationFailures.add("No @PersistenceCapable entities found. " +
                                  "(Are the entities referenced by the registered services? " + 
                                  "are all services registered? " + 
                                  "did the DataNucleus enhancer run?)");
                      }
      

      because it's perfectly valid to have an Isis app with no persisted entities, just view models.

        Attachments

          Activity

            People

            • Assignee:
              danhaywood Dan Haywood
              Reporter:
              danhaywood Dan Haywood
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: