Uploaded image for project: 'Isis'
  1. Isis
  2. ISIS-1482

Occasional(?) exception in i18n PoWriter, looks like a concurrent access problem

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.13.0
    • Fix Version/s: 1.13.1
    • Component/s: Core
    • Labels:
      None

      Description

      Did not manifest in the UI, but present as a stacktrace (below).

      This SO article http://stackoverflow.com/questions/37048084/is-this-null-pointer-exception-in-treemap-due-to-concurrent-access suggests concurrent exception.

      Fix probably to introduce the 'synchronized' keyword at some judicious point.

      stacktrace:

      00:05:59,617 [RequestCycleExtra             ] ********************************
      00:05:59,617 [RequestCycleExtra             ] Handling the following exception
      org.apache.wicket.WicketRuntimeException: Exception in rendering component: [MessageContainer [Component id = _message_5]]
      	at org.apache.wicket.Component.internalRenderComponent(Component.java:2560)
      	at org.apache.wicket.MarkupContainer.onRender(MarkupContainer.java:1496)
      	at org.apache.wicket.Component.internalRender(Component.java:2366)
      	at org.apache.wicket.Component.render(Component.java:2294)
      	at org.apache.wicket.MarkupContainer.renderNext(MarkupContainer.java:1392)
      	at org.apache.wicket.MarkupContainer.renderAll(MarkupContainer.java:1557)
      	at org.apache.wicket.MarkupContainer.renderComponentTagBody(MarkupContainer.java:1532)
      	at org.apache.wicket.MarkupContainer.onComponentTagBody(MarkupContainer.java:1487)
      	at org.apache.wicket.markup.html.panel.DefaultMarkupSourcingStrategy.onComponentTagBody(DefaultMarkupSourcingStrategy.java:71)
      	at org.apache.wicket.Component.internalRenderComponent(Component.java:2536)
      	at org.apache.wicket.MarkupContainer.onRender(MarkupContainer.java:1496)
      	at org.apache.wicket.Component.internalRender(Component.java:2366)
      	at org.apache.wicket.Component.render(Component.java:2294)
      	at org.apache.wicket.MarkupContainer.renderNext(MarkupContainer.java:1392)
      	at org.apache.wicket.MarkupContainer.renderAll(MarkupContainer.java:1557)
      	at org.apache.wicket.MarkupContainer.renderComponentTagBody(MarkupContainer.java:1532)
      	at org.apache.wicket.MarkupContainer.onComponentTagBody(MarkupContainer.java:1487)
      	at org.apache.wicket.markup.html.form.Form.onComponentTagBody(Form.java:1743)
      	at org.apache.wicket.markup.html.panel.DefaultMarkupSourcingStrategy.onComponentTagBody(DefaultMarkupSourcingStrategy.java:71)
      	at org.apache.wicket.Component.internalRenderComponent(Component.java:2536)
      	at org.apache.wicket.MarkupContainer.onRender(MarkupContainer.java:1496)
      	at org.apache.wicket.Component.internalRender(Component.java:2366)
      	at org.apache.wicket.Component.render(Component.java:2294)
      	at org.apache.wicket.MarkupContainer.renderNext(MarkupContainer.java:1392)
      	at org.apache.wicket.MarkupContainer.renderAll(MarkupContainer.java:1557)
      	at org.apache.wicket.MarkupContainer.renderComponentTagBody(MarkupContainer.java:1532)
      	at org.apache.wicket.MarkupContainer.renderAssociatedMarkup(MarkupContainer.java:689)
      	at org.apache.wicket.markup.html.panel.AssociatedMarkupSourcingStrategy.renderAssociatedMarkup(AssociatedMarkupSourcingStrategy.java:76)
      	at org.apache.wicket.markup.html.panel.PanelMarkupSourcingStrategy.onComponentTagBody(PanelMarkupSourcingStrategy.java:112)
      	at org.apache.wicket.Component.internalRenderComponent(Component.java:2536)
      	at org.apache.wicket.MarkupContainer.onRender(MarkupContainer.java:1496)
      	at org.apache.wicket.Component.internalRender(Component.java:2366)
      	at org.apache.wicket.Component.render(Component.java:2294)
      	at org.apache.wicket.MarkupContainer.renderNext(MarkupContainer.java:1392)
      	at org.apache.wicket.MarkupContainer.renderAll(MarkupContainer.java:1557)
      	at org.apache.wicket.MarkupContainer.renderComponentTagBody(MarkupContainer.java:1532)
      	at org.apache.wicket.MarkupContainer.onComponentTagBody(MarkupContainer.java:1487)
      	at org.apache.wicket.markup.html.panel.DefaultMarkupSourcingStrategy.onComponentTagBody(DefaultMarkupSourcingStrategy.java:71)
      	at org.apache.wicket.Component.internalRenderComponent(Component.java:2536)
      	at org.apache.wicket.MarkupContainer.onRender(MarkupContainer.java:1496)
      	at org.apache.wicket.Component.internalRender(Component.java:2366)
      	at org.apache.wicket.Component.render(Component.java:2294)
      	at org.apache.wicket.MarkupContainer.renderNext(MarkupContainer.java:1392)
      	at org.apache.wicket.MarkupContainer.renderAll(MarkupContainer.java:1557)
      	at org.apache.wicket.MarkupContainer.renderComponentTagBody(MarkupContainer.java:1532)
      	at org.apache.wicket.MarkupContainer.onComponentTagBody(MarkupContainer.java:1487)
      	at org.apache.wicket.markup.html.panel.DefaultMarkupSourcingStrategy.onComponentTagBody(DefaultMarkupSourcingStrategy.java:71)
      	at org.apache.wicket.Component.internalRenderComponent(Component.java:2536)
      	at org.apache.wicket.MarkupContainer.onRender(MarkupContainer.java:1496)
      	at org.apache.wicket.Component.internalRender(Component.java:2366)
      	at org.apache.wicket.Component.render(Component.java:2294)
      	at org.apache.wicket.MarkupContainer.renderNext(MarkupContainer.java:1392)
      	at org.apache.wicket.MarkupContainer.renderAll(MarkupContainer.java:1557)
      	at org.apache.wicket.Page.onRender(Page.java:887)
      	at org.apache.wicket.markup.html.WebPage.onRender(WebPage.java:143)
      	at org.apache.wicket.Component.internalRender(Component.java:2366)
      	at org.apache.wicket.Component.render(Component.java:2294)
      	at org.apache.wicket.Page.renderPage(Page.java:1024)
      	at org.apache.wicket.request.handler.render.WebPageRenderer.renderPage(WebPageRenderer.java:139)
      	at org.apache.wicket.request.handler.render.WebPageRenderer.respond(WebPageRenderer.java:229)
      	at org.apache.wicket.core.request.handler.RenderPageRequestHandler.respond(RenderPageRequestHandler.java:175)
      	at org.apache.wicket.request.cycle.RequestCycle$HandlerExecutor.respond(RequestCycle.java:890)
      	at org.apache.wicket.request.RequestHandlerStack.execute(RequestHandlerStack.java:64)
      	at org.apache.wicket.request.cycle.RequestCycle.execute(RequestCycle.java:261)
      	at org.apache.wicket.request.cycle.RequestCycle.processRequest(RequestCycle.java:218)
      	at org.apache.wicket.request.cycle.RequestCycle.processRequestAndDetach(RequestCycle.java:289)
      	at org.apache.wicket.protocol.http.WicketFilter.processRequestCycle(WicketFilter.java:259)
      	at org.apache.wicket.protocol.http.WicketFilter.processRequest(WicketFilter.java:201)
      	at org.apache.wicket.protocol.http.WicketFilter.doFilter(WicketFilter.java:282)
      	at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1668)
      	at org.apache.isis.core.webapp.diagnostics.IsisLogOnExceptionFilter.doFilter(IsisLogOnExceptionFilter.java:52)
      	at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1668)
      	at org.apache.shiro.web.servlet.AbstractShiroFilter.executeChain(AbstractShiroFilter.java:449)
      	at org.apache.shiro.web.servlet.AbstractShiroFilter$1.call(AbstractShiroFilter.java:365)
      	at org.apache.shiro.subject.support.SubjectCallable.doCall(SubjectCallable.java:90)
      	at org.apache.shiro.subject.support.SubjectCallable.call(SubjectCallable.java:83)
      	at org.apache.shiro.subject.support.DelegatingSubject.execute(DelegatingSubject.java:383)
      	at org.apache.shiro.web.servlet.AbstractShiroFilter.doFilterInternal(AbstractShiroFilter.java:362)
      	at org.apache.shiro.web.servlet.OncePerRequestFilter.doFilter(OncePerRequestFilter.java:125)
      	at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1668)
      	at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:581)
      	at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:143)
      	at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:548)
      	at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:226)
      	at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1158)
      	at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:511)
      	at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:185)
      	at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:1090)
      	at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:141)
      	at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:119)
      	at org.eclipse.jetty.server.Server.handle(Server.java:517)
      	at org.eclipse.jetty.server.HttpChannel.handle(HttpChannel.java:308)
      	at org.eclipse.jetty.server.HttpConnection.onFillable(HttpConnection.java:242)
      	at org.eclipse.jetty.io.AbstractConnection$ReadCallback.succeeded(AbstractConnection.java:261)
      	at org.eclipse.jetty.io.FillInterest.fillable(FillInterest.java:95)
      	at org.eclipse.jetty.io.SelectChannelEndPoint$2.run(SelectChannelEndPoint.java:75)
      	at org.eclipse.jetty.util.thread.strategy.ExecuteProduceConsume.produceAndRun(ExecuteProduceConsume.java:213)
      	at org.eclipse.jetty.util.thread.strategy.ExecuteProduceConsume.run(ExecuteProduceConsume.java:147)
      	at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:654)
      	at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:572)
      	at java.lang.Thread.run(Thread.java:745)
      Caused by: java.lang.RuntimeException: An error occurred while executing code in a temporary session
      	at org.apache.isis.core.runtime.system.session.IsisSessionFactory.doInSession(IsisSessionFactory.java:349)
      	at org.apache.isis.core.runtime.system.session.IsisSessionFactory.doInSession(IsisSessionFactory.java:327)
      	at org.apache.isis.viewer.wicket.viewer.integration.wicket.LocalizerForIsis.translate(LocalizerForIsis.java:75)
      	at org.apache.isis.viewer.wicket.viewer.integration.wicket.LocalizerForIsis.getString(LocalizerForIsis.java:62)
      	at org.apache.wicket.Localizer.getString(Localizer.java:201)
      	at org.apache.wicket.Localizer.getString(Localizer.java:150)
      	at org.apache.wicket.markup.resolver.WicketMessageResolver$MessageContainer.onComponentTagBody(WicketMessageResolver.java:203)
      	at org.apache.wicket.markup.html.panel.DefaultMarkupSourcingStrategy.onComponentTagBody(DefaultMarkupSourcingStrategy.java:71)
      	at org.apache.wicket.Component.internalRenderComponent(Component.java:2536)
      	... 100 more
      Caused by: java.lang.NullPointerException
      	at java.util.TreeMap.rotateLeft(TreeMap.java:2224)
      	at java.util.TreeMap.fixAfterInsertion(TreeMap.java:2291)
      	at java.util.TreeMap.put(TreeMap.java:582)
      	at org.apache.isis.core.runtime.services.i18n.po.PoWriter.blockFor(PoWriter.java:143)
      	at org.apache.isis.core.runtime.services.i18n.po.PoWriter.translate(PoWriter.java:120)
      	at org.apache.isis.core.runtime.services.i18n.po.TranslationServicePo.translate(TranslationServicePo.java:103)
      	at org.apache.isis.viewer.wicket.viewer.integration.wicket.LocalizerForIsis.translate(LocalizerForIsis.java:144)
      	at org.apache.isis.viewer.wicket.viewer.integration.wicket.LocalizerForIsis.access$000(LocalizerForIsis.java:45)
      	at org.apache.isis.viewer.wicket.viewer.integration.wicket.LocalizerForIsis$1.call(LocalizerForIsis.java:78)
      	at org.apache.isis.viewer.wicket.viewer.integration.wicket.LocalizerForIsis$1.call(LocalizerForIsis.java:75)
      	at org.apache.isis.core.runtime.system.session.IsisSessionFactory.doInSession(IsisSessionFactory.java:347)
      	... 108 more
      
      1. screenshot-1.png
        278 kB
        Dan Haywood

        Activity

        danhaywood Dan Haywood added a comment -

        further issue, see screenshot. This manifested itself as freezing up the app (none responsive when trying to render). I'm guessing some sort of deadlock.

        jira-bot ASF subversion and git services added a comment -

        Commit 325b51e4248c1a92191d6073b4d95776b50c5a28 in isis's branch refs/heads/master from Dan Haywood
        [ https://git-wip-us.apache.org/repos/asf?p=isis.git;h=325b51e ]

        ISIS-1482: synchronizes access to PoWriter, to avoid deadlocks

        jira-bot ASF subversion and git services added a comment -

        Commit fd7f1052924b71b697f4b424d66da4dbd2a7cfcf in isis's branch refs/heads/maint-1.13.1 from Dan Haywood
        [ https://git-wip-us.apache.org/repos/asf?p=isis.git;h=fd7f105 ]

        ISIS-1482: synchronizes access to PoWriter, to avoid deadlocks

        jira-bot ASF subversion and git services added a comment -

        Commit fd7f1052924b71b697f4b424d66da4dbd2a7cfcf in isis's branch refs/heads/master from Dan Haywood
        [ https://git-wip-us.apache.org/repos/asf?p=isis.git;h=fd7f105 ]

        ISIS-1482: synchronizes access to PoWriter, to avoid deadlocks


          People

          • Assignee:
            danhaywood Dan Haywood
            Reporter:
            danhaywood Dan Haywood
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development