Uploaded image for project: 'Isis'
  1. Isis
  2. ISIS-1315

Can't generate swagger specs, where actions are contributed.

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.11.1
    • Fix Version/s: 1.12.0
    • Component/s: None
    • Labels:
      None

      Description

      as per http://isis.markmail.org/thread/gn3ijffsxhnslphn

      The issue is that the metamodel cannot be properly created without a session.

        Issue Links

          Activity

          danhaywood Dan Haywood added a comment -

          To test, added:

          @DomainService(nature = NatureOfService.VIEW_CONTRIBUTIONS_ONLY)
          public class SimpleObjectContrib  {
          
              @Action(semantics = SemanticsOf.SAFE)
              @ActionLayout(
                      contributed = Contributed.AS_BOTH
              )
              public List<SimpleObject> all(SimpleObject object) {
                  return simpleObjects.listAll();
              }
          
              @Action(semantics = SemanticsOf.SAFE)
              @ActionLayout(
                      contributed = Contributed.AS_ASSOCIATION
              )
              public SimpleObject other(SimpleObject object) {
                  return object;
              }
          
              @Inject
              SimpleObjects simpleObjects;
          
          }
          

          for the simpleapp.

          danhaywood Dan Haywood added a comment -

          Looks like this is fixed in 1.12.0 as result of other changes (possibly the ApplicationFeatureRepository service brought in ISIS-1292). What is required is to run the swagger mojo within the integtests project, rather than the dom, and specify the regular AppManifest (from the app module) rather than the manifest in the dom module.

          Will update docs.

          jira-bot ASF subversion and git services added a comment -

          Commit 65860b6aa77072dd8947ca3be4a449358c2f7fa0 in isis's branch refs/heads/master from Dan Haywood
          [ https://git-wip-us.apache.org/repos/asf?p=isis.git;h=65860b6 ]

          ISIS-1315: updating docs for swagger goal.

          In addition, moved the isis maven plugin to its own reference guide, and renamed the cgcon "contributors guide" to "developers' guide" (didn't change file names or links, though).


            People

            • Assignee:
              danhaywood Dan Haywood
              Reporter:
              danhaywood Dan Haywood
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development