Uploaded image for project: 'Isis'
  1. Isis
  2. ISIS-1276

Update DN to 5.1.x (from DN 4.1.x)

    Details

    • Type: Dependency upgrade
    • Status: Closed
    • Priority: Major
    • Resolution: Resolved
    • Affects Version/s: 1.10.0
    • Fix Version/s: 2.0.0-M1
    • Component/s: Core
    • Labels:
      None

      Description

      Update: With v2.0.0-M1 'IsisJdoSupport' is provided by 'jdo-datanucleus-x' plugins. Developers may pick the 'dn-4' plugin, if they still need to use 'TypesafeQuery'.

      Note that this will break IsisJdoSupport since the TypesafeQuery class is removed. While strictly speaking we ought to bump to Isis v2.0.0 because it is a breaking change, I think in this particular instance we make an exception: my guess is that not may are using that particular API.

      http://www.datanucleus.org/products/accessplatform_5_1/migration.html

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                danhaywood Dan Haywood
                Reporter:
                danhaywood Dan Haywood
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: