Uploaded image for project: 'Isis'
  1. Isis
  2. ISIS-1132

possible timezone issues when refresh page in Wicket viewer.

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: core-1.8.0
    • Fix Version/s: 1.12.2
    • Component/s: Core: Viewer: Wicket
    • Labels:
      None

      Description

      The issue is reproducible in the latest kitchensink demo application which uses Isis 1.8.0.

      When a form page is opened and the URL in the browser is like - ".../wicket/entity?15" and the page is refreshed, following happens:

      • All "org.joda.time.DateTime" fields are changed, so they have "03:00" at the end. (ex. It was ...00:00 and becomes ...03:00)
      • The splitters in the menus disappear.
        I suppose there can be some other issues too.

      The URL becomes like ".../wicket/entity?15" after a form is edited or if you click for example on the "First DateObject" menu item in kitchensink app. If the URL is like ".../wicket/entity/DATE:L_0" it works normally.

        Issue Links

          Activity

          jira-bot ASF subversion and git services added a comment -

          Commit 1dd64e618aebb85669ac8ceeed8deefc89c25c34 in isis's branch refs/heads/master from Dan Haywood
          [ https://git-wip-us.apache.org/repos/asf?p=isis.git;h=1dd64e6 ]

          ISIS-1132: finally, the fix... the (legacy) Isis encoder/decoder stuff is used to copy the value from the object into the action parameter; the impl for joda DateTime was missing the time portion, so was defaulting to +1:00 (presumably due to locale, GMT+1 hour).

          jira-bot ASF subversion and git services added a comment -

          Commit adcbcf8140a4ccc52e9ab46e4a31be4f17ac4aaa in isis's branch refs/heads/master from Dan Haywood
          [ https://git-wip-us.apache.org/repos/asf?p=isis.git;h=adcbcf8 ]

          ISIS-1132: finally, the fix... the (legacy) Isis encoder/decoder stuff is used to copy the value from the object into the action parameter; the impl for joda DateTime was missing the time portion, so was defaulting to +1:00 (presumably due to locale, GMT+1 hour).

          jira-bot ASF subversion and git services added a comment -

          Commit b332a8bd9e3c5a7ccd16ecccbb3e14342b6d04c2 in isis's branch refs/heads/master from Dan Haywood
          [ https://git-wip-us.apache.org/repos/asf?p=isis.git;h=b332a8b ]

          ISIS-1132: further refactoring (no functional change) - showing how the bootstrap datetime config is built from the converter's dateTime pattern.

          jira-bot ASF subversion and git services added a comment -

          Commit eb90e2991de4355db481224d717a7c8de4ae688c in isis's branch refs/heads/master from Dan Haywood
          [ https://git-wip-us.apache.org/repos/asf?p=isis.git;h=eb90e29 ]

          ISIS-1132: refactoring (no functional changes) ... rationalized and simplified the DataConverterForJoda hierarchy of classes.

          jira-bot ASF subversion and git services added a comment -

          Commit a2197cd52e2feac31bb54dec95193181ec058a36 in isis's branch refs/heads/master from Dan Haywood
          [ https://git-wip-us.apache.org/repos/asf?p=isis.git;h=a2197cd ]

          ISIS-1132: refactoring (no functional changes) in order to understand current design better.

          It seems that the datepicker pattern is not actually used; instead we read either the datePattern or the dateTimePattern and - if there is the picker for the component - then convert the format to moment.js format (as used by the bootstrap3 cpt we are using) on-the-fly.

          jira-bot ASF subversion and git services added a comment -

          Commit 1dd64e618aebb85669ac8ceeed8deefc89c25c34 in isis's branch refs/heads/maintenance-1.12.x from Dan Haywood
          [ https://git-wip-us.apache.org/repos/asf?p=isis.git;h=1dd64e6 ]

          ISIS-1132: finally, the fix... the (legacy) Isis encoder/decoder stuff is used to copy the value from the object into the action parameter; the impl for joda DateTime was missing the time portion, so was defaulting to +1:00 (presumably due to locale, GMT+1 hour).

          mgrigorov Martin Grigorov added a comment -

          The problem with the splitters in the menus is fixed with ISIS-1175.


            People

            • Assignee:
              danhaywood Dan Haywood
              Reporter:
              Boris.Toninski Boris Toninski
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development