Uploaded image for project: 'Isis'
  1. Isis
  2. ISIS-1093

Integrate Wicket's i18n requirements with Isis' TranslationPoService.

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: core-1.8.0
    • Fix Version/s: 1.11.0
    • Component/s: Core
    • Labels:
      None

      Description

      Currently Wicket's i18n support (via property files) is not associated with Isis' new TranslationService.

      This ticket is to integrate them somehow so that the developer has only the translations.po file to maintain.

      use https://github.com/apache/wicket/blob/master/wicket-core/src/main/java/org/apache/wicket/Localizer.java

      see also https://cwiki.apache.org/confluence/display/WICKET/Everything+about+Wicket+internationalization

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              danhaywood Dan Haywood
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: