OK, point taken.
How about adding new copyFileXX() and copyDirectoryXX() methods that do report failures?
I don't think there's any point in adding a boolean reportError parameter as it would only apply if preserveDates is true, so the methods would need new names.
It's a pity that changing the return from void to boolean is not binary compatible, otherwise that would be an easy solution.
Maybe consider doing that for a major version update?
However the private internal copy methods could be changed to return true/false without affecting binary compatibility of the public API.