Commons IO
  1. Commons IO
  2. IO-196

Occasional FileSystemObserver test failures

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.0
    • Component/s: None
    • Labels:
      None

      Description

      The FilesystemObserverTestCase method testFileCreate() fails occasionally in the Continuum build at http://vmbuild.apache.org/continuum/projectView.action?projectId=155. The failure, when it happens, is:

      FilesystemObserverTestCase
      testFileCreate :
      junit.framework.AssertionFailedError
      junit.framework.AssertionFailedError: E[0 0 0 1 0 0]: No. of directories changed expected:<1> but was:<0>
      at junit.framework.Assert.fail(Assert.java:47)
      at junit.framework.Assert.failNotEquals(Assert.java:282)
      at junit.framework.Assert.assertEquals(Assert.java:64)
      at junit.framework.Assert.assertEquals(Assert.java:201)
      at org.apache.commons.io.monitor.FilesystemObserverTestCase.checkCollectionSizes(FilesystemObserverTestCase.java:424)
      at org.apache.commons.io.monitor.FilesystemObserverTestCase.testFileCreate(FilesystemObserverTestCase.java:203)

        Activity

        Niall Pemberton added a comment -

        Here are the recent gump failures from the mail archive - can't tell the cause though because gump only emails a portion of the output:

        Gump	Aug 4, 2010 2:24 am	
        Gump	Aug 9, 2010 8:08 pm	
        Gump	Aug 10, 2010 7:26 am	
        Gump	Aug 11, 2010 7:39 am	
        Gump	Aug 13, 2010 1:38 am	
        Gump	Aug 13, 2010 7:40 pm	
        Gump	Aug 17, 2010 7:13 am	
        Gump	Aug 22, 2010 1:30 pm	
        Gump	Aug 24, 2010 1:31 am	
        Gump	Aug 24, 2010 1:54 pm	
        Gump	Aug 25, 2010 1:42 am	
        Gump	Aug 27, 2010 7:22 am	
        Gump	Aug 27, 2010 7:18 pm	
        Gump	Aug 28, 2010 7:17 pm	
        Gump	Aug 29, 2010 7:17 pm	
        Gump	Aug 30, 2010 7:27 pm	
        Gump	Aug 31, 2010 7:31 pm	
        Gump	Sep 1, 2010 8:41 am	
        Gump	Sep 1, 2010 7:36 pm	
        Gump	Sep 2, 2010 7:11 pm	
        Gump	Sep 3, 2010 7:11 am	
        Gump	Sep 3, 2010 7:11 pm	
        Gump	Sep 4, 2010 7:08 pm	
        Gump	Sep 6, 2010 7:15 pm	
        Gump	Sep 7, 2010 7:17 pm	
        Gump	Sep 8, 2010 7:20 am	
        Gump	Sep 8, 2010 7:26 pm	
        Gump	Sep 9, 2010 7:30 pm	
        Gump	Sep 10, 2010 7:23 pm	
        Gump	Sep 11, 2010 7:19 pm	
        Gump	Sep 12, 2010 7:14 pm	
        Gump	Sep 13, 2010 7:24 pm	
        Gump	Sep 14, 2010 7:25 pm	
        Gump	Sep 15, 2010 7:23 pm	
        Gump	Sep 16, 2010 7:33 pm	
        Gump	Sep 18, 2010 2:16 am	
        Gump	Sep 19, 2010 1:27 am	
        Gump	Sep 19, 2010 1:14 pm	
        Gump	Sep 20, 2010 1:28 am	
        Gump	Sep 21, 2010 2:17 am	
        Gump	Sep 22, 2010 1:31 am	
        Gump	Sep 24, 2010 1:40 am	
        Gump	Sep 25, 2010 1:34 pm	
        Gump	Sep 26, 2010 1:29 am	
        Gump	Sep 27, 2010 1:28 am	
        Gump	Sep 28, 2010 1:28 am	
        Gump	Sep 29, 2010 1:31 am	
        Gump	Oct 1, 2010 1:38 am	
        Gump	Oct 2, 2010 1:27 am	
        Gump	Oct 3, 2010 2:27 am	
        Gump	Oct 3, 2010 1:37 pm	
        Gump	Oct 7, 2010 1:33 am	
        
        Niall Pemberton added a comment - - edited

        Here is the full log of Contiuum builds to date - along with all the causes of the FAILED builds and what changes were made to try and improve the situation:

        52	Oct 08, 2010 01:28:59 AM UTC
        51	Oct 08, 2010 12:33:07 AM UTC
        --------------------------------------------------------------------------
        FileSystemMonitorTestCase - revert r1002909 and try alternative fix for failures
        --------------------------------------------------------------------------
        50	Oct 07, 2010 05:27:22 PM UTC
        --------------------------------------------------------------------------
        FileCleaningTrackerTestCase - try to fix Gump OutOfMemoryError in r1005515
        --------------------------------------------------------------------------
        49	Oct 07, 2010 09:22:54 AM UTC
        48	Oct 06, 2010 05:50:07 PM UTC
        47	Oct 06, 2010 04:33:01 PM UTC
        46	Oct 06, 2010 04:20:27 AM UTC
        45	Oct 06, 2010 03:20:30 AM UTC
        44	Oct 06, 2010 02:20:36 AM UTC
        43	Oct 06, 2010 01:20:50 AM UTC
        42	Oct 06, 2010 12:22:09 AM UTC
        41	Oct 05, 2010 11:22:04 PM UTC
        40	Oct 05, 2010 10:22:06 PM UTC
        39	Oct 05, 2010 06:20:40 PM UTC
        38	Oct 05, 2010 04:20:32 AM UTC
        37	Oct 05, 2010 03:20:28 AM UTC
        36	Oct 05, 2010 01:22:16 AM UTC
        35	Oct 04, 2010 11:33:52 PM UTC
        34	Oct 04, 2010 09:27:46 PM UTC
        33	Oct 04, 2010 08:31:43 PM UTC
         	Oct 04, 2010 07:31:19 PM UTC ERROR - FileCleaningTrackerTestCase - OutOfMemoryError: Java heap space
        32	Oct 04, 2010 06:20:44 PM UTC
        31	Oct 04, 2010 06:20:52 AM UTC
        30	Oct 04, 2010 05:20:33 AM UTC
         	Oct 04, 2010 04:22:37 AM UTC ERROR - FileSystemMonitorTestCase - Delete ./test-observer/file1.java not found
         	Oct 04, 2010 03:22:05 AM UTC ERROR - TailerTest - AssertionFailedError: fileNotFound should not be called expected:<0> but was:<241>
         	Oct 04, 2010 01:22:02 AM UTC ERROR - FileCleaningTrackerTestCase - OutOfMemoryError: Java heap space
        29	Oct 04, 2010 12:20:42 AM UTC
        28	Oct 03, 2010 11:33:49 PM UTC
        27	Oct 02, 2010 01:20:27 AM UTC
        26	Oct 01, 2010 11:20:33 PM UTC
        25	Oct 01, 2010 10:20:41 PM UTC
        24	Oct 01, 2010 09:47:52 PM UTC
        23	Oct 01, 2010 05:20:33 PM UTC
        22	Oct 01, 2010 03:29:58 AM UTC
        21	Oct 01, 2010 02:19:26 AM UTC
        20	Oct 01, 2010 01:20:35 AM UTC
        19	Sep 30, 2010 11:20:40 PM UTC
        18	Sep 30, 2010 10:20:52 PM UTC
        17	Sep 30, 2010 09:20:33 PM UTC
        16	Sep 30, 2010 08:20:42 PM UTC
        15	Sep 30, 2010 05:32:39 PM UTC
        14	Sep 30, 2010 04:20:31 PM UTC
        13	Sep 30, 2010 03:20:44 AM UTC
        12	Sep 30, 2010 02:20:38 AM UTC
        -----------------------------------------------------------------------
        FileCleaningTrackerTestCase - try to fix OutOfMemoryError in r1002920
        -----------------------------------------------------------------------
        11	Sep 30, 2010 01:20:40 AM UTC
        -----------------------------------------------------------------------
        FileSystemMonitorTestCase changed to try to reduce failures in r1002909
        FileSystemUtilsTestCase fixed broken test in r1002794
        -----------------------------------------------------------------------
        	Sep 29, 2010 10:20:31 PM UTC ERROR - FileSystemUtilsTestCase & FileCleaningTrackerTestCase
         	Sep 29, 2010 09:20:31 PM UTC ERROR - FileSystemUtilsTestCase & FileCleaningTrackerTestCase
         	Sep 29, 2010 08:20:39 PM UTC ERROR - FileSystemUtilsTestCase 
         	Sep 29, 2010 07:20:28 PM UTC ERROR - FileSystemMonitorTestCase - testFileDelete E[0 0 0 0 0 1]
         	Sep 29, 2010 06:21:07 PM UTC ERROR - FileCleaningTrackerTestCase - OutOfMemoryError: Java heap space
                Sep 29, 2010 04:20:35 PM UTC Compile Error :(
         	Sep 29, 2010 12:20:50 PM UTC ERROR - FileCleaningTrackerTestCase - OutOfMemoryError: Java heap space
        10	Sep 29, 2010 04:20:29 AM UTC
         	Sep 29, 2010 02:20:39 AM UTC ERROR - FileSystemMonitorTestCase - testFileCreate F[0 0 0 1 0 0]
        9	Sep 29, 2010 01:20:44 AM UTC
        8	Sep 29, 2010 12:34:15 AM UTC
        7	Sep 28, 2010 11:20:36 PM UTC
         	Sep 28, 2010 10:33:14 PM UTC ERROR - FileSystemMonitorTestCase - testFileCreate E[0 0 0 1 0 0]
        6	Sep 28, 2010 03:31:34 PM UTC
        5	Sep 28, 2010 02:20:32 PM UTC
        4	Sep 28, 2010 01:20:27 PM UTC
         	Sep 09, 2010 07:20:45 PM UTC ERROR - FileSystemMonitorTestCase - testFileCreate E[0 0 0 1 0 0]
        3	Sep 09, 2010 02:20:31 PM UTC
        2	Sep 08, 2010 05:36:10 PM UTC
         	Sep 08, 2010 03:20:51 PM UTC ERROR - FileCleaningTrackerTestCase - OutOfMemoryError: Java heap space
        1	Aug 18, 2010 07:51:32 PM UTC
         	Aug 18, 2010 06:36:38 PM UTC ERROR - FileCleaningTrackerTestCase - OutOfMemoryError: Java heap space
         	Aug 18, 2010 04:51:30 PM UTC ERROR - FileCleaningTrackerTestCase - OutOfMemoryError: Java heap space
        
        Niall Pemberton added a comment -

        Continuum doesn't have much historical data at the moment - the following shows all the builds where FilesystemObserverTestCase ran and in which ones it failed:

         	Sep 29, 2010 10:20:31 PM UTC OK
         	Sep 29, 2010 09:20:31 PM UTC OK
         	Sep 29, 2010 08:20:39 PM UTC OK
         	Sep 29, 2010 07:20:28 PM UTC testFileDelete E[0 0 0 0 0 1]: No. of directories changed expected:<1> but was:<0>
         	Sep 29, 2010 06:21:07 PM UTC OK
         	Sep 29, 2010 12:20:50 PM UTC OK
        10	Sep 29, 2010 04:20:29 AM UTC OK
         	Sep 29, 2010 02:20:39 AM UTC testFileCreate F[0 0 0 1 0 0]: No. of directories changed expected:<1> but was:<0>
        9	Sep 29, 2010 01:20:44 AM UTC OK
        8	Sep 29, 2010 12:34:15 AM UTC OK
        7	Sep 28, 2010 11:20:36 PM UTC OK
         	Sep 28, 2010 10:33:14 PM UTC testFileCreate E[0 0 0 1 0 0]: No. of directories changed expected:<1> but was:<0>
        6	Sep 28, 2010 03:31:34 PM UTC OK
        5	Sep 28, 2010 02:20:32 PM UTC OK
        4	Sep 28, 2010 01:20:27 PM UTC OK
         	Sep 09, 2010 07:20:45 PM UTC testFileCreate E[0 0 0 1 0 0]: No. of directories changed expected:<1> but was:<0>
        3	Sep 09, 2010 02:20:31 PM UTC OK
        2	Sep 08, 2010 05:36:10 PM UTC OK
         	Sep 08, 2010 03:20:51 PM UTC OK
        1	Aug 18, 2010 07:51:32 PM UTC OK
         	Aug 18, 2010 06:36:38 PM UTC OK
         	Aug 18, 2010 04:51:30 PM UTC OK
        

        I then made some changes to FilesystemObserverTestCase to hopefully reduce the failures:

        http://svn.apache.org/viewvc?view=revision&revision=1002909

        Since then it has run 10 times without failing:

        20	Oct 01, 2010 01:20:35 AM UTC
        19	Sep 30, 2010 11:20:40 PM UTC
        18	Sep 30, 2010 10:20:52 PM UTC
        17	Sep 30, 2010 09:20:33 PM UTC
        16	Sep 30, 2010 08:20:42 PM UTC
        15	Sep 30, 2010 05:32:39 PM UTC
        14	Sep 30, 2010 04:20:31 PM UTC
        13	Sep 30, 2010 03:20:44 AM UTC
        12	Sep 30, 2010 02:20:38 AM UTC
        11	Sep 30, 2010 01:20:40 AM UTC
        
        Jukka Zitting added a comment -

        Also the following test fails occasionally:

        FilesystemObserverTestCase
        testFileDelete :
        junit.framework.AssertionFailedError
        junit.framework.AssertionFailedError: E[0 0 0 0 0 1]: No. of directories changed expected:<1> but was:<0>
        at junit.framework.Assert.fail(Assert.java:47)
        at junit.framework.Assert.failNotEquals(Assert.java:282)
        at junit.framework.Assert.assertEquals(Assert.java:64)
        at junit.framework.Assert.assertEquals(Assert.java:201)
        at org.apache.commons.io.monitor.FilesystemObserverTestCase.checkCollectionSizes(FilesystemObserverTestCase.java:424)
        at org.apache.commons.io.monitor.FilesystemObserverTestCase.testFileDelete(FilesystemObserverTestCase.java:324)


          People

          • Assignee:
            Unassigned
            Reporter:
            Jukka Zitting
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development