Uploaded image for project: 'Infrastructure'
  1. Infrastructure
  2. INFRA-7915

Identify shared resource issues interfering with Nexus

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Fix Version/s: Jul 2014
    • Component/s: Nexus, VMWare
    • Labels:
      None

      Description

      I am receiving random reports of timeouts and inaccessability of repository.apache.org. When this happens, the process always appears to be happily running along although with high load, sometimes 5+. Do we have visibility into the shared resources on the same host and/or the shared disks that might explain this?

      See https://issues.apache.org/jira/browse/INFRA-7812

        Issue Links

          Activity

          brianf Brian Fox added a comment - Reporter
          I believe we identified the root cause as being hundreds of zombie puppet processes. The kill puppet script is now part of the root cronjob to take care of this daily. Since making the change, things have stabilized.

            People

            • Assignee:
              Unassigned
              Reporter:
              brianf Brian Fox
              Request participants:
              None
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: