Infrastructure
  1. Infrastructure
  2. INFRA-6736

Remove and disable HTML export for Hive wiki

    Details

    • Type: Task Task
    • Status: Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Fix Version/s: Initial Clearing
    • Component/s: Confluence
    • Labels:
      None

      Description

      Hive has its Wiki at https://cwiki.apache.org/confluence/display/Hive/Home. Unfortunately there is also a HTML export version at https://cwiki.apache.org/Hive/home.html

      This HTML version comes up first in all Google searches but it's styles and links are broken and people are complaining about it on the mailing list.

      It'd be great if this export could be deleted and disabled.

      (I'm not a Hive committer but I'll ask them to verify this here)

      Thanks,
      Lars

        Activity

        Lefty Leverenz added a comment -
        I'm not a committer either but I can verify that the {code} style comes up blank and many wikidoc links give "404 Not Found" in the HTML export version.

        Broken code examples:

        * DDL -- [https://cwiki.apache.org/Hive/languagemanual-ddl.html]
        * DML -- [https://cwiki.apache.org/Hive/languagemanual-dml.html]

        Broken links on Home page:

        * Getting Started -- [https://cwiki.apache.org/Hive/gettingstarted.html]
        * Hive Tutorial -- [https://cwiki.apache.org/Hive/tutorial.html]

        Any code samples that do appear are marked up with {noformat} instead of {code}. You can tell at a glance because the box around the sample is a solid line for {noformat} and a dashed line for {code}.
        Carl Steinbach added a comment -
        I'm a Hive committer and can confirm that this is a serious issue. Some help from ASF INFRA would be greatly appreciated. Thanks.
        Ulrich Stärk added a comment -
        I cannot access the URLs you mention. The autoexport sites have been removed some time ago.
        Lars Francke added a comment -
        Excellent! Thanks to whomever made this happen.

        Must have been fixed sometimes in the last month.
        Thejas M Nair added a comment -
        awesome! where is the like button?!
        Lefty Leverenz added a comment -

          People

          • Assignee:
            Unassigned
            Reporter:
            Lars Francke
          • Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development