Infrastructure
  1. Infrastructure
  2. INFRA-6678

Add full archive for Apache Flex user and dev forums

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Fix Version/s: Initial Clearing
    • Component/s: None
    • Labels:
      None

      Description

      For the Nabble user forms to be more useful we need a full archive of the dev@flex.apache.org and users@flex.apache.org mailing lists to be imported into Nabble.

      Is there any way I can generated the archive myself or can only INFRA do this? Nabble have requested that the archive be in mbox format.

        Activity

        #asfinfra IRC Bot added a comment -
        <danielsh> http://flex.apache.org/mail/ (the project site documentation explains how to set this up)
        Justin Mclean added a comment -
        http://flex.apache.org/mail/ doesn't exist - can you provide the right URL? Even if there are instructions somewhere I assume I'd need karma to be able to do the export?
        Justin Mclean added a comment -
        Added a symbolic link:
        http://svn.apache.org/viewvc/flex/site/trunk/content/mail?view=markup&pathrev=1517390

        And publish the site, but http://flex.apache.org/mail doesn't work.

        What have I done wrong?
        Justin Mclean added a comment -
        Added sym link but not working.
        Gavin added a comment -
        I don't see the symlink , where did you add it?
        Justin Mclean added a comment - - edited
        See link above:
        http://svn.apache.org/viewvc/flex/site/trunk/content/mail?view=markup&pathrev=1517390

        Note "svn:special" property which indicates it's a symbolic link.
        Justin Mclean added a comment -
        locally I see this:

        $ls -l mail
        lrwxr-xr-x 1 justinmclean justinmclean 40 26 Aug 08:45 mail -> /home/apmail/public-arch/flex.apache.org
        Justin Mclean added a comment -
        Any ideas to what the issue is here?
        #asfinfra IRC Bot added a comment -
        <danielsh> The symlink is not present in the published website.
        #asfinfra IRC Bot added a comment -
        <danielsh> (You might fix have the build system create it, or do what the www.a.o site: add it to extpaths.txt and then create it by hand in the published website.)
        #asfinfra IRC Bot added a comment -
        <danielsh> (You might fix have the build system create it, or do what the www.a.o site: add it to extpaths.txt and then create it by hand in the svn location of the built/published website.)
        #asfinfra IRC Bot added a comment -
        <danielsh> By the way, if you just want the mbox archives, you can pull them from people.apache.org:~apmail over scp.
        Justin Mclean added a comment -
        Thanks I've pulled the archives off people.apache.org hopefully nabble be able to import those.
        Justin Mclean added a comment -
        Nabble were able to import the archived supplied from peopel.apache.org. Thanks.

          People

          • Assignee:
            Unassigned
            Reporter:
            Justin Mclean
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development