Infrastructure
  1. Infrastructure
  2. INFRA-6611

JSPWiki site commits not propagating to CMS staging/production site

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Fix Version/s: Initial Clearing
    • Component/s: CMS
    • Labels:
      None

      Description

      (issue background on INFRA-6577)
      (edited summary in accordance to september 7th & 15th comments, original summary below)

      Changes to JSPWiki's Apache CMS folder at http://svn.apache.org/viewvc/jspwiki/site/ are not propagating to either http://jspwiki.staging.apache.org/jspwiki/ or http://jspwiki.staging.apache.org/ (the latter should be the correct URL)


      -- updating the JSPWiki CMS site via bookmarklet yields the following message:

      Updating 'usr/local/cms/wc/jspwiki/juanpablo-9Enkzj/trunk/content/jspwiki':
      svn: E175011: Repository moved permanently to 'https://svn.apache.org/repos/asf/jspwiki/site/trunk/content'; please relocate

      As per Danielsh comment on INFRA-6577, the 301 Permanent Redirect response is given to the second request (a REPORT), not to the initial OPTIONS request.--

        Issue Links

          Activity

          Juan Pablo Santos Rodríguez added a comment -
          thanks Joe!
          Joe Schaefer added a comment -
          All set- you still need to migrate your content out of the content/jspwiki subdir
          and into content/. Otherwise site builds are working again now.
          Joe Schaefer added a comment -
          Working on this- we had to reboot the server to unfreeze the zfs mount.
          Juan Pablo Santos Rodríguez added a comment -
          Updated summary, title & priority in accordance with latest comments on this issue
          Glen Mazza added a comment -
          Hi, to simplify matters, we deleted http://svn.apache.org/viewvc/jspwiki/trunk/jspwiki-site/, so now there's only one source of record for our website, the standard http://svn.apache.org/viewvc/jspwiki/site/ location expected by Apache's CMS. However, changes to that location still aren't being propagated to the Apache JSPWiki's staging area: http://jspwiki.staging.apache.org/jspwiki/ (which should actually be just http://jspwiki.staging.apache.org). For example, the left-side menu in SVN: http://svn.apache.org/viewvc/jspwiki/site/trunk/templates/sidenav.mdtext?view=co doesn't have a "PPMC" section but it's still being shown in the staging URL above.
          Glen Mazza added a comment -
          Hi Daniel, Glen on the JSPWiki team, re your earlier comments in this JIRA:

          <danielsh> The reason r1509834 (aka r872516) didn't catch is that you guys commit to a path other than jspwiki/site/, which is what CMS watches. In other words, the reason your site is broken is that you implemented your half of INFRA-6492 before we implemented our half.
          and
          <danielsh> Let me clarify... using the wrong URL is why the site stopped updating. The mount errors upon destroy (which aren't under your control) is why we couldn't re-point the CMS at the correct URL easily.

          We'd like to undo INFRA-6492 to help get our website working again, i.e., use the same jspwiki/site Repo structure the rest of the Apache CMS sites like Apache Roller use. Can you reconnect http://jspwiki.staging.apache.org/ back to http://svn.apache.org/viewvc/jspwiki/site/ and completely ignore http://svn.apache.org/viewvc/jspwiki/trunk/jspwiki-site/ (also, as far as you're concerned, can we delete the latter URL now, you guys never did anything with it, correct?) I just want to get JSPWiki's website back to one and only one source of record in SVN and have a website source folder structure identical to Roller's already-well-working website. Thanks!
          Juan Pablo Santos Rodríguez added a comment -
          Wondering if anything is needed from our side? Thanks!
          #asfinfra IRC Bot added a comment -
          <danielsh> Yes, pushing directly to the production/ URL is the easiest way to get stuff published right now.
          Juan Pablo Santos Rodríguez added a comment -
          Hi Danielsh,

          having the front page showing a dir listing was the most pressing issue, so kudos on fixing that :-) As for the correct/incorrect URLs, when we filed INFRA-6492 we also created the new SVN location, but we didn't delete the older one. While incubating, we were publishing under https://svn.apache.org/repos/asf/incubator/jspwiki/site/trunk, although we also had https://svn.apache.org/repos/asf/incubator/jspwiki/trunk/jspwiki-site/src/site/trunk, in order to make the transition between locations seamless. Not sure when the new URL became the used URL by CMS, or how we triggered that change, which is why all the problems, if I've understood correctly

          Anyway, I think it's easier for now, until this JIRA gets solved, to push only most important changes to https://svn.apache.org/repos/infra/websites/jspwiki/production/content (namely, removing incubation references on front page).


          thanks for your time on this
          #asfinfra IRC Bot added a comment -
          <danielsh> Let me clarify... using the wrong URL is why the site stopped updating. The mount errors upon destroy (which aren't under your control) is why we couldn't re-point the CMS at the correct URL easily.
          #asfinfra IRC Bot added a comment -
          <danielsh> .. and the problems here: (a) https://cms.apache.org/jspwiki/teardown doesn't work; (b) mod_svn_check_path's 301 redirect pops up too late. (The fact that your commits don't trigger builds is not a bug -- it would have been a bug if those commits had been made to /jspwiki/site (which they hadn't) -- but it'll get fixed when we fix this ticket.)
          #asfinfra IRC Bot added a comment -
          <danielsh> So, anyway. The workarounds right now are: (a) commit directly to https://svn.apache.org/repos/infra/websites/jspwiki/production/content after running local builds; or (b) set up a "jspwiki2" CMS entry and build your site off of that.
          #asfinfra IRC Bot added a comment -
          <danielsh> The reason r1509834 (aka r872516) didn't catch is that you guys commit to a path other than jspwiki/site/, which is what CMS watches. In other words, the reason your site is broken is that you implemented your half of INFRA-6492 before we implemented our half.
          #asfinfra IRC Bot added a comment -
          <danielsh> Ignore last...
          #asfinfra IRC Bot added a comment -
          <danielsh> That revision number is of the staging or production tree. I suggested that you edit the source tree (the one in /repos/asf). That should trigger a staging build.
          Juan Pablo Santos Rodríguez added a comment -
          Hi Danielsh,

          we tried that also (f. ex. r872516), but the staging website didn't get updated, we thought it was also related to this issue

          thx for looking into this
          #asfinfra IRC Bot added a comment -
          <danielsh> BTW, not sure why I didn't say it earlier, but what's stopping you from doing a checkout of the site source and making commits locally (not via the CMS webgui)? Your staging builds work so you ought to be able to publish that way
          #asfinfra IRC Bot added a comment -
          <danielsh> Applied a quick duct tape fix to unbreak the site root dir. Note permanent fix for that would be to reshuffle the site source and re-publish.
          #asfinfra IRC Bot added a comment -
          <danielsh> Applied a quick duct tape fix to unbreak the site root dir. Note permanet fix for that would be to reshuffle the site source and puwre-publish.
          Juan Pablo Santos Rodríguez added a comment -
          changed priority to blocker: since transfer to TLP we aren't able to edit the website, with our front page (jspwiki.apache.org) currently presenting a directory listing, as it keeps the incubator structure; so we would really welcome any advance on this issue

          TIA

            People

            • Assignee:
              Joe Schaefer
              Reporter:
              Juan Pablo Santos Rodríguez
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development