Uploaded image for project: 'Infrastructure'
  1. Infrastructure
  2. INFRA-6218

Jenkins - Bunch of Apache Camel builds end up with some weird Jenkins/Maven exceptions/errors.

    Details

    • Type: Task
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Fix Version/s: Initial Clearing
    • Component/s: Jenkins
    • Labels:
      None

      Description

      Recently we're extremely suffering from different weird errors of Apache Camel builds. In many cases Jenkins says "Ping time out" and gives up the build process so we end up again & again with broken and incomplete builds shown with red bubbles, following two examples:

      https://builds.apache.org/job/Camel.trunk.fulltest/1324/console
      https://builds.apache.org/job/Camel.trunk.fulltest.java7/591/console

      And the corresponding Jenkins output in console:

      U camel-core/pom.xml
      U tooling/apt/src/main/java/org/apache/camel/tools/apt/EndpointAnnotationProcessor.java
      FATAL: hudson.remoting.RequestAbortedException: hudson.remoting.Channel$OrderlyShutdown
      hudson.remoting.RequestAbortedException: hudson.remoting.RequestAbortedException: hudson.remoting.Channel$OrderlyShutdown
      at hudson.remoting.Request.call(Request.java:174)
      at hudson.remoting.Channel.call(Channel.java:672)
      at hudson.FilePath.act(FilePath.java:854)
      at hudson.FilePath.act(FilePath.java:838)
      at hudson.scm.SubversionSCM.checkout(SubversionSCM.java:743)
      ...

      Or sometimes the build ends up with some wired Jenkins internal errors as you see here:

      https://builds.apache.org/job/Camel.trunk.fulltest.java7/582/console

      And the corresponding Jenkins output in console:

      [JENKINS] Archiving disabled
      [JENKINS] Archiving disabled
      Waiting for Jenkins to finish collecting data
      mavenExecutionResult exceptions not empty
      message : Internal error: java.lang.reflect.UndeclaredThrowableException
      cause : null
      Stack trace :
      org.apache.maven.InternalErrorException: Internal error: java.lang.reflect.UndeclaredThrowableException
      at org.apache.maven.lifecycle.internal.BuilderCommon.handleBuildError(BuilderCommon.java:128)
      at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:95)
      at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:59)
      at org.apache.maven.lifecycle.internal.LifecycleStarter.singleThreadedBuild(LifecycleStarter.java:183)
      at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:161)
      at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:320)
      at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:156)

      No idea if all these has to do with the recent Jenkins upgrades @ INFRA. In all cases this is really annoying and currently almost all our builds end up with red bubbles.
      1. Bildschirmfoto 2013-05-14 um 18.06.38.png
        182 kB
        Babak Vahdat
      2. Camel.trunk.fulltest.java7-608-console .txt
        6 kB
        Babak Vahdat
      3. Camel.trunk.fulltest.java7-616-console.txt
        517 kB
        Babak Vahdat
      4. Camel.trunk.fulltest.java7-870-console.txt
        543 kB
        Babak Vahdat
      5. Camel.trunk.fulltest-1339-console.txt
        7 kB
        Babak Vahdat
      6. Camel.trunk.notest-1873-console .txt
        5 kB
        Babak Vahdat
      7. Camel.trunk.notest-1890-console.txt
        3.85 MB
        Babak Vahdat
      8. Camel-2.10.x_build_237_Jenkins_log.txt
        1.46 MB
        Christian Müller
      9. sling-trunk-1.6-failures.zip
        642 kB
        Robert Munteanu

        Issue Links

          Activity

          gmcdonald Gavin added a comment -
          " Failed to deploy artifacts:" has absolutely nothing to do with the original query why this ticket was opened. in fact I see no mention of it over the last 8 months until today !! How can you relate this to this ticket I have no idea.

          The 2nd error you mention about "heap space" is also brand new and YES as I hinted IS to do with ARM.

          So yes I claim this ticket FIXED - please now follow up any questions to the builds@ mailing list like I said.
          I will not respond further to this FIXED ticket.
          bvahdat Babak Vahdat added a comment - Reporter
          The original problem because of which I opened this ticket 8 months ago still remains and to my understanding is not resolved, e.g. look at some of the Apache Camel builds of today:

          https://builds.apache.org/job/Camel.trunk.notest/2064/console

          ERROR: Failed to deploy artifacts: Could not transfer artifact org.apache.camel:apt:jar:2.13-20131230.055901-66 from/to apache.snapshots.https (https://repository.apache.org/content/repositories/snapshots): The target server failed to respond
          org.apache.maven.artifact.deployer.ArtifactDeploymentException: Failed to deploy artifacts: Could not transfer artifact org.apache.camel:apt:jar:2.13-20131230.055901-66 from/to apache.snapshots.https (https://repository.apache.org/content/repositories/snapshots): The target server failed to respond

          Which definitely has nothing to do we Java 8 ARM. Why did we fail to upload our artifacts into the snapshot repo. Was the server down? Was it overloaded? Did we hit a timeout we could probably increase it's limit somehow? I don't know.

          Another build of us for today:

          https://builds.apache.org/job/Camel.trunk.fulltest.java7/963/console

          Caused by: java.lang.OutOfMemoryError: Java heap space
          at org.codehaus.plexus.util.xml.Xpp3Dom.<init>(Xpp3Dom.java:110)
          at org.codehaus.plexus.util.xml.Xpp3Dom.<init>(Xpp3Dom.java:97)
          at org.codehaus.plexus.util.xml.Xpp3Dom.<init>(Xpp3Dom.java:123)
          at org.codehaus.plexus.util.xml.Xpp3Dom.<init>(Xpp3Dom.java:97)
          at org.apache.maven.model.ConfigurationContainer.clone(ConfigurationContainer.java:92)

          Has this one something to do with ARM? I don't know.

          So that I do not think we can really claim this ticket is "Fixed"!
          gmcdonald Gavin added a comment -
          Thanks all for your patience, and to [~jfarrell] [~olamy] and others for investigations; this issue is now closed.
          gmcdonald Gavin added a comment -
          Going to close this issue now as it keeps evolving beyond the original issue. Jenkins Master and Slaves have been upgraded and tweaked along the way.

          Due to the nature of builds and build env, can we continue or start new discussions about builds on the builds@ a.o mailing list please.

          One note to Camel - [~bvahdat] and [~muellerc] - Your camel full test has been changed at some point to only use the ARM servers - that also means using the ARM Java 7 version -- did you intend to do this ? I suspect all your builds since November are failing due to an ARM Java incompatibility. If you did intend to change to ARM servers only for this build, we need to investigate the errors (especially why oom heap space) , please follow up your answer on the builds@ a.o list where I'll respond.

          Thanks all.!
          hboutemy Hervé Boutemy added a comment -
          ok, I see the problem didn't completely disappear: https://builds.apache.org/view/S-Z/view/Sling/job/sling-trunk-1.7/432/console

          from previous lines:
          15.12.2013 17:24:05.285 *WARN* [Apche Sling JCR Resource Event Queue Processor for path '/'] org.apache.felix.eventadmin EventAdmin: Blacklisting ServiceReference [[org.apache.sling.event.jobs.JobManager, org.osgi.service.event.EventHandler, org.apache.sling.discovery.TopologyEventListener, java.lang.Runnable] | Bundle(org.apache.sling.event [66])] due to timeout!
          Build timed out (after 150 minutes). Marking the build as failed.
          ...
          [INFO] ------------------------------------------------------------------------
          [INFO] BUILD FAILURE
          [INFO] ------------------------------------------------------------------------
          [INFO] Total time: 2:29:14.366s
          [INFO] Finished at: Sun Dec 15 19:29:33 UTC 2013
          [INFO] Final Memory: 147M/268M
          [INFO] ------------------------------------------------------------------------
          [ERROR] Internal error: java.lang.IllegalStateException: Unable to call isArchivingDisabled. Invalid object ID 100 -> [Help 1]
          org.apache.maven.InternalErrorException: Internal error: java.lang.IllegalStateException: Unable to call isArchivingDisabled. Invalid object ID 100


          I suppose there is some weakness in Jenkins in case of timeout
          rombert Robert Munteanu added a comment - - edited
          This already looks much better, so thank you for the upgrade to JDK 7!

          One note that I have is that I got the same kind of strange error when a build time out:

          Build timed out (after 150 minutes). Marking the build as failed.
          ...
          [ERROR] Internal error: java.lang.IllegalStateException: Unable to call isArchivingDisabled. Invalid object ID 100 -> [Help 1]
          org.apache.maven.InternalErrorException: Internal error: java.lang.IllegalStateException: Unable to call isArchivingDisabled. Invalid object ID 100
          at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:168)
          at org.jvnet.hudson.maven3.launcher.Maven3Launcher.main(Maven3Launcher.java:117)
          at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
          at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
          at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
          at java.lang.reflect.Method.invoke(Method.java:606)
          at org.codehaus.plexus.classworlds.launcher.Launcher.launchStandard(Launcher.java:329)
          at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:239)
          at org.jvnet.hudson.maven3.agent.Maven3Main.launch(Maven3Main.java:178)
          at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
          at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
          at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
          at java.lang.reflect.Method.invoke(Method.java:606)
          at hudson.maven.Maven3Builder.call(Maven3Builder.java:134)
          at hudson.maven.Maven3Builder.call(Maven3Builder.java:69)
          at hudson.remoting.UserRequest.perform(UserRequest.java:118)
          at hudson.remoting.UserRequest.perform(UserRequest.java:48)
          at hudson.remoting.Request$2.run(Request.java:328)
          at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:72)
          at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
          at java.util.concurrent.FutureTask.run(FutureTask.java:166)
          at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
          at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
          at java.lang.Thread.run(Thread.java:724)
          Caused by: java.lang.IllegalStateException: Unable to call isArchivingDisabled. Invalid object ID 100
          at hudson.remoting.RemoteInvocationHandler$RPCRequest.perform(RemoteInvocationHandler.java:293)
          at hudson.remoting.RemoteInvocationHandler$RPCRequest.call(RemoteInvocationHandler.java:280)
          at hudson.remoting.RemoteInvocationHandler$RPCRequest.call(RemoteInvocationHandler.java:239)
          at hudson.remoting.UserRequest.perform(UserRequest.java:118)
          at hudson.remoting.UserRequest.perform(UserRequest.java:48)
          at hudson.remoting.Request$2.run(Request.java:328)
          at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:72)
          at java.util.concurrent.FutureTask.run(FutureTask.java:262)
          at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
          at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
          at java.lang.Thread.run(Thread.java:744)
          [ERROR]
          [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
          [ERROR] Re-run Maven using the -X switch to enable full debug logging.
          [ERROR]
          [ERROR] For more information about the errors and possible solutions, please read the following articles:
          [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/InternalErrorException
          channel stopped
          Sending e-mails to: dev@sling.apache.org null@apache.org cziegeler@apache.org chetan.mehrotra@gmail.com bdelacretaz@apache.org robert@lmn.ro
          Finished: FAILURE
          hboutemy Hervé Boutemy added a comment - - edited
          Jenkins Ubuntu slaves have been upgraded to Oracle JDK 7, and the slave seems to be stable now: 2 Camel builds have passed without failure (other than 4 unit-test failures which seem more related to recent code modifications than to Jenkins instability) https://builds.apache.org/job/Camel.trunk.fulltest

          AFAK, the problem is now away: can you confirm?
          rombert Robert Munteanu added a comment -
          One suggestion that came up in the builds@apache.org list was to upgrade Ubuntu slaves to use OpenJDK 7. Maybe this will help, since OpenJDK 6 did not reach the level of stability that OpenJDK 7 ( or indeed Oracle JDK 6 ) has.
          gmcdonald Gavin added a comment -
          Regarding the last comment from Bertrand all I can find is someone saying: "The cause has been found. Someone programmed a non-terminating while loop in the test code" but no real answers.

          Regarding Exit code 143 I found this:

          https://issues.jenkins-ci.org/browse/JENKINS-19207

          but not much else.

          Our buildmaster machine has been running like a dog lately and maybe its related who knows.

          First thing to try is upgrade to latest Jenkins; then file an issue with them if it persists after that.

          bdelacretaz Bertrand Delacretaz added a comment -
          Here's some more weird problems encountered on recent Slings builds.

          I have marked all those builds as "keep forever" in case someone wants to dig deeper.

          https://builds.apache.org/view/S-Z/view/Sling/job/sling-oak-it-1.6/8/console
          Fails on
          hudson.remoting.ChannelClosedException: channel is already closed
          ...
          Looks like the node went offline during the build. Check the slave log for the details.
          FATAL: /home/hudson/hudson/logs/slaves/ubuntu6/slave.log (No such file or directory)

          https://builds.apache.org/view/S-Z/view/Sling/job/sling-trunk-1.7/399/console
          https://builds.apache.org/view/S-Z/view/Sling/job/sling-trunk-1.6/2031/console
          Both fail on
          java.lang.IllegalStateException: Unable to call isArchivingDisabled. Invalid object ID 102
          at hudson.remoting.RemoteInvocationHandler$RPCRequest.perform(RemoteInvocationHandler.java:293)

          https://builds.apache.org/view/S-Z/view/Sling/job/sling-trunk-1.6/2030/console
          Everything looks good but the end of the log says "Finished: FAILURE" without stating the reason.
          bvahdat Babak Vahdat added a comment - Reporter
          Yeah makes sense, now attached the full build console output "Camel.trunk.fulltest.java7-870-console.txt" and updated my previous post accordingly.
          bdelacretaz Bertrand Delacretaz added a comment -
          Can we please attach stack traces instead of having them inline? That doesn't help the conversation.
          bvahdat Babak Vahdat added a comment - - edited Reporter
          This ticket is now 7 months old and since then our builds are suffering seriously because of this problem from day to day. Would INFRA have any update on this? Attached a "cryptographic" Jenkins output from one of our builds today (Camel.trunk.fulltest.java7-870-console.txt). No idea what Jenkins is trying to tell us...
          muellerc Christian Müller added a comment -
          Today, we still got this error in Camel using Java 7:
          {noformat}
          ERROR: Maven JVM terminated unexpectedly with exit code 143
          [ci-game] evaluating rule: Build result
          {noformat}
          muellerc Christian Müller added a comment -
          Added Camel build output on Jenkins which fails with:
          ERROR: Maven JVM terminated unexpectedly with exit code 143
          rombert Robert Munteanu added a comment -
          I've attached a zip file containing the full build logs of the most recent 5 failed sling-trunk-1.6 builds. What I can make out of it is:

          - the submodule failing varies - there are 3 submodules failing
          - the slave varies as well, but recently it has only failed on ubuntu5

          Let me know if there's any more information that I can give you or help in any other way.

          $ grep -ae '\. FAILURE' *

          sling-trunk-1.6-1684.txt:[INFO] Apache Sling JCR Resource Resolver ................ FAILURE [1:13.049s]
          sling-trunk-1.6-1723.txt:[INFO] Apache Sling Event Support ........................ FAILURE [7:19.101s]
          sling-trunk-1.6-1728.txt:[INFO] Apache Sling Event Support ........................ FAILURE [6:58.881s]
          sling-trunk-1.6-1729.txt:[INFO] Apache Sling JCR Resource Resolver ................ FAILURE [1:15.625s]
          sling-trunk-1.6-1730.txt:[INFO] Apache Sling Event Support ........................ FAILURE [9:46.768s]


          $ grep -ae 'Building remotely' *
          sling-trunk-1.6-1684.txt:Building remotely on ubuntu6 in workspace /home/jenkins/jenkins-slave/workspace/sling-trunk-1.6
          sling-trunk-1.6-1723.txt:Building remotely on ubuntu5 in workspace /home/jenkins/jenkins-slave/workspace/sling-trunk-1.6
          sling-trunk-1.6-1728.txt:Building remotely on ubuntu5 in workspace /home/jenkins/jenkins-slave/workspace/sling-trunk-1.6
          sling-trunk-1.6-1729.txt:Building remotely on ubuntu5 in workspace /home/jenkins/jenkins-slave/workspace/sling-trunk-1.6
          sling-trunk-1.6-1730.txt:Building remotely on ubuntu5 in workspace /home/jenkins/jenkins-slave/workspace/sling-trunk-1.6
          bdelacretaz Bertrand Delacretaz added a comment -
          FWIW we're having similar issues with the Sling builds, java.io.UTFDataFormatException at hudson.remoting.UserRequest.deserialize, and also some "Maven JVM terminated unexpectedly with exit code 143" errors.

          See for example
          https://builds.apache.org/view/S-Z/view/Sling/job/sling-contrib-1.6/1003/console
          https://builds.apache.org/view/S-Z/view/Sling/job/sling-trunk-1.6/1684/console
          bvahdat Babak Vahdat added a comment - Reporter
          Another build of today which JUST compiles the code (profile Camel.trunk.notest):

          https://builds.apache.org/job/Camel.trunk.notest/1890/console

          Which at the end of the build says:

          ...
          ...
          [INFO] BUILD SUCCESS
          [INFO] ------------------------------------------------------------------------
          [INFO] Total time: 28:32.992s
          [INFO] Finished at: Sat Jun 01 11:04:10 UTC 2013
          [INFO] Final Memory: 331M/965M
          [INFO] ------------------------------------------------------------------------
          [locks-and-latches] Releasing all the locks
          [locks-and-latches] All the locks released
          ERROR: Maven JVM terminated unexpectedly with exit code 143
          Email was triggered for: Failure
          Sending email for trigger: Failure
          Sending email to: dev@camel.apache.org babak.vahdat@swissonline.ch claus.ibsen@gmail.com willem.jiang@gmail.com
          Finished: FAILURE

          Attaching the complete output of this build as Camel.trunk.notest-1890-console.txt
          bvahdat Babak Vahdat added a comment - Reporter
          Following another build ending up with Maven error from yesterday, which I'm attaching to this ticket as Camel.trunk.fulltest.java7-616-console.txt:

          https://builds.apache.org/job/Camel.trunk.fulltest.java7/616/console

          The stacktrace at the end of the console output is:

          org.apache.maven.InternalErrorException: Internal error: java.lang.reflect.UndeclaredThrowableException
          at org.apache.maven.lifecycle.internal.BuilderCommon.handleBuildError(BuilderCommon.java:128)
          at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:95)
          at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:59)
          at org.apache.maven.lifecycle.internal.LifecycleStarter.singleThreadedBuild(LifecycleStarter.java:183)
          at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:161)
          at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:320)
          at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:156)
          at org.jvnet.hudson.maven3.launcher.Maven3Launcher.main(Maven3Launcher.java:79)
          at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
          at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
          at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
          at java.lang.reflect.Method.invoke(Method.java:601)
          at org.codehaus.plexus.classworlds.launcher.Launcher.launchStandard(Launcher.java:329)
          at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:239)
          at org.jvnet.hudson.maven3.agent.Maven3Main.launch(Maven3Main.java:158)
          at hudson.maven.Maven3Builder.call(Maven3Builder.java:100)
          at hudson.maven.Maven3Builder.call(Maven3Builder.java:66)
          at hudson.remoting.UserRequest.perform(UserRequest.java:118)
          at hudson.remoting.UserRequest.perform(UserRequest.java:48)
          at hudson.remoting.Request$2.run(Request.java:326)
          at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:72)
          at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
          at java.util.concurrent.FutureTask.run(FutureTask.java:166)
          at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
          at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
          at java.lang.Thread.run(Thread.java:722)
          Caused by: java.lang.reflect.UndeclaredThrowableException
          at $Proxy2.setExecutedMojos(Unknown Source)
          at hudson.maven.MavenBuildProxy$Filter.setExecutedMojos(MavenBuildProxy.java:243)
          at hudson.maven.Maven3Builder$MavenExecutionListener.recordMojoEnded(Maven3Builder.java:439)
          at hudson.maven.Maven3Builder$MavenExecutionListener.mojoSucceeded(Maven3Builder.java:425)
          at org.apache.maven.lifecycle.internal.DefaultExecutionEventCatapult.fire(DefaultExecutionEventCatapult.java:87)
          at org.apache.maven.lifecycle.internal.DefaultExecutionEventCatapult.fire(DefaultExecutionEventCatapult.java:42)
          at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:228)
          at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
          at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
          at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:84)
          ... 24 more
          Caused by: java.io.StreamCorruptedException: invalid type code: FA
          at java.io.ObjectInputStream$BlockDataInputStream.readBlockHeader(ObjectInputStream.java:2487)
          at java.io.ObjectInputStream$BlockDataInputStream.refill(ObjectInputStream.java:2522)
          at java.io.ObjectInputStream$BlockDataInputStream.skipBlockData(ObjectInputStream.java:2424)
          at java.io.ObjectInputStream.skipCustomData(ObjectInputStream.java:1920)
          at java.io.ObjectInputStream.readSerialData(ObjectInputStream.java:1897)
          at java.io.ObjectInputStream.readOrdinaryObject(ObjectInputStream.java:1777)
          at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1347)
          at java.io.ObjectInputStream.defaultReadFields(ObjectInputStream.java:1970)
          at java.io.ObjectInputStream.readSerialData(ObjectInputStream.java:1894)
          at java.io.ObjectInputStream.readOrdinaryObject(ObjectInputStream.java:1777)
          at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1347)
          at java.io.ObjectInputStream.defaultReadFields(ObjectInputStream.java:1970)
          at java.io.ObjectInputStream.defaultReadObject(ObjectInputStream.java:498)
          at java.lang.Throwable.readObject(Throwable.java:913)
          at sun.reflect.GeneratedMethodAccessor121.invoke(Unknown Source)
          at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
          at java.lang.reflect.Method.invoke(Method.java:601)
          at java.io.ObjectStreamClass.invokeReadObject(ObjectStreamClass.java:1004)
          at java.io.ObjectInputStream.readSerialData(ObjectInputStream.java:1872)
          at java.io.ObjectInputStream.readOrdinaryObject(ObjectInputStream.java:1777)
          at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1347)
          at java.io.ObjectInputStream.defaultReadFields(ObjectInputStream.java:1970)
          at java.io.ObjectInputStream.readSerialData(ObjectInputStream.java:1894)
          at java.io.ObjectInputStream.readOrdinaryObject(ObjectInputStream.java:1777)
          at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1347)
          at java.io.ObjectInputStream.readObject(ObjectInputStream.java:369)
          at hudson.remoting.UserRequest.deserialize(UserRequest.java:182)
          at hudson.remoting.UserRequest.perform(UserRequest.java:98)
          at hudson.remoting.UserRequest.perform(UserRequest.java:48)
          at hudson.remoting.Request$2.run(Request.java:326)
          at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:72)
          at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
          at java.util.concurrent.FutureTask.run(FutureTask.java:166)
          at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
          at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
          ... 1 more

           
          jfarrell Jake Farrell added a comment -
          Ran the build scripts as the jenkins user and experienced no issues using latest Maven

          .....
          [INFO] Camel :: Example :: SSH :: Security ............... SUCCESS [0.205s]
          [INFO] Camel :: Example :: SQL ........................... SUCCESS [1.313s]
          [INFO] Camel :: Example :: Tracer ........................ SUCCESS [1.438s]
          [INFO] Camel :: Example :: Twitter WebSocket ............. SUCCESS [1.901s]
          [INFO] Camel :: Assembly ................................. SUCCESS [2:22.028s]
          [INFO] ------------------------------------------------------------------------
          [INFO] BUILD SUCCESS


          bvahdat Babak Vahdat added a comment - Reporter
          So probably INFRA-6248 is also relevant in this context.
          bvahdat Babak Vahdat added a comment - Reporter
          I've also noticed the same RED error message (see the attached PNG file) by some of the Apache Camel profiles, including by the ones I've attached the console outputs from.
          bvahdat Babak Vahdat added a comment - Reporter
          Attached the three example console outputs mentioned above to this ticket.
          jfarrell Jake Farrell added a comment -
          The logs for the linked builds have been auto removed by jenkins, can you attach a copy of the logs from a build when this occurs or change the configuration for the build when this happens to not remove previous builds. Thanks
          bvahdat Babak Vahdat added a comment - - edited Reporter
          https://builds.apache.org/job/Camel.trunk.notest.jdk7/4/console

          All goes well until at the very end where Jenkins says:

          ERROR: Maven JVM terminated unexpectedly with exit code 143
          bvahdat Babak Vahdat added a comment - - edited Reporter
          Sorry I don't get the point. That option is NOT selected by the "Camel.trunk.notest" profile, that's true. Actually I verified that it is NOT selected by ALL of the Apache Camel profiles.

          If I understand it right, when this option is NOT selected then Archiving is ENABLED which is fine for us because we want JENKINS to archive. And then with this setting in place there should be no "[JENKINS] Archiving disabled" errors at all as we've got Archiving ENABLED.
          jfarrell Jake Farrell added a comment -
          Babak, did you try the setting I mentioned in INFRA-6207? In the Jenkins project configuration, Build section Advanced options is an option for "Disable automatic artifact archiving" which is not selected for camel.trunk.notest project. This should take care of the "[JENKINS] Archiving disabled" errors you are seeing.

            People

            • Assignee:
              Unassigned
              Reporter:
              bvahdat Babak Vahdat
              Request participants:
              None
            • Votes:
              4 Vote for this issue
              Watchers:
              8 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: