Details

      Description

      Please create:

      Mailing lists

      dev@climate.incubator.apache.org

      Moderators: mattmann@apache.org, smarru@apache.org,niq@apache.org, pramirez@apache.org,cdouglas@apache.org

      Membership:
      Chris A. Mattmann mattmann@apache.org
      Cameron E. Goodale goodale@apache.org
      Paul Ramirez pramirez@apache.org
      Andrew F. Hart ahart@apache.org
      Jinwon Kim jkim@atmos.ucla.edu
      Duane Waliser duane.waliser@jpl.nasa.gov
      Huikyo Lee Huikyo.Lee@jpl.nasa.gov
      Paul Loikith Paul.C.Loikith@jpl.nasa.gov
      Daniel J. Crichton crichton@apache.org
      Kim Whitehall Kim.D.Whitehall@jpl.nasa.gov
      Paul Zimdars pzimdars@apache.org
      Chris Jack cjack@csag.uct.ac.za
      Bruce Hewitson hewitson@csag.uct.ac.za
      Lluis Fita Borrell l.fitaborrell@unsw.edu.au
      Jason Evans jason.evans@unsw.edu.au
      Estani Gonzalez estanislao.gonzalez@met.fu-berlin.de
      Luca Cinquini luca.cinquini@jpl.nasa.gov
      J. Sanjay sanjay@tropmet.res.in
      M. V. S. Rama Rao ramarao@tropmet.res.in
      Tsengdar Lee tsengdar.j.lee@nasa.gov
      Laura Carriere laura.carriere@nasa.gov
      Denis Nadeau denis.nadeau@nasa.gov
      Michael Joyce Michael.J.Joyce@jpl.nasa.gov
      Shakeh Khudikyan Shakeh.E.Khudikyan@jpl.nasa.gov
      Maziyar Boustani Maziyar.Boustani@jpl.nasa.gov
      Chris Douglas cdouglas@apache.org
      Nick Kew niq@apache.org
      Suresh Marru smarru@apache.org

      commits@climate.incubator.apache.org

      Moderators: mattmann@apache.org, smarru@apache.org,niq@apache.org, pramirez@apache.org,cdouglas@apache.org

      Membership:
      Chris A. Mattmann mattmann@apache.org
      Cameron E. Goodale goodale@apache.org
      Paul Ramirez pramirez@apache.org
      Andrew F. Hart ahart@apache.org
      Jinwon Kim jkim@atmos.ucla.edu
      Duane Waliser duane.waliser@jpl.nasa.gov
      Huikyo Lee Huikyo.Lee@jpl.nasa.gov
      Paul Loikith Paul.C.Loikith@jpl.nasa.gov
      Daniel J. Crichton crichton@apache.org
      Kim Whitehall Kim.D.Whitehall@jpl.nasa.gov
      Paul Zimdars pzimdars@apache.org
      Chris Jack cjack@csag.uct.ac.za
      Bruce Hewitson hewitson@csag.uct.ac.za
      Lluis Fita Borrell l.fitaborrell@unsw.edu.au
      Jason Evans jason.evans@unsw.edu.au
      Estani Gonzalez estanislao.gonzalez@met.fu-berlin.de
      Luca Cinquini luca.cinquini@jpl.nasa.gov
      J. Sanjay sanjay@tropmet.res.in
      M. V. S. Rama Rao ramarao@tropmet.res.in
      Tsengdar Lee tsengdar.j.lee@nasa.gov
      Laura Carriere laura.carriere@nasa.gov
      Denis Nadeau denis.nadeau@nasa.gov
      Michael Joyce Michael.J.Joyce@jpl.nasa.gov
      Shakeh Khudikyan Shakeh.E.Khudikyan@jpl.nasa.gov
      Maziyar Boustani Maziyar.Boustani@jpl.nasa.gov
      Chris Douglas cdouglas@apache.org
      Nick Kew niq@apache.org
      Suresh Marru smarru@apache.org


      private@climate.incubator.apache.org

      Moderators: mattmann@apache.org, smarru@apache.org,niq@apache.org, pramirez@apache.org,cdouglas@apache.org

      Membership:
      Chris A. Mattmann mattmann@apache.org
      Cameron E. Goodale goodale@apache.org
      Paul Ramirez pramirez@apache.org
      Andrew F. Hart ahart@apache.org
      Jinwon Kim jkim@atmos.ucla.edu
      Duane Waliser duane.waliser@jpl.nasa.gov
      Huikyo Lee Huikyo.Lee@jpl.nasa.gov
      Paul Loikith Paul.C.Loikith@jpl.nasa.gov
      Daniel J. Crichton crichton@apache.org
      Kim Whitehall Kim.D.Whitehall@jpl.nasa.gov
      Paul Zimdars pzimdars@apache.org
      Chris Jack cjack@csag.uct.ac.za
      Bruce Hewitson hewitson@csag.uct.ac.za
      Lluis Fita Borrell l.fitaborrell@unsw.edu.au
      Jason Evans jason.evans@unsw.edu.au
      Estani Gonzalez estanislao.gonzalez@met.fu-berlin.de
      Luca Cinquini luca.cinquini@jpl.nasa.gov
      J. Sanjay sanjay@tropmet.res.in
      M. V. S. Rama Rao ramarao@tropmet.res.in
      Tsengdar Lee tsengdar.j.lee@nasa.gov
      Laura Carriere laura.carriere@nasa.gov
      Denis Nadeau denis.nadeau@nasa.gov
      Michael Joyce Michael.J.Joyce@jpl.nasa.gov
      Shakeh Khudikyan Shakeh.E.Khudikyan@jpl.nasa.gov
      Maziyar Boustani Maziyar.Boustani@jpl.nasa.gov
      Chris Douglas cdouglas@apache.org
      Nick Kew niq@apache.org
      Suresh Marru smarru@apache.org

        Activity

        Chris A. Mattmann created issue -
        #asfinfra Bot added a comment -
        #asfinfra Bot made changes -
        Field Original Value New Value
        Status Waiting for Infra [ 10011 ] Waiting for user [ 10010 ]
        #asfinfra Bot made changes -
        Assignee Daniel Shahaf (äñ§€¥£¢) [ danielsh ]
        Chris A. Mattmann added a comment -
        Yes sir! Will do
        Chris A. Mattmann made changes -
        Status Waiting for user [ 10010 ] Waiting for Infra [ 10011 ]
        Chris A. Mattmann added a comment -
        Hey Daniel, I received:

        Form not submitted due to errors

        Invalid pmc: climate
        Invalid pmc: climate
        Invalid pmc: climate
        #asfinfra Bot added a comment -
        <danielsh> Oops sorry. r851030. Try again?
        #asfinfra Bot made changes -
        Status Waiting for Infra [ 10011 ] Waiting for user [ 10010 ]
        Chris A. Mattmann added a comment -
        Thanks Daniel, done!
        Chris A. Mattmann made changes -
        Status Waiting for user [ 10010 ] Waiting for Infra [ 10011 ]
        #asfinfra Bot added a comment -
        <danielsh> We don't presubscribe people to mailing lists we create.
        #asfinfra Bot added a comment -
        <danielsh> OK looks good. I'll create it once I remember which script is supposed to create the lists/climate* dirs on the mail hosts
        Chris A. Mattmann added a comment -
        Want me to help? Do I have the karma with my apmail stuff to do it? Then, I can help with these types of tasks in the future. Let me know.
        #asfinfra Bot added a comment -
        <danielsh> Thanks. Yes you have karma (apmail@{hermes,minotaur}). Currently mlreq fails because ~apmail/lists/climate.a.o doesn't exist. I want to automate podling creations (like we have tlpreq now) and so I wonder which script should be creating that dir (and then calling mlreq/queuerun.py). Specifically whether it should be tlpreq/scripts/listdirs (when in piaoreq mode) or something
        #asfinfra Bot added a comment -
        <danielsh> "or something else" (IRC truncated me)
        #asfinfra Bot added a comment -
        <danielsh> More to the point Chris - as apmailer, you're welcome to create lists. The worflow (once mlreq request is sent) is "svn up && ./queuerun.py" in trunk/mlreq/. Thanks!
        #asfinfra Bot added a comment -
        <danielsh> Chris, correction, you don't have karma to create this yourself, since the internal subdomains list must be updated. (maybe apmailers could be given that karma, but they don't have it atm)
        #asfinfra Bot added a comment -
        <danielsh> FTR - mainly to other root@ - I'm going to create lists here by running './mkpodling climate'.
        #asfinfra Bot added a comment -
        <danielsh> OK I've done the root@ parts - Chris you can now do the rest yourself via 'mlreq/queuerun.py' (or via 'python tlpreq/scripts/queuerun climate true' if you prefer)
        #asfinfra Bot made changes -
        Status Waiting for Infra [ 10011 ] Waiting for user [ 10010 ]
        Chris A. Mattmann made changes -
        Assignee Daniel Shahaf (äñ§€¥£¢) [ danielsh ] Chris A. Mattmann [ chrismattmann ]
        Chris A. Mattmann added a comment -
        - working on mlreq/queuerun.py once i find where it is on hermes :)
        Chris A. Mattmann made changes -
        Status Waiting for user [ 10010 ] In Progress [ 3 ]
        Chris A. Mattmann added a comment -
        Hey Daniel, tried queuerun.py on whimsy:

        whimsy-vm:/var/tools/infra> ./mlreq/queuerun.py
        Traceback (most recent call last):
          File "./mlreq/queuerun.py", line 30, in <module>
            from tlpreq import *
        ImportError: No module named tlpreq
        whimsy-vm:/var/tools/infra>

        I tried SVN check'ing out svn co https://svn.apache.org/repos/infra/infrastructure/trunk/tlpreq/ but don't have perms on whimsy-vm at /var/tools/infra to drop the lib in there. :(
        Chris A. Mattmann made changes -
        Status In Progress [ 3 ] Open [ 1 ]
        Chris A. Mattmann made changes -
        Assignee Chris A. Mattmann [ chrismattmann ] Daniel Shahaf (äñ§€¥£¢) [ danielsh ]
        Chris A. Mattmann added a comment -
        One more question Daniel -- does it matter that it's climate.apache.org instead of climate.incubator.apache.org ?
        #asfinfra Bot added a comment -
        <danielsh> Chris you shouldn't have involved whimsy in this. The script is designed to be run on your workstation/laptop, it might not have been safe to run on ASF hosts. Undo whimsy changes please.
        #asfinfra Bot added a comment -
        <danielsh> Run the script on your laptop. (It might fail in prepare() if you aren't apmail@mino yet.) Calling it climate.apache.org is fine - see tlpreq/PIAO for some condensed docs - tldr it's by design but there's no "climate.apache.org" DNS entry until you become a PMC.
        Chris A. Mattmann added a comment -
        Sorry about that Daniel. As discussed on IRC nothing changed on whimsy. I'll run the script on my laptop. Thanks for the help.
        #asfinfra Bot added a comment -
        <danielsh> OK, waiting to hear that you ran it, let us know if it worked or not
        #asfinfra Bot made changes -
        Status Open [ 1 ] Waiting for user [ 10010 ]
        Chris A. Mattmann made changes -
        Assignee Daniel Shahaf (äñ§€¥£¢) [ danielsh ] Chris A. Mattmann [ chrismattmann ]
        Chris A. Mattmann added a comment -
        going to run mlreq
        Chris A. Mattmann made changes -
        Status Waiting for user [ 10010 ] In Progress [ 3 ]
        Chris A. Mattmann added a comment -
        Hey Daniel, ran queuerun.py all good! Several points in the script asked for danielsh, but I just hit return and it let me change the username. Sorry if I added up against your missed pwd count!
        Chris A. Mattmann made changes -
        Status In Progress [ 3 ] Open [ 1 ]
        Chris A. Mattmann made changes -
        Assignee Chris A. Mattmann [ chrismattmann ] Daniel Shahaf (äñ§€¥£¢) [ danielsh ]
        Chris A. Mattmann added a comment -
        Hmm, I think this is done :) Woo hoo, assigning to me, and resolving!
        Chris A. Mattmann made changes -
        Assignee Daniel Shahaf (äñ§€¥£¢) [ danielsh ] Chris A. Mattmann [ chrismattmann ]
        Chris A. Mattmann added a comment -
        - complete with awesome help from danielsh, per usual.
        Chris A. Mattmann made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Resolution Fixed [ 1 ]
        #asfinfra Bot added a comment -
        <danielsh> Re username prompt, that's normal behaviour, and yes pressing 'Enter' to get a new Username: prompt is the recommended solution.
        #asfinfra Bot added a comment -
        <danielsh> The new lists are not being archived. Do not use them yet. (and join IRC so we can figure out what went wrong)
        #asfinfra Bot made changes -
        Resolution Fixed [ 1 ]
        Status Closed [ 6 ] Reopened [ 4 ]
        Chris A. Mattmann added a comment -
        Hi Daniel, OK in IRC so we can figure it out.
        Chris A. Mattmann added a comment -
        with [~danielsh] we resolved this on IRC by running archivealias -d as apmail on mino. Lists are now archived and we're good.
        Chris A. Mattmann made changes -
        Status Reopened [ 4 ] Closed [ 6 ]
        Resolution Fixed [ 1 ]
        Gavin made changes -
        Fix Version/s Initial Clearing [ 12325964 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Waiting for user Waiting for user Waiting for Infra Waiting for Infra
        31m 6s 2 Chris A. Mattmann 18/Feb/13 19:25
        Waiting for Infra Waiting for Infra Waiting for user Waiting for user
        12h 34m 3 #asfinfra Bot 19/Feb/13 07:47
        Open Open Waiting for user Waiting for user
        1d 7h 24m 1 #asfinfra Bot 21/Feb/13 09:51
        Waiting for user Waiting for user In Progress In Progress
        3d 12h 40m 2 Chris A. Mattmann 24/Feb/13 04:05
        In Progress In Progress Open Open
        23m 25s 2 Chris A. Mattmann 24/Feb/13 04:15
        Open Open Closed Closed
        1m 18s 1 Chris A. Mattmann 24/Feb/13 04:16
        Closed Closed Reopened Reopened
        7h 18m 1 #asfinfra Bot 24/Feb/13 11:35
        Reopened Reopened Closed Closed
        6h 13m 1 Chris A. Mattmann 24/Feb/13 17:49

          People

          • Assignee:
            Chris A. Mattmann
            Reporter:
            Chris A. Mattmann
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development