Infrastructure
  1. Infrastructure
  2. INFRA-5866

Move Apache Any23 to use Git as main source code repository

    Details

    • Type: Wish Wish
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Fix Version/s: Initial Clearing
    • Component/s: Git
    • Labels:
      None

      Description

      The Apache Any23 community has expressed commitment to use Git as the main source code repository.
      We would be grateful if the Infrastructure team could make the Any23 Git repository writable.
      Thank you
      Lewis

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Waiting for Infra Waiting for Infra Waiting for user Waiting for user
        18d 21h 8m 2 David Nalley 11/Mar/13 22:36
        Waiting for user Waiting for user Waiting for Infra Waiting for Infra
        7d 22h 57m 2 #asfinfra Bot 13/Mar/13 18:59
        Closed Closed Reopened Reopened
        28d 37m 1 Lewis John McGibbney 10/Apr/13 20:37
        Reopened Reopened Waiting for Infra Waiting for Infra
        6d 2h 43m 1 Gavin 16/Apr/13 23:20
        Waiting for Infra Waiting for Infra Closed Closed
        2d 3h 42m 2 David Nalley 19/Apr/13 03:03
        Gavin made changes -
        Fix Version/s Initial Clearing [ 12325964 ]
        Lewis John McGibbney added a comment -
        Hi David. Thank you so much for this. Your help is greatly appreciated honestly.
        David Nalley made changes -
        Status Waiting for Infra [ 10011 ] Closed [ 6 ]
        Resolution Fixed [ 1 ]
        David Nalley added a comment -
        Lewis:

        Both git repos are writable now.

        any23/site is writable in SVN now, the remainder remains read-only.

        Enjoy.
        Lewis John McGibbney added a comment -
        Hi David, new Git committers tree is great. New Git Any23 tree is great.
        It is just the site directory within SVN we would like to keep writable.
        Thank you so much.
        David Nalley added a comment -
        Lewis:

        If I understand correctly - the any23 git repo is satisfactory and can be made writable?

        The committers module is here:
        https://git-wip-us.apache.org/repos/asf/any23-committers.git

        which parts of the any23 svn tree (aside from site) are you wanting to keep writable?

        --David
        Gavin made changes -
        Status Reopened [ 4 ] Waiting for Infra [ 10011 ]
        Lewis John McGibbney made changes -
        Resolution Later [ 7 ]
        Status Closed [ 6 ] Reopened [ 4 ]
        Lewis John McGibbney added a comment -
        I would like to reopen this issue.
        * We are happy with the Git repos set out and content.
        * We would however like the committers module [0] also made available within the Git repos.
        * We will manage the Any23 documentation from the curent SVN directory so presumable this will need to stay writable?

        Thank you

        [0] http://svn.apache.org/repos/asf/any23/committers/
        #asfinfra Bot made changes -
        Resolution Later [ 7 ]
        Status Waiting for Infra [ 10011 ] Closed [ 6 ]
        #asfinfra Bot made changes -
        Status Waiting for user [ 10010 ] Waiting for Infra [ 10011 ]
        #asfinfra Bot added a comment -
        <danielsh> feedback timeout
        David Nalley made changes -
        Status Waiting for Infra [ 10011 ] Waiting for user [ 10010 ]
        David Nalley added a comment -
        Any update on this?
        Lewis John McGibbney added a comment -
        I've checked the branches (which are legacy and currently not used anyway) and tags, and all looks good to me. Also the issues which have been addressed look up-to-date as of the last commit.
        @Peter, if you can confirm then I would be happy for the new repos to go writable.
        Thank you for your work guys.
        David Nalley added a comment -
        The issue is that while we have general faith in process/scripts for migration we have had occurrences where branches/tags have been missing in certain cases. So this is really that the project is satisfied that the git repo is an accurate copy of what is in SVN.

        --David
        Peter Ansell made changes -
        Status Waiting for user [ 10010 ] Waiting for Infra [ 10011 ]
        Peter Ansell added a comment -
        I am not familiar with the process, but there was a dev mailing list thread that was responded to by PPMC members where all of the responses indicated +1 for moving to git. Is that enough for signoff or does there need to be a [Vote] in the thread title for it to be official?

        The initial emails were [1] and [2].

        This was followed by this email that started a thread with +1's [3]

        [1] http://mail-archives.apache.org/mod_mbox/any23-dev/201302.mbox/%3CCAGaRif1tT45_yKbDeVo35e-B3%2BQdYRo56Fe%3DK_aLZeyhierhMg%40mail.gmail.com%3E
        [2] http://mail-archives.apache.org/mod_mbox/any23-dev/201302.mbox/%3CCAGYFOCRgNywdsPM7_rPC2HVp6hr8HayByBXJfCpO78ePEEkcqQ%40mail.gmail.com%3E
        [3] http://mail-archives.apache.org/mod_mbox/any23-dev/201302.mbox/%3CCAGaRif1ycSWNEZPVhmTOeWw2pv1aLmMGeb=v7=eq+UEy9hSLNQ@mail.gmail.com%3E
        David Nalley made changes -
        Status Waiting for Infra [ 10011 ] Waiting for user [ 10010 ]
        David Nalley added a comment -
        SVN is RO now.

        Git repo is here: https://git-wip-us.apache.org/repos/asf/any23.git
        It's also read-only.

        Please review, once the PPMC signs off, update this ticket and I'll make it writable.
        David Nalley made changes -
        Assignee David Nalley [ ke4qqq ]
        Lewis John McGibbney made changes -
        Field Original Value New Value
        Issue Type Bug [ 1 ] Wish [ 5 ]
        Lewis John McGibbney created issue -

          People

          • Assignee:
            David Nalley
            Reporter:
            Lewis John McGibbney
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development