Infrastructure
  1. Infrastructure
  2. INFRA-5716

Apache Gora CI is no longer working. Seems like the node does not have maven installed?

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Fix Version/s: Initial Clearing
    • Component/s: Jenkins
    • Labels:
      None

      Description

      When running Gora nightly builds with Jenkins CI we now getting these errors:

      Building remotely on ubuntu5 in workspace /home/jenkins/jenkins-slave/workspace/gora-trunk
      ERROR: A Maven installation needs to be available for this project to be built.Either your server has no Maven installations defined, or the requested Maven version does not exist.
      Retrying after 10 seconds
      ERROR: A Maven installation needs to be available for this project to be built.Either your server has no Maven installations defined, or the requested Maven version does not exist.
      Retrying after 10 seconds
      ERROR: A Maven installation needs to be available for this project to be built.Either your server has no Maven installations defined, or the requested Maven version does not exist.
      Email was triggered for: Failure
      Sending email for trigger: Failure
      Error retrieving environment vars: A Maven installation needs to be available for this project to be built.Either your server has no Maven installations defined, or the requested Maven version does not exist.
      Sending email to: dev@gora.apache.org
      Finished: FAILURE

      https://builds.apache.org/job/gora-trunk/568/console

      Seems like the machines where CI is running could not find Maven installation?

        Activity

        Gavin added a comment -
        Confirmed.
        Henry Saputra added a comment -
        Yeah, looks good now. Thanks Gavin
        Lewis John McGibbney added a comment -
        I've just caught up with this one. The Gora nightly build seems to be back online and stable.
        Henry Saputra added a comment -
        Hi Gavin,

        Seems like it is still not working:
        "
        The Apache Jenkins build system has built gora-trunk (build #569)

        Status: Still Failing

        Check console output at https://builds.apache.org/job/gora-trunk/569/ to view the results.
        "
        Gavin added a comment -
        I updated all the 'latest' and 'latest3' links on the slaves from maven-3.0.3 to maven-3.0.4

        Try again

          People

          • Assignee:
            Unassigned
            Reporter:
            Henry Saputra
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development