Details

    • Type: Sub-task
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Fix Version/s: Initial Clearing
    • Component/s: CMS
    • Labels:
      None

      Description

      Requests to http://marmotta.incubator.apache.org still return 404.

      We would like to have it working when possible, at least for adding a simple "comming soon".

      Thanks!

        Issue Links

          Activity

          infrabot #asfinfra Bot added a comment -
          <danielsh> svnpubsub hooked, site will worked as soon as you 'publish' in CMS
          wikier Sergio Fernández added a comment - Reporter
          thanks to danielsh support on IRC, with r1447650 I switched back to 'site.output' as property to set the build path, and now http://marmotta.staging.apache.org is being build :-)
          wikier Sergio Fernández added a comment - Reporter
          Joe, is there anything else missing from our side?
          Thanks in advance.
          wikier Sergio Fernández added a comment - Reporter
          OK. What would be the staging url: http://marmotta.staging.incubator.apache.org or http://marmotta.staging.apache.org ?

          At the pom there was a property exactly for such purpose, but stupid of me I forgot to add the configuration on the plugin. Now (r1445365) should be fine, and site can be generated using something like:

          $ mvn site -DsiteOutputDirectory=foo

          I didn' t find any normative name for it, so I took the default one directly recommended by the plugin: http://maven.apache.org/plugins/maven-site-plugin/site-mojo.html#outputDirectory

          Thanks, Joe!
          joes Joe Schaefer added a comment -
          CMS builds thru staging are available, but you really need to fix your pom
          to support target directories on the command line.
          wikier Sergio Fernández added a comment - - edited Reporter
          Thanks to Joe Schaefer who pointed us some valuable guidelines: http://www.apache.org/dev/cmsadoption#maven
          Now (r1443087) the content at https://svn.apache.org/repos/asf/incubator/marmotta/site/trunk should be more appropriate to setup the CMS.
          wastl Sebastian Schaffert added a comment -
          Is there any progress on this issue or at least a time estimate? We'd like to have a central entry point for the community and start documenting :)
          wikier Sergio Fernández added a comment - Reporter
          That's right: CMS using Maven to build it.
          infrabot #asfinfra Bot added a comment -
          <danielsh> So in short, you'd like a CMS site to be set up based on https://svn.apache.org/repos/asf/incubator/marmotta/site/trunk with a maven build. Can you update the issue description and set component="CMS" please
          wikier Sergio Fernández added a comment - Reporter
          Now that the site source has been populated (at least we a preliminary version of it), can we get an estimation when could be online at marmotta.incubator.apache.org ?

          In the meantime I'll read how "mvn site" could add reports from external artifacts, because we'd like to be able to publish the javadoc in the site using only Maven.
          wikier Sergio Fernández added a comment - Reporter
          OK, after some reading I think I got it.

          $ /path/to/apache/cms/build/build_site.pl --source-base /path/to/marmotta/svn/site/trunk --target-base /path/to/marmotta/svn/site/trunk/target

          Correctly generates the site in local. So I can say the preliminary version of the site would be ready to go online.
          wikier Sergio Fernández added a comment - Reporter
          Based on some example sites, I created, what I think is, a layout-compliant site source which uses Maven as build type:

          https://svn.apache.org/repos/asf/incubator/marmotta/site/trunk

          The problem is that I'm new on using the Apache CMS, so I'm not totally sure if this is completely fine.

          I tried to build the site using this command line:

          $ /path/to/apache/cms/build/build_external.pl --source-base /path/to/marmotta/svn/site/trunk --target-base /path/to/marmotta/svn/site/trunk --type maven

          but I don't know how to further proceed.

          Thanks for the kind support of all the INFRA team.
          infrabot #asfinfra Bot added a comment -
          <danielsh> waiting for site source to be populated
          wikier Sergio Fernández added a comment - Reporter
          Being solved by IPMC...
          wikier Sergio Fernández added a comment - Reporter
          Back to this issue, definitively we'll use the CMS. Initially with basic static files to have some information online soon; but once MARMOTTA-2 will be solve we'll use Maven as build system for the website, as the Maven project does: http://maven.apache.org/developers/website/deploy-maven-website.html

          I tried to provide the layout-compliant site source, but I don't have permissions on the incubator svn:

          $ svn mkdir https://wikier@svn.apache.org/repos/asf/incubator/marmotta
          svn: E175013: Access to '/repos/asf/!svn/txr/1433969-vcdd/incubator/marmotta' forbidden

          Could you create please such path?
          wikier Sergio Fernández added a comment - Reporter
          We were discussing, and we'd like like to use a site based on what maven generates. But at the same time CMS has some clear benefits.
          As it's been discussed in INFRA-5591, could we try to use a similar approach for Marmotta?
          wikier Sergio Fernández added a comment - Reporter
          OK, we are discussing the issue at the mailing list: http://markmail.org/thread/g4k4abdxlgr72jsc
          Hope I'll be able to provide you the missing information in the upcoming days.
          Thanks.
          infrabot #asfinfra Bot added a comment -
          <danielsh> Your guess is wrong. Please choose between svnpubsub and CMS as per the provided link.
          wikier Sergio Fernández added a comment - Reporter
          Sorry, my fault, I' m a newbie in this process.

          I guess this depends on solving first INFRA-5610 and find an alternative to a svnpubsub-based site while we'd like to use git for the actual source code.
          infrabot #asfinfra Bot added a comment -
          <danielsh> What 'still'? You haven't asked for it to be set up, AFAICT. http://www.apache.org/dev/infra-contact#what-we-need-to-know

            People

            • Assignee:
              joes Joe Schaefer
              Reporter:
              wikier Sergio Fernández
              Request participants:
              None
            • Votes:
              2 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: