Uploaded image for project: 'Infrastructure'
  1. Infrastructure
  2. INFRA-5598

Problems setting up podling marmotta mailing lists

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Fix Version/s: Initial Clearing
    • Component/s: None
    • Labels:
      None

      Description

      I used the web form mlreq/incubator for new podling marmotta mailing lists (3/Dec, ~9AM UTC)

      The json committed, but trailing script (called "piao.sh"?) had a error. On IRC, the suggestion was that this didn't matter.

      But today (4/Dec) I can't seem to -subscribe (-> 550), or ping the lists with -info ("no mailbox").

      Please let me know it's safe to try again or whether something needs adjusting first.

      (I didn't retry as something had committed so I didn't want to risk chaos)


        Activity

        infrabot #asfinfra Bot added a comment -
        <danielsh> It's probably a good idea not to CC the reject list, but you do need to CC the accept list if oy uwant to avoid having to moderate yourself every time.
        andy.seaborne Andy Seaborne added a comment - Reporter
        I must have been replying only. reply-all is certainly one way to fix it.

        But the reply-all gets a weird looking list:

        To: dev-accept-TOKEN@marmotta.i.a.o
        CC: dev-reject-TOKEN@marmotta.i.a.o
        cc: Recipient list not shown: ;
        cc : dev-allow-tc.TOKEN2-user=host@marmotta.i.a.o

        so it goes to accept and reject?

        (yes it says "Recipient list not shown: " because of the headers)

        The moderation email headers are:

        ---------------------------
        From: dev-reject-TOKEN@marmotta.i.a.o
        Reply-To: dev-accept-TOKEN@marmotta.i.a.o
        Cc: dev-allow-tc.TOKEN2-user=host@marmotta.i.a.o
        To: Recipient list not shown: ;
        Subject: MODERATE for ....
        ---------------------------
        infrabot #asfinfra Bot added a comment -
        <danielsh> In case you didn't know: as a moderator you can manipulate the -allow list like an ordinary list: dev-allow-subscribe@, dev-allow-list@, etc. Normally "Reply all" to a MODERATE mail adds teh sender to the allow list. So why is private@'s allow list empty ?
        andy.seaborne Andy Seaborne added a comment - Reporter
        I'll try adding another address based on the same setup.

        My andy@a.o account is backed by gmail and I used -subscribe-user=host@ to subscribe the second time. Listing the address list shows looking OK.

        Email to another project's (jena) lists work OK with the same address but they were set up a awhile ago.

        andy@a.o is the moderator address.

        It also affects the dev@marmotta.inc.a.o list (I thought I had successfully emailed that list)

        So far, it seems to be only me.
        infrabot #asfinfra Bot added a comment -
        <danielsh> the -allow@ sublist is empty. Can you reproduce the problem from another of your addresses? Did the mods fail-to-reproduce it from their moderator addresses?
        andy.seaborne Andy Seaborne added a comment - Reporter
        There is one oddity with these lists.

        When I send to the private@ list, I have to moderate my own messages,but I'm subscribed (and a moderator) with that email address (andy@a.o). It seems to only happen to me - not to other subscribers or moderators.

        Sending a "subscribe" says I am subscribed.

        Unsubscribing and resubscribing didn't change the situation.
        andy.seaborne Andy Seaborne added a comment - Reporter
        tested - dev@ and private@ - and works as expected -- thanks.
        infrabot #asfinfra Bot added a comment -
        <danielsh> I forgot a step - try now.
        andy.seaborne Andy Seaborne added a comment - Reporter
        If I send subscription email from my apache account I get the expected "you are already subscribed" reply. (I was added as a moderator during setup.)

        But if I send from a different email address, I do not get a confirmation reply and the dev-list@ email does not show a new subscriber.
        infrabot #asfinfra Bot added a comment -
        <danielsh> yes and the website too analogously
        andy.seaborne Andy Seaborne added a comment - Reporter
        Thanks.

        I notice the names are users@marmotta.inc.a.o, not marmotta-users@inc.a.o Is that the new normal?
        (it isn't a problem - just want to check before the names go out widely)


        infrabot #asfinfra Bot added a comment -
        <danielsh> Lists created and ready to use enjoy
        infrabot #asfinfra Bot added a comment -
        <danielsh> The lists haven't been created - wait for the NOTICE mail to the PMC

          People

          • Assignee:
            Unassigned
            Reporter:
            andy.seaborne Andy Seaborne
            Request participants:
            None
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: