Infrastructure
  1. Infrastructure
  2. INFRA-5595

Update ooo-wiki to allow a test wiki setup

    Details

    • Type: Task Task
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Fix Version/s: Initial Clearing
    • Component/s: Website
    • Labels:
      None
    • Environment:
      VM: ooo-wiki, apache

      Description

      We need to have a testwiki to test upgrades of wiki.openoffice.org, without affecting the production system.

      I have changed ooo-wiki.conf (apache conf) to allow an extra URL pointing to a new directory.

      I have NOT activated the changes, because I want Infra (as responsible for the VM) to give the thumbs up, or suggest something else.

      The testwiki will be used the next couple of months, without any heavy load (just a few testers), and later from time to time, when mediawiki is updated or to test new configuration settings. Therefore there are no need for a separate VM. Having it in the same VM just a new directory makes upgrading easier.

      If I get the thumbs up, I can activate the changes, and infra would like to do it then please.

      The adapted file is located on the VM in /home/jani/ooo-wiki.conf

      Thanks for a swift reply

        Activity

        jan iversen added a comment -
        Found a way to attach the file...To put it politely it would be a help if infra made a "how to use" or "faq".

        But anyhow here is my proposal, it is NOT activated, please have a look and give me thumps up to activate (and you make the appropriate backup) or give me another suggestion.
         
        Daniel Shahaf (äñ§€¥£¢) added a comment -
        Deleted an attachment as it is a file whose canonical version lives in a non-public repository.
        #asfinfra IRC Bot added a comment -
        <danielsh> And BTW, even if it's not versioned, you still should have posted a unidiff instead of a complete file.
        jan iversen added a comment -
        I have made a file attachment from my personal account on ooo-wike, please inform me in plain english what I have to do, to get it accepted...Being danish I do not understand what " canonical version lives in a non-public repository", it is very well available to people from infra who have access to ooo-wiki (like gmcdonald).

        thank for giving me information
        Jan I.
        #asfinfra IRC Bot added a comment -
        <danielsh> You made public something which isn't public. You shouldn't have done that.
        jan iversen added a comment -
        This is a copy of the file stored in the VM: ooo-wiki::/home/jani provided only to make life simpler for infra people doing a great job.
        #asfinfra IRC Bot added a comment -
        <danielsh> Jani join IRC please
        jan iversen added a comment -
        I am sorry, but I do not have the karma to commit in Infra SVN, so I just copied the file. The file as such is in the infra svn as part of the setup of VM.

        As you suggested I have made a diff, and attached hope it pleased you.

        Important to me is to get the changes done, which has been discussed with Infra (gavin) previously. I am simply trying to save you hard working guys work.

        have a nice evening.
        jan I.
        jan iversen added a comment -
        I am in irc now....and have been for a while as "janI".

        rgds
        Jan I.



        jan iversen added a comment -
        @daniel: I tried your suggestion to test with the ip number (checked with nslookup and ifconfig):

        http://http://140.211.11.66 (expected to get old wiki)
        http://http://140.211.11.66/mwiki (expected to get old wiki due to alias)
        http://http://140.211.11.66/testwiki (expected to get test wiki due to alias)

        http://http://140.211.11.66/index.php (expected to get old wiki)
        http://http://140.211.11.66/mwiki/index.php (expected to get old wiki due to alias)

        In all cases I got the error:
        "ERROR 404: Not Found on Accelerator."

        just to test, I did wget with the above urls directly on the machine, same error.

        then I did again on the machine and used localhost, that worked (not for wikitest, because I have not restarted apache).

        Can you please advice ? or do you have a time schedule for the dns change ?

        thanks
        jan.
        #asfinfra IRC Bot added a comment -
        <danielsh> Gavin can you take a look? Feel free to unassign if not, thx
        jan iversen added a comment -
        I have changed /etc/trafficserver/remap.config, it seems that /etc/trafficserver is not in SVN, is that correct ?

        I added wikitest and mapped to a subdirectory.

        I also changed /etc/apache2/apache2.conf, the file sites-available (and link in sites-enabled) is/was NOT used, and is quite confusing, so it should be deleted.

        I added wikitest and alias for the directories.

        From my side the issue is closed, but I leave it open, as reference to the SVN work.

        jan.
        Gavin added a comment -
        Sorry Jani, I reverted what you did. Things are broken again (on purpose)

        Rather than publically state what I dont like about the setup, we need to talk on IRC.
        Happy to go through things with you, but we need to get it right first time.
        Gavin added a comment -
        Done.

          People

          • Assignee:
            Unassigned
            Reporter:
            jan iversen
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Review Date:

              Time Tracking

              Estimated:
              Original Estimate - 1h
              1h
              Remaining:
              Remaining Estimate - 1h
              1h
              Logged:
              Time Spent - Not Specified
              Not Specified

                Development