Uploaded image for project: 'Infrastructure'
  1. Infrastructure
  2. INFRA-5139

PigServer fails with macros without a script file

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Duplicate
    • Fix Version/s: Initial Clearing
    • Component/s: None
    • Labels:
      None

      Description

      Making a call to {{PigServer.registerQuery}} with an {{InputStream}} will fail if the script contains a macro. This is because {{QueryParserDriver.makeMacroDef}} requires a filename. {{QueryParserDriver.makeMacroDef}} should be changed to not assume that the script input is from a file.

        Activity

        billgraham Bill Graham added a comment - Reporter
        Duplicate of PIG-2866
        billgraham Bill Graham added a comment - Reporter
        Duplicate of PIG-2866. Can't close this JIRA because it's in a bad state (see INFRA-5131).

          People

          • Assignee:
            Unassigned
            Reporter:
            billgraham Bill Graham
            Request participants:
            None
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: