Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Fix Version/s: Initial Clearing
    • Component/s: JIRA
    • Labels:
      None

      Description

      Error creating issue: com.atlassian.jira.util.RuntimeIOException: java.io.IOException: read past EOF

      This is 100% reproducible.

        Issue Links

          Activity

          David S. Wang created issue -
          David S. Wang added a comment -
          I tried Safari and Firefox BTW. I was trying to file an HBase JIRA.
          Jarek Jarcec Cecho added a comment -
          I do have the same issue on linux using chrome on Sqoop project.
          Mike Percy added a comment -
          FYI - I created 10 identical FLUME JIRAs just now while "retrying" the JIRA creation button when getting this error message. So it actually kind of works, but it looks like it fails, and it doesn't report JIRA creation to the mailing list.

          Adding yourself as a watcher also throws some kind of error, but you can see that your Watch was added after a page refresh.
          Himanshu Vashishtha added a comment -
          Yea, same for HBase. It looks like the notification and response page is not coming up.
          Sebb added a comment -
          Also happened to me trying to re-open an issue.
          I assumed the re-open had failed and retried - JIRA then said the issue was in the wrong state.
          On checking the issue it turned out that the invalid state error was because the re-open had succeeded.
          Mike Percy added a comment -
          One more thing. It doesn't appear that changing Status - i.e. marking Patch Available, Resolved, or Closed for JIRA issue is possible right now (not available via the UI). I do still see the option to permanently delete a JIRA (which works).
          Mike Percy added a comment -
          At the risk of spamming comments here, I am additionally seeing the following symptoms:
          * "Old" JIRAs are "fine"... they have the buttons on the UI to do things like "Submit Patch", "Start Progress", "Workflow" > "Resolve Issue"
          * "New" JIRAs are missing these functions.

          So it appears that the "read past EOF" error is causing JIRAs to be only partially created and left in an incomplete state.
          Bill Graham added a comment -
          Same for Pig FYI.
          Bill Graham added a comment -
          Here's an example of a JIRA that got this error upon creation. Notice how is missing a bunch of buttons across the top (i.e., can't resolve):

          https://issues.apache.org/jira/browse/PIG-2866
          Denny Ye added a comment -
          It's still existing when I want to create Flume JIRA
          Gavin made changes -
          Field Original Value New Value
          Link This issue is duplicated by INFRA-5133 [ INFRA-5133 ]
          Gavin added a comment -
          Im looking at this now, patience please whilt I flip-flop jira up and down over the next hour or so.
          Gavin added a comment -
          any better folks?
          Jarek Jarcec Cecho added a comment -
          I'm afraid not:

          * Layout seems to be broken (I see text over text, couple of icons is completely missing, ...)
          * I still do not see closing buttons on newly created tickets in pig, flume or sqoop
          * I even saw some exceptions when randomly iterating over JIRA (for example https://issues.apache.org/jira/browse/SQOOP?selectedTab=com.atlassian.jira.plugin.system.project%3Achangelog-panel)
          Cheolsoo Park added a comment -
          I was able to create a new jira normally today. But how can I fix the ones that have no top buttons? Should I simply ignore bad ones and create new ones? Or is there a way to fix them?
          Brett Porter added a comment -
          https://confluence.atlassian.com/display/JIRAKB/Missing+Available+Workflow+Actions suggests the integrity checker needs to be run, and suggests a workaround (move to another project and back) as an alternative.
          Daniel Kulp added a comment -
          I did try to run the integrity checker. However, it's a synchronous thing (aka: browser must wait for the response with the results) and the proxy server errors out before the results are returned. Thus, it's pretty much impossible to run it unless one of:

          1) Proxy server timeout is completely turned off for a while.

          2) Open up *HTTPS* directly to tomcat just for the duration of the integrity checker run. While in issues-vm, I tried having the non-https port opened up, but logging in as admin automatically redirects to the https port (good) which then goes back to the proxy. I have no idea if the tomcat is even setup for direct https.

          My suggestion would be to just delete the affected issues (I think the Delete button is there) and create a new one.

          surendra singh lilhore added a comment -
          Hi,

          I am not able to attach the docs as well now.

          {quote}
          Cannot attach file JCarder_Doc.pdf: Unknown server error.
          {quote}
          Cheolsoo Park added a comment -
          I tried to move my jira to another project (from Pig to Sqoop), but I still don't see the close button. Furthermore, I cannot move it back... Was anyone able to fix bad jiras?

          https://issues.apache.org/jira/browse/SQOOP-575

          I also don't see the delete button (maybe because I don't have permission). Can anyone please delete the above jira for me? I don't mind creating a new one.
          Jarek Jarcec Cecho added a comment -
          Deleted.

          I tried the same moving hack and it did not helped. Also as far as I know, Infra guys have tried to run the "integrity check" and it did not worked either.
          #asfinfra IRC Bot added a comment -
          <pctony> This shoudl be resolved now - the integrity checker saved the day (tm) ?
          #asfinfra IRC Bot made changes -
          Status Waiting for Infra [ 10011 ] Closed [ 6 ]
          Resolution Fixed [ 1 ]
          Gavin made changes -
          Fix Version/s Initial Clearing [ 12325964 ]

            People

            • Assignee:
              Unassigned
              Reporter:
              David S. Wang
            • Votes:
              0 Vote for this issue
              Watchers:
              15 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development