Infrastructure
  1. Infrastructure
  2. INFRA-4945

post-review seems unable to authenticate with ReviewBoard

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Invalid
    • Fix Version/s: Initial Clearing
    • Component/s: ReviewBoard
    • Labels:
      None
    • Environment:
      Fedora 16, RBTools 0.4.1

      Description

      I am unable to login to RB using post-review. I set reviewboard.url as:
      git config reviewboard.url https://reviews.apache.org


      [ke4qqq@nalleyx200 incubator-cloudstack]$ post-review
      ==> HTTP Authentication Required
      Enter authorization information for "Web API" at reviews.apache.org
      Username: ke4qqq
      Password:
      ==> Review Board Login Required
      Enter username and password for Review Board at https://reviews.apache.org/
      Username: ke4qqq
      Password:
      Unable to log in: HTTP 404


      I am unsure what the Web API creds are supposed to be, and this seems to lack documentation (or I can't find it if it does.) I happy to add documentation for clueless newbs like myself if you don't mind enlightening me.

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Waiting for user Waiting for user
        23d 18h 35m 1 Tony Stevenson 14/Jul/12 12:17
        Waiting for user Waiting for user Closed Closed
        10d 21h 56m 1 Tony Stevenson 25/Jul/12 10:13
        Closed Closed Waiting for Infra Waiting for Infra
        354d 21h 5m 1 15/Jul/13 07:19
        Waiting for Infra Waiting for Infra Closed Closed
        76d 1h 4m 1 Mark Thomas 29/Sep/13 08:24
        Gavin made changes -
        Fix Version/s Initial Clearing [ 12325964 ]
        Mark Thomas made changes -
        Status Waiting for Infra [ 10011 ] Closed [ 6 ]
        Anonymous made changes -
        Status Closed [ 6 ] Waiting for Infra [ 10011 ]
        Review Date 16/Jul/13
        Tony Stevenson made changes -
        Status Waiting for user [ 10010 ] Closed [ 6 ]
        Resolution Invalid [ 6 ]
        Tony Stevenson added a comment -
        Closing as no feedback for a month.
        Tony Stevenson made changes -
        Status Open [ 1 ] Waiting for user [ 10010 ]
        Tony Stevenson added a comment -
        Is this still an issue folks? The HTTPD config looks ok to me. If it's not I'll close the issue.
        Tony Stevenson made changes -
        Field Original Value New Value
        Workflow jira [ 12708024 ] INFRA Workflow [ 12712051 ]
        Pradeep Soundararajan added a comment -
        Earlier I am able to post the review but right now I am unable to post the same. Please find the error below:

        >>> RBTools 0.4.1
        >>> Home = /home/pradeep-ubuntu
        >>> HTTP GETting api/
        Traceback (most recent call last):
          File "/usr/local/bin/post-review", line 8, in <module>
            load_entry_point('RBTools==0.4.1', 'console_scripts', 'post-review')()
          File "build/bdist.linux-x86_64/egg/rbtools/postreview.py", line 1222, in main
          File "build/bdist.linux-x86_64/egg/rbtools/postreview.py", line 226, in check_api_version
          File "build/bdist.linux-x86_64/egg/rbtools/postreview.py", line 669, in api_get
          File "build/bdist.linux-x86_64/egg/rbtools/postreview.py", line 639, in http_get
          File "/usr/lib/python2.7/urllib2.py", line 126, in urlopen
            return _opener.open(url, data, timeout)
          File "/usr/lib/python2.7/urllib2.py", line 392, in open
            response = self._open(req, data)
          File "/usr/lib/python2.7/urllib2.py", line 410, in _open
            '_open', req)
          File "/usr/lib/python2.7/urllib2.py", line 370, in _call_chain
            result = func(*args)
          File "/usr/lib/python2.7/urllib2.py", line 1192, in https_open
            return self.do_open(httplib.HTTPSConnection, req)
          File "/usr/lib/python2.7/urllib2.py", line 1159, in do_open
            raise URLError(err)
        urllib2.URLError: <urlopen error [Errno 110] Connection timed out>


        It looks like there are some API error.
        David Nalley added a comment - - edited
        I think this is actually a httpd config issue.

        So if I login to the web interface, I can visit:
        https://reviews.apache.org/json/account/info, and get a valid response.

        However, if I am not logged into the web interface, I get a basic auth prompt that says Web API, and creds don't appear to work on it - I'll try and take a look and see what is going on.

        UPDATE: I don't see anything in httpd's conf files. perhaps a .htaccess somewhere?
        Pradeep Soundararajan added a comment -
        The issue is with the login URL, it should be json/account/login (this will get concatenated with the review-board url) but the postreview.py is having invalid URL 'api/json/accounts/login/'. This will not work, that is the reason we are facing HTTP 404 error.

        It worked fine for me after changing the URL to "json/account/login" in my private postreview.py....Took lot of time to figure out this :)

        Please some one help to fix this issue permanently in Review Board.


        David Nalley created issue -

          People

          • Assignee:
            Unassigned
            Reporter:
            David Nalley
          • Votes:
            1 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Review Date:

              Development