Infrastructure
  1. Infrastructure
  2. INFRA-4581

Add HBase to https://analysis.apache.org

    Details

    • Type: Task Task
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Fix Version/s: Initial Clearing
    • Component/s: Analysis
    • Labels:
      None

      Description

      Please add HBase to https://analysis.apache.org/
      https://svn.apache.org/repos/asf/hbase/trunk/pom.xml

      On our instance, we've found that we need to exclude some tests that may hang the analysis.

      **/TestReplication.java
      **/TestMasterObserver.java
      **/TestSplitLogManager.java
      **/TestSplitTransactionOnCluster.java
      **/TestCoprocessorEndpoint.java
      **/TestZooKeeper.java
      **/TestMultiColumnScanner.java
      **/TestMemStore.java
      **/TestMetaReaderEditor.java
      **/TestMetaMigrationRemovingHTD.java
      **/TestLogRolling.java

        Activity

        Jonathan Hsieh added a comment -
        and oh -- the 2.12.3 isn't good because we've done some stuff in the hbase pom file that takes advantage of features that weren't released yet. Hopefully when 2.13 come one we can be back on standard releases of surefire.
        Jonathan Hsieh added a comment -
        [~olivier lamy] Awesome, much appreciated!
        Olivier Lamy (*$^¨%`£) added a comment -
        Apologize for delay.
        It's now fixed: see first report https://analysis.apache.org/dashboard/index/71923
        That will now run on a daily basis (triggered if scm change detected)
        So I have added -Dfindbugs.version=2.5.2 and -Dfindbugs.skip=true to exclude findbugs from the normal build to prevent the issue. (why having that in the standard lifecycle that just slow the build IMHO) No problem for sonar findbugs run.
         maven-surefire-plugin:2.12-TRUNK-HBASE-2 wtf ? any reason for using that ?
        Last 2.12.3 is not good ? If not please load a jira with your issue (and the changes you applied locally).
        Can you prune list of repositories you are using that will speed build ? (I see a lot to people.a.o)
        Jonathan Hsieh added a comment -
        Hm.. the findbugs-exclude.xml lives in the project's root dir's dev-support dir -- that is hbase-common/../dev-support/findbug-exclude.xml.
        Olivier Lamy (*$^¨%`£) added a comment -
        issue using maven2:
        {code}
        [INFO] Trace
        org.codehaus.plexus.resource.loader.ResourceNotFoundException: Could not find resource '/x1/jenkins/jenkins-master/jenkins-home/jobs/hbase/workspace/hbase-common/dev-support/findbugs-exclude.xml'.
        {code}
        Olivier Lamy (*$^¨%`£) added a comment -
        jobs created but failure (do you need so much repositories in your pom ?)
        {code}
        [ERROR] Failed to execute goal on project hbase-server: Could not resolve dependencies for project org.apache.hbase:hbase-server:jar:0.95-SNAPSHOT: The following artifacts could not be resolved: org.apache.hbase:hbase-common:jar:0.95-SNAPSHOT, org.apache.hbase:hbase-hadoop-compat:jar:0.95-SNAPSHOT, org.apache.hbase:hbase-hadoop1-compat:jar:0.95-SNAPSHOT: Failure to find org.apache.hbase:hbase-common:jar:0.95-SNAPSHOT in http://repository-netty.forge.cloudbees.com/snapshot/ was cached in the local repository, resolution will not be reattempted until the update interval of cloudbees netty has elapsed or updates are forced -> [Help 1]
        org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal on project hbase-server: Could not resolve dependencies for project org.apache.hbase:hbase-server:jar:0.95-SNAPSHOT: The following artifacts could not be resolved: org.apache.hbase:hbase-common:jar:0.95-SNAPSHOT, org.apache.hbase:hbase-hadoop-compat:jar:0.95-SNAPSHOT, org.apache.hbase:hbase-hadoop1-compat:jar:0.95-SNAPSHOT: Failure to find org.apache.hbase:hbase-common:jar:0.95-SNAPSHOT in http://repository-netty.forge.cloudbees.com/snapshot/ was cached in the local repository, resolution will not be reattempted until the update interval of cloudbees netty has elapsed or updates are forced
        at org.apache.maven.lifecycle.internal.LifecycleDependencyResolver.getDependencies(LifecycleDependencyResolver.java:210)
        at org.apache.maven.lifecycle.internal.LifecycleDependencyResolver.resolveProjectDependencies(LifecycleDependencyResolver.java:117)
        at org.apache.maven.lifecycle.internal.MojoExecutor.ensureDependenciesAreResolved(MojoExecutor.java:258)
        at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:201)
        at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
        at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
        at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:84)
        at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:59)
        at org.apache.maven.lifecycle.internal.LifecycleStarter.singleThreadedBuild(LifecycleStarter.java:183)
        at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:161)
        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:85)
        at org.sonar.maven3.Maven3PluginExecutor.concreteExecute(Maven3PluginExecutor.java:49)
        at org.sonar.batch.AbstractMavenPluginExecutor.execute(AbstractMavenPluginExecutor.java:49)
        at org.sonar.batch.AbstractMavenPluginExecutor.execute(AbstractMavenPluginExecutor.java:38)
        at org.sonar.batch.phases.InitializersExecutor.executeMavenPlugin(InitializersExecutor.java:73)
        at org.sonar.batch.phases.InitializersExecutor.execute(InitializersExecutor.java:60)
        at org.sonar.batch.phases.Phases.execute(Phases.java:90)
        at org.sonar.batch.bootstrap.ProjectModule.doStart(ProjectModule.java:139)
        at org.sonar.batch.bootstrap.Module.start(Module.java:83)
        at org.sonar.batch.bootstrap.BatchModule.analyze(BatchModule.java:131)
        at org.sonar.batch.bootstrap.BatchModule.analyze(BatchModule.java:126)
        at org.sonar.batch.bootstrap.BatchModule.doStart(BatchModule.java:121)
        at org.sonar.batch.bootstrap.Module.start(Module.java:83)
        at org.sonar.batch.bootstrap.BootstrapModule.doStart(BootstrapModule.java:121)
        at org.sonar.batch.bootstrap.Module.start(Module.java:83)
        at org.sonar.batch.bootstrapper.Batch.startBatch(Batch.java:73)
        at org.sonar.batch.bootstrapper.Batch.execute(Batch.java:60)
        at org.sonar.maven3.SonarMojo.execute(SonarMojo.java:142)
        at org.codehaus.mojo.sonar.Bootstraper.executeMojo(Bootstraper.java:113)
        at org.codehaus.mojo.sonar.Bootstraper.start(Bootstraper.java:65)
        at org.codehaus.mojo.sonar.SonarMojo.execute(SonarMojo.java:90)
        at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:101)
        at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:209)
        at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
        at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
        at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:84)
        at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:59)
        at org.apache.maven.lifecycle.internal.LifecycleStarter.singleThreadedBuild(LifecycleStarter.java:183)
        at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:161)
        at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:320)
        at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:156)
        at org.apache.maven.cli.MavenCli.execute(MavenCli.java:537)
        at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:196)
        at org.apache.maven.cli.MavenCli.main(MavenCli.java:141)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:290)
        at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:230)
        at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:409)
        at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:352)
        Caused by: org.apache.maven.project.DependencyResolutionException: Could not resolve dependencies for project org.apache.hbase:hbase-server:jar:0.95-SNAPSHOT: The following artifacts could not be resolved: org.apache.hbase:hbase-common:jar:0.95-SNAPSHOT, org.apache.hbase:hbase-hadoop-compat:jar:0.95-SNAPSHOT, org.apache.hbase:hbase-hadoop1-compat:jar:0.95-SNAPSHOT: Failure to find org.apache.hbase:hbase-common:jar:0.95-SNAPSHOT in http://repository-netty.forge.cloudbees.com/snapshot/ was cached in the local repository, resolution will not be reattempted until the update interval of cloudbees netty has elapsed or updates are forced
        at org.apache.maven.project.DefaultProjectDependenciesResolver.resolve(DefaultProjectDependenciesResolver.java:189)
        at org.apache.maven.lifecycle.internal.LifecycleDependencyResolver.getDependencies(LifecycleDependencyResolver.java:185)
        ... 51 more
        Caused by: org.sonatype.aether.resolution.DependencyResolutionException: The following artifacts could not be resolved: org.apache.hbase:hbase-common:jar:0.95-SNAPSHOT, org.apache.hbase:hbase-hadoop-compat:jar:0.95-SNAPSHOT, org.apache.hbase:hbase-hadoop1-compat:jar:0.95-SNAPSHOT: Failure to find org.apache.hbase:hbase-common:jar:0.95-SNAPSHOT in http://repository-netty.forge.cloudbees.com/snapshot/ was cached in the local repository, resolution will not be reattempted until the update interval of cloudbees netty has elapsed or updates are forced
        at org.sonatype.aether.impl.internal.DefaultRepositorySystem.resolveDependencies(DefaultRepositorySystem.java:375)
        at org.apache.maven.project.DefaultProjectDependenciesResolver.resolve(DefaultProjectDependenciesResolver.java:183)
        ... 52 more
        Caused by: org.sonatype.aether.resolution.ArtifactResolutionException: The following artifacts could not be resolved: org.apache.hbase:hbase-common:jar:0.95-SNAPSHOT, org.apache.hbase:hbase-hadoop-compat:jar:0.95-SNAPSHOT, org.apache.hbase:hbase-hadoop1-compat:jar:0.95-SNAPSHOT: Failure to find org.apache.hbase:hbase-common:jar:0.95-SNAPSHOT in http://repository-netty.forge.cloudbees.com/snapshot/ was cached in the local repository, resolution will not be reattempted until the update interval of cloudbees netty has elapsed or updates are forced
        at org.sonatype.aether.impl.internal.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:538)
        at org.sonatype.aether.impl.internal.DefaultArtifactResolver.resolveArtifacts(DefaultArtifactResolver.java:216)
        at org.sonatype.aether.impl.internal.DefaultRepositorySystem.resolveDependencies(DefaultRepositorySystem.java:358)
        ... 53 more
        Caused by: org.sonatype.aether.transfer.ArtifactNotFoundException: Failure to find org.apache.hbase:hbase-common:jar:0.95-SNAPSHOT in http://repository-netty.forge.cloudbees.com/snapshot/ was cached in the local repository, resolution will not be reattempted until the update interval of cloudbees netty has elapsed or updates are forced
        at org.sonatype.aether.impl.internal.DefaultUpdateCheckManager.newException(DefaultUpdateCheckManager.java:230)
        at org.sonatype.aether.impl.internal.DefaultUpdateCheckManager.checkArtifact(DefaultUpdateCheckManager.java:176)
        at org.sonatype.aether.impl.internal.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:427)
        ... 55 more
        [ERROR] Failed to execute goal org.codehaus.mojo:sonar-maven-plugin:2.0:sonar (default-cli) on project hbase: Can not execute Sonar: Unable to execute maven plugin: Exception during execution of org.apache.maven.plugins:maven-surefire-plugin:2.12-TRUNK-HBASE-2:test -> [Help 2]
        org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal org.codehaus.mojo:sonar-maven-plugin:2.0:sonar (default-cli) on project hbase: Can not execute Sonar
        at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:217)
        at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
        at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
        at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:84)
        at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:59)
        at org.apache.maven.lifecycle.internal.LifecycleStarter.singleThreadedBuild(LifecycleStarter.java:183)
        at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:161)
        at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:320)
        at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:156)
        at org.apache.maven.cli.MavenCli.execute(MavenCli.java:537)
        at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:196)
        at org.apache.maven.cli.MavenCli.main(MavenCli.java:141)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:290)
        at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:230)
        at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:409)
        at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:352)
        Caused by: org.apache.maven.plugin.MojoExecutionException: Can not execute Sonar
        at org.codehaus.mojo.sonar.Bootstraper.executeMojo(Bootstraper.java:118)
        at org.codehaus.mojo.sonar.Bootstraper.start(Bootstraper.java:65)
        at org.codehaus.mojo.sonar.SonarMojo.execute(SonarMojo.java:90)
        at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:101)
        at org.apache.maven.lifecycle.internal.Moj....
        {code}
        Tony Stevenson added a comment -
        Transitioning to waiting for Infra

          People

          • Assignee:
            Olivier Lamy (*$^¨%`£)
            Reporter:
            Jonathan Hsieh
          • Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development