1. Infrastructure
  2. INFRA-4482

Why is my upload to mvn spread across multiple repositories?


    • Type: Task Task
    • Status: Closed
    • Priority: Major Major
    • Resolution: Unresolved
    • Fix Version/s: Initial Clearing
    • Component/s: Nexus
    • Labels:


      I'm been struggling publishing a release to Its worked for me in the past. If you look at (you need to be logged in), you will see that I somehow made twelve repositories when I did my mvn release:perform, each artifact element to its own repo. Any idea how that happens? (I'll attach a png that shows similar). How do I prevent it?

      I have another issue where the upload to apache will fail with a 400 Bad Request very frequently uploading one of my artifact items -- usually maven-metadata.xml -- but then, just now, it went through fine. Pointers appreciated on this little nugget too.

      I'm using mvn 3.0.4 and 2.2.2 of the maven:release plugin. Otherwise, my settings.xml is one that has worked for me in the past:

          <!-- To publish a snapshot of some part of Maven -->
          <!-- To publish a website using Maven -->
          <!-- To stage a release of some part of Maven -->

      My pom is here:

      Thanks for any pointers.


        Gavin made changes -
        Fix Version/s Initial Clearing [ 12325964 ]
        Tony Stevenson made changes -
        Workflow jira [ 12654596 ] INFRA Workflow [ 12711588 ]
        Brian Fox made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Assignee Brian Fox [ brianf ]
        Resolution Unresolved [ 9 ]
        Sebb made changes -
        Component/s Nexus [ 12312660 ]
        stack made changes -
        Field Original Value New Value
        Attachment Screen Shot 2012-02-23 at 9.50.58 AM.png [ 12515782 ]
        stack created issue -


          • Assignee:
            Brian Fox
          • Votes:
            0 Vote for this issue
            0 Start watching this issue


            • Created: