Details

    • Type: Task Task
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Fix Version/s: Initial Clearing
    • Component/s: Nexus
    • Labels:
      None

      Description

      Project URL: tomcat.apache.org

      SVN URL: http://svn.apache.org/repos/asf/tomcat/

      Maven Group Ids: org.apache.tomcat

      Managed By This TLP Project: tomcat

        Activity

        Brian Demers added a comment -
        Is tomcat ready to have ALL releases under org.apache.tomcat to be deployed to repository.apache.org ?
        Jean-Frederic Clere added a comment -
        After discussion with the other release manager, yes if:
        a) the end result is the same as it is now
        b) we only have to run a single script (as we do now)

        Otherwise just for Tomcat6
        Brian Demers added a comment -
        I'm not sure I understand what you mean by your points.

        Everything will be the same assuming that you currently deploy with maven, I don't know what your script does.

        I ask be cause this is an all or nothing change for the release process, it is the only way to synchronize the maven metadata.

        Basically enabling access means you will use repository.apache.org instead of the people.apache.org (scp? + rsync)

        Jean-Frederic Clere added a comment -
        ok we are using people.apache.org (scp + rsync) .
        Brian Demers added a comment -
        Are you still looking to move tomcat deployments to repository.apache.org?
        Jean-Frederic Clere added a comment -
        sure
        Brian Demers added a comment -
        All set, see: http://www.apache.org/dev/publishing-maven-artifacts.html

        NOTE: Tomcat was already set to deploy snapshots to RAO.
        Mark Thomas added a comment -
        Please note that this change was requested without any discussion within the Tomcat community. It is far from clear that there is consensus within the community that this change is desired. The Tomcat community may well be asking for this change to be reverted.
        Brian Demers added a comment - - edited
        The community should not be effected by this. Tomcat could still be deployed to /dist as well as repository.apache.org. Artifacts from RAO are still getting sync'd to central, we just cannot sync the same maven GA from multiple places without causing metadata conflicts. (that and there should be only be one source of the artifact)

        Mark Thomas added a comment -
        This is nothing to do with /dist. This is solely about the artifacts published to Maven Central.

        The community is affected in that the build scripts are still trying to publish Maven artifacts via people.a.o which is now blocked. We are therefore, currently, unable to publish artifacts to Maven Central. That impacts our users that rely on that route for obtaining Tomcat JARs.

        Yes, this can be worked around by our end-users and yes it should be possible to change the build scripts to publish via Nexus. However, the Tomcat community has not decided that it wants to make this change. i.e. the decision to switch to Nexus was not made by the Tomcat community on the Tomcat dev list.

        My assumption is that the Tomcat community will retrospectively approve this change. However, in case it does not, how much work is involved in reverting the switch to Nexus, restoring the repo on people.a.o and returning to publishing via scp+rsync?
        Brian Demers added a comment -
        I still see this as a dev issue, not a community issue (but your closer to that then I)
        Part of this task should have been updating the tomcat scripts to deploy to RAO, after that your artifacts start flowing to central again.

        Technically switching back isn't much work (tar and scp). But to correctly switch back with out incident, we would need to have someone mess with the rsync scripts. After maven release artifacts are deployed they should NOT be removed (the people rsync is a different beast, it is only a place to push, not pull)
        Jean-Frederic Clere added a comment -
        the fix in the tomcat code is quite easy and once done you need 2 clicks in https://repository.apache.org/index.html#stagingRepositories to move the staging to release.
        Mark Thomas added a comment -
        The issues created by the switch to Nexus have been resolved. Since Nexus is neither worse nor better than the previous process, there is no appetite to revert the change now it has been made. That the switch to Nexus didn't resolve the issue it was intended to is a separate issue.

          People

          • Assignee:
            Brian Demers
            Reporter:
            Jean-Frederic Clere
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development