Details

    • Type: Wish Wish
    • Status: Closed
    • Priority: Major Major
    • Resolution: Won't Fix
    • Fix Version/s: Initial Clearing
    • Component/s: Git, JIRA
    • Labels:
      None

      Description

      Check & test the jira git plugin at https://studio.plugins.atlassian.com/wiki/display/JGIT/JIRA+Git+Plugin - make sure its stable,viable, etc etc ...

        Activity

        Brett Porter added a comment -
        I've been running this for several months @ work connected to github, no major complaints. Let me know if I can lend a hand.
        Gavin added a comment -
        There are problems with it and the subversion plugin running together, filed an issue with the git-plugin project.
        Jukka Zitting added a comment -
        Leif Hedstrom added a comment -
        jpeach found this: https://github.com/joyjit/git-jira-hook


        I have no idea if that is a viable option, but it looks like it uses some SOAP APIs, instead of being a Jira plugin, so I'd imagine it would not collide with the SVN plugin?
        Tony Stevenson added a comment -
        This doesnt look so good as it REQUIRES a JIRA ID for every commit. I suspect that will be too intrusive.
        Tony Stevenson added a comment -
        Transitioning to waiting for Infra
        Noah Slater added a comment -
        Tony, what does waiting for Infra mean? You closed as Won't Fix. I'm confused.
        Noah Slater added a comment -
        For some additional context, see David's comment on CLOUDSTACK-195.
        Brett Porter added a comment -
        It looks like the originally referenced plugin has gone commercial now.

        There is the DVCS connector, https://confluence.atlassian.com/display/BITBUCKET/Using+the+JIRA+DVCS+Connector+Plugin, but so far that would only support working off the github mirrors.

        {{git log --oneline --group ISSUE-123}} is pretty effective anyway :)
        Martin Grigorov added a comment -
        I guess, you meant: git log --oneline --grep ISSUE-123
        Noah Slater added a comment -
        I have been pointed to this:

        https://github.com/Humbedooh/gitpubsub

        Is this something we can use? Has there been any other development on this? :)
        Daniel Gruno added a comment -
        gitpubsub is already being used by the ASF (it was invented FOR the ASF), and git->jira, git->irc, jira->irc integration is already happening, see fx. https://issues.apache.org/jira/browse/TS-1714
        As to whether we'll allow you to close a ticket via git, well that's better discussed on the mailing list I think (although this ticket should be updated to reflect whatever decision we may come to).
        Noah Slater added a comment -
        Thanks!

          People

          • Assignee:
            Gavin
            Reporter:
            Gavin
          • Votes:
            1 Vote for this issue
            Watchers:
            8 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development