Infrastructure
  1. Infrastructure
  2. INFRA-2577

Please remerge existing XWork issues into JIRA

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Fix Version/s: Initial Clearing
    • Component/s: JIRA
    • Labels:
      None

      Description

      Not all issues from Opensymphony were imported into Apache JIRA, please remerge them. This issues is in releation with INFRA-1963

      Thanks in advance!
      --
      Lukasz
      1. Screen Shot 2012-02-28 at 09.01.38.png
        149 kB
        Tony Stevenson
      2. Screen Shot 2012-02-13 at 16.52.39.png
        69 kB
        Tony Stevenson
      3. Screen Shot 2012-02-13 at 14.16.27.png
        79 kB
        Tony Stevenson

        Activity

        Gavin added a comment -
        Lukasz, pehaps you should talk with Opensymphony and get a project export or something, otherwise we'll have to close this, we cant import something we dont have.
        Lukasz Lenart added a comment -
        Ok, I will try to contact with someone to do this. Thanks!
        Tony Stevenson added a comment -
        Closing as no update in over 5 weeks. Ticket was opened in late March.
        If you suddenly get data, please re-open the ticket or open a new one.
        Lukasz Lenart added a comment -
        Could you take a look here [1], those are files exported from OpenSymphony JIRA

        [1] people.apache.org:/home/wesw/tmp
        Tony Stevenson added a comment -
        Lukasz,

        If we run an import with any data you provide us, it will blow away the current tickets.
        What do you want us to do?
        Lukasz Lenart added a comment -
        Could you create a new JIRA project for that and give me some time to move / review the imported tickets ?
        Tony Stevenson added a comment -
        Gav,

        You happy for me to do what Lukasz suggests? Create a 2bd temp project, import, and allow him to move the issues across as he sees fit?
        Gavin added a comment -
        Yes thats fine.

        Also, once imported into the 2nd project and after review, a bulk move should be enough to then move them all internally to the current XW jira.

        Go ahead.
        Tony Stevenson added a comment -
        Lukasz,

        This is a little tricky. You're data is from an old version of JIRA, 3.x - So we first need to get that upto our current version 4.3.
        Then we need import your data into a test instance of JIRA, create a new project, bulk move all the old XW issues into new project, delete all the old projects, export the data again, and then import into our production instance.

        Then we need to take care of the attachments later.

        This is likely going to take a few more days. Apologies for the delay. Its not a simple import, as your XW key at opensymphony overlaps with your ASF one.
        Lukasz Lenart added a comment -
        Ok, thanks a lot Tony!
        Tony Stevenson added a comment -
        Lukasz,

        I have managed to finally import the data, after what seems like trying to push a square block through a round hole.
        Now that it is restored however, I no longer have admin acces and cannot complete the process.

        Can you please login here, https://issues.apache.org/jira-test/secure/Dashboard.jspa - and create me an admin account.
        Lukasz Lenart added a comment -
        Thanks a lot!

        The problem is, I don't have admin rights too ;-) I'll ask on Struts user group for help.
        Tony Stevenson added a comment -
        Ahh, then we will need to be given the cred's of an admin user who existed in the backup.

        Else they will need to create another user, and create a backup again.
        Tony Stevenson added a comment -
        Lukasz,

        I have imported the data into the test instance, you can see this here: https://issues.apache.org/jira-test/browse/XWASF
        Can you please perform ant sifting/filtering you wanted to do on here please.

        I have created you an account, so you can login. I will mail you offline with the password.

        So, when you decide you do not want to move a ticket over, please delete it from the test instance, and let us know when you are done and we will export/import into the main instance.

        This way we only need import the data we/you want.
        Lukasz Lenart added a comment -
        Thanks Tony,

        There is one problem, I don't see Delete option in Action menu
        Mark Thomas added a comment -
        lukasz03 should now have privs to do that.
        Lukasz Lenart added a comment -
        Super, thanks!
        Tony Stevenson added a comment -
        Lukasz,

        Hows it going?
        Lukasz Lenart added a comment -
        Slowly - I have vacation right now ;-)
        Lukasz Lenart added a comment -
        Tony, could you import OGNL issues as well ? OGNL was moved under ASF and now it's a part of Commons

        Thanks in advance
        Lukasz Lenart added a comment -
        Is it possible to merge issues base on Summary text ? The keys are different and the only option is to merge base on Summary text, eg.

        https://issues.apache.org/jira-test/browse/XWASF-3
        https://issues.apache.org/jira/browse/XW-37
        Mark Thomas added a comment -
        Why haven't you just deleted the duplicate from the test instance?
        Lukasz Lenart added a comment -
        Because I have to review over 700 issues and compare them by Summary text which isn't too efficient ;-)

        But if there is no other way, I will write some script to do it :/
        Christian Grobmeier added a comment -
        Tony, I might help Lukasz a little bit. Can I have such a login too?
        Tony Stevenson added a comment -
        Christian,

        A login to what exactly? Just so I dont giving you access to too much.
        Lukasz Lenart added a comment -
        Tony, could you import OGNL issues as well and add access to it for me and for Christian ?

        OGNL project was moved under ASF and the issues should be in the same archive as for XWork. Thank you!
        Tony Stevenson added a comment -
        Lukasz,

        Not quite so easily no. We imported the XWork set, separately as that is what you asked for. We removed all the other projects from the list.
        We'd have to start all over again. This isnt a trivial 2 second task, it takes time (hours) to import, tidy, trim, prevent name clashes etc.

        You will also lose all your changes you have made we import your data again.

        Lukasz Lenart added a comment -
        Tony go ahead, I'm preparing a script to do it right ;-)
        Tony Stevenson added a comment -
        Ill see what I can do. Im not sure if I still have the original file now.

        The import will take some time. Please make sure this is the last change as it does get a tad tedious having to redo something you spent quite a lot of time doing before.
        You know, import into an old version, upgrade, then export, import etc - Not too mention all the work Mark did on removing clashing userid's

        Lukasz Lenart added a comment -
        Tony thanks a lot! If ever there would be something, you will hear nothing from me :-)
        Tony Stevenson added a comment -
        Lukasz,

        I no longer have the original source file to be able to do this from.
        Considering the amount of effort that Mark and I have already put into this I am very loathed to have to do it all again.

        So we have two options:

        1) You continue with the current instance with XWorks only and you let us know once you are done, and we proceed as previously planned.
        2) You provide Mark and I with a new XML backup of the data you want to import. We can then load this into the test instance for you. This XML must be taken from a version of JIRA that is the same as the test import version.

        Lukasz Lenart added a comment -
        Ok, I understand Tony, I'll do my best to prepare the package. Could you advise me how did you achieved it ?
        Tony Stevenson added a comment -
        Lukasz, what package? You mean the XML data dump, or something else?
        Lukasz Lenart added a comment -
        I have the old data dump (export) from OpenSymphony JIRA but it's in older JIRA format, right now I want to migrate that data to current ASF JIRA format. Started doing that but got lost ... :/
        Tony Stevenson added a comment - - edited
        To make it import, it needs to be running the same version as the production instance. We cannot import from older versions.
        You need to import that data into a test instance, and upgrade it. Then export it again, and we can work with that.
        Mark Thomas added a comment -
        And the users will need to be de-dupped. Again.

        I made some notes in the Jira run book on how I did this last time.
        #asfinfra IRC Bot added a comment -
        <pctony> Yes, thanks Mark.
        Lukasz Lenart added a comment -
        OK, thanks, I'll do my best :-)
        Lukasz Lenart added a comment -
        Done, I'm running JIRA 4.1.1 locally with imported backup from OpenSymphony. What to do next ?
        Mark Thomas added a comment -
        Upgrade to 4.4.1 to match the ASF Jira instances.
        Lukasz Lenart added a comment -
        Was to tired yesterday :/
        Lukasz Lenart added a comment -
        I was really, really tired, already running 4.4.1 ;-)
        Tony Stevenson added a comment -
        Ok. Any progress Lukasz? Do you have an import for us?

        Cheers,
        Tony
        Lukasz Lenart added a comment -
        Just export what I have now locally ? Or should I clean up it a bit ?
        Tony Stevenson added a comment -
        If the version is the same that is step 1.
        Step 2 is to drop dupes in user names (i.e. OpenSymphony -> ASF) We did this last time.

        Make sure the export you give us is the XML (+ attachments) export.
        Lukasz Lenart added a comment -
        How to achieve step 2 ? Is there a tool for that ? Or maybe I will drop all the users except mine ?
        Lukasz Lenart added a comment -
        Should I do the step 2 manually ?
        #asfinfra IRC Bot added a comment -
        <pctony> Lukasz, only we can do that. As we have the pg database with them all in. Once you provide us with the XML data we can run that up against the live user set.
        Lukasz Lenart added a comment -
        Upload them here or put in my home directory on people.a.o ?
        #asfinfra IRC Bot added a comment -
        <pctony> Lukasz I presume this will not be a private JIRA queue, so feel free to put them wherever you feel most appropriate
        #asfinfra IRC Bot added a comment -
        <pctony> Lukasz I will then take that and try and use it
        Lukasz Lenart added a comment -
        Backup - 8MB
        Attachments - 125MB

        I'll put the in my home folder
        Lukasz Lenart added a comment -
        The files are here /home/lukaszlenart/opensymphony-jira
        Tony Stevenson added a comment -
        Lukasz,

        Is this ready for the test import?
        Lukasz Lenart added a comment -
        Yes
        Tony Stevenson added a comment -
        Thanks, I'll do this as soon as I can,
        Tony Stevenson added a comment -
        Lukasz,

        There are several issues with the import. Also, do you realise there is data from several other projects in this import file?
        Tony Stevenson added a comment -
        All but two errors now resolved...
        Tony Stevenson added a comment -
        Lukasz,

        Hurrah! The data has been imported into the test instance. Can you please check that it looks ok?

        https://issues.apache.org/jira-test

        Tony Stevenson added a comment -
        Actually, scratch that. The issues didn't import, but everything else did.

        Investigating.
        Lukasz Lenart added a comment -
        Waiting ... ;-)

        And regarding the other projects, yes I know, we would like to reimport data for OGNL and XWork - both are part of ASF now
        Tony Stevenson added a comment -
        Lukasz,

        We are still having major issues importing this data. Both Gavin and I have tried this now. On at least 14 occasions.
        I have even built a brand new VM and deployed a brand new, clean 4.4.1 install. The installation fails there too.

        Efforts are still on-going.
        Tony Stevenson added a comment -
        Lukasz,

        I am starting to scrape the bottom of the barrel in terms of ideas. Re-reading atlassians' import guide (http://confluence.atlassian.com/display/JIRA044/Restoring+a+Project+from+Backup)
        it clearly states under the 'Before you begin' stage that we must have identical versions of plugins such as JIRA Toolkit.

        Can you please find out which version of these you have?

        If we dont make much progress I think we will have to open a support ticket with Atlassian.
        Lukasz Lenart added a comment -
        Tony, maybe I'll start my copy locally and we will marge it manually somehow. But maybe this can be against ASF law :/
        Lukasz Lenart added a comment -
        I'm using atlassian-jira-4.4.1-standalone, checking the plugins now
        Tony Stevenson added a comment -
        Thanks.

        Not sure what you mean by start you copy locally? You mean run JIRA yourself, and we will merge it later?
        That might not be as easy your comment suggests. Look how hard it is now.
        Lukasz Lenart added a comment -
        How can I check the version of JIRA Toolkit ? I don't see such plugin in my installation. It consists only bundled plugins.
        Tony Stevenson added a comment -
        Administration > Plugins

        See the latest screenshot I attached....
        Lukasz Lenart added a comment -
        Ok, so I see the problem. My local instance doesn't have any of your plugins ;-) Should I install them and reexport ?
        Tony Stevenson added a comment -
        I have just disabled our plugin... Lets see if that helps...
        Tony Stevenson added a comment -
        I have opened a suport issue with atlassian -- https://support.atlassian.com/browse/JSP-120420
        Lukasz Lenart added a comment -
        @Tony maybe we can use that [1]

        [1] http://swizzle.codehaus.org/Jira+Migration
        #asfinfra IRC Bot added a comment -
        <pctony> Hi, I bet you thought we forgot about you, right? Well we haven't. We recently completed a rather painful upgrade to Jira 5.0.4 - and we are ready to try the import again. Do you think you can provide us with data from 5.0.4 so i can try the import ASAP, before then next upgrade comes along...
        Lukasz Lenart added a comment -
        Ok, will try, thanks :-)
        Lukasz Lenart added a comment -
        the xml is here

        /home/lukaszlenart/opensymphony-jira/2012-05-23-opensymphony-jira-5-0-4.zip

        Attachments didn't change.
        Tony Stevenson added a comment -
        Lukasz,

        We have finally gotten past our issues, and we have an import wich we have managed to complete. Can you please check https://issues.apache.org/jira-test/browse/XW
        Once you have done this, and we have permission from the PMC we will go ahead and do the import. At a weekend.

        However, as you have already been using JIRA the import steps are slightly more complicated. They are below:

        Create new project XWSTAG
        Move the current XW project to XWSTAG
        Delete XW project
        Import old XW project
        Move the XWSTAG issues to XW


        This is straight forward enough, but it will have some consequences. For example, XW-1 as it stands right now in the ASF JIRA will be renumbered, as it will be added after the import of XW JIRA. This is both
        intentional, and unavoidable.

        As this process is running, we dont want anyone using the XW project I propose to run the import this weekend. Probably Saturday PM (UTC/BST) if there are any objections please speak up ASAP. Any delays will push back the import to
        another weekend (it wont be the two that follow as there are other things planned for then)
        Lukasz Lenart added a comment -
        Ok, thanks I'll check ASAP.

        One thing - do I get it right, the both project XW and jira-test/XW will be merged ? The case is that the XW was already imported from OpenSymphony some time ago when XWork project was moved under ASF, but some issues are missing. Merging them will duplicate some issues, is it right ? If so, could you just import what is now under jira-test ? Just add all the issues just after what is now ? Then I'll be able to remove duplicates.

        And the same thing for OGNL project, which also was moved under ASF.
        #asfinfra IRC Bot added a comment -
        <pctony> Lukasz, the current live jira contains an XW project. Does that contain new data, or data imported from XW? If you want the data merged (and that is what my intention is to do) we can do. if you want something else you need to make it clear what it is.
        Lukasz Lenart added a comment -
        The current XW project contains data imported from the old OpenSymphony XW project and some new data (as some issues where created here, after moving to ASF).
        I think, it will be the best to merge the two project together.
        Tony Stevenson added a comment -
        Ok,

        They have been imported. You can now see that you have over 1100 issues in your JIRA project. Enjoy.
        Tony Stevenson added a comment -
        This has now been done.
        Lukasz Lenart added a comment -
        Thanks a lot Tony!

        What about OGNL ? It was also included in the dump package.
        #asfinfra IRC Bot added a comment -
        <pctony> Sorry Lukasz I wasnt aware that we needed to import that too.. Is that to be kept as a separate project still?
        Lukasz Lenart added a comment -
        Yes, OGNL is a separated project under ASF, XWork used it as an expression language

        https://issues.apache.org/jira/browse/OGNL
        #asfinfra IRC Bot added a comment -
        <pctony> Lukasz, I have just imported OGNL now too. Enjoy.
        Lukasz Lenart added a comment -
        Thanks a lot Tony!!!
        #asfinfra IRC Bot added a comment -
        <pctony> All done here now, I think. Closed.
        Lukasz Lenart added a comment -
        Confirmed, great job!

          People

          • Assignee:
            Tony Stevenson
            Reporter:
            Lukasz Lenart
          • Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development