Infrastructure
  1. Infrastructure
  2. INFRA-2532

receiving "svn: PROPFIND of '/repos/asf/...': SSL negotiation failed: SSL error: parse tlsext (https://svn.apache.org) "

    Details

      Description

      Just today, I've started receiving the above error while performing an svn merge -c $REV between a branch and trunk. It's done from the root of the tree (https://svn.apache.org/repos/asf/archiva/trunk/). I'm not sure the last time I did it successfully to correlate to any changes that might have happened on the server.

      It seems we are running a combo that is known to trigger it (httpd 2.2.14 and openssl 0.9.8k), as it's been reported on other installs:
      http://mail-archives.apache.org/mod_mbox/httpd-dev/200910.mbox/%3c4ADF0D8E.1000202@collab.net%3e
      http://serverfault.com/questions/44470/ssl-error-parse-tlsext-on-large-commit-to-svn-via-apache-gentoo

      The clients I tried are Subversion 1.6.5 (Mac) and Subversion 1.6.6 (Windows)

        Issue Links

          Activity

          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Closed Closed
          115d 6h 31m 1 #asfinfra Bot 27/Jun/10 22:20
          Gavin made changes -
          Fix Version/s Initial Clearing [ 12325964 ]
          Tony Stevenson made changes -
          Workflow jira [ 12500837 ] INFRA Workflow [ 12714983 ]
          Brett Porter made changes -
          Link This issue is related to INFRA-2887 [ INFRA-2887 ]
          #asfinfra Bot made changes -
          Field Original Value New Value
          Status Open [ 1 ] Closed [ 6 ]
          Resolution Fixed [ 1 ]
          Hide
          #asfinfra Bot added a comment -
          <pgollucc1> probably suprious, also subversion has been upgraded since, please re-open if it persists
          Show
          #asfinfra Bot added a comment - <pgollucc1> probably suprious, also subversion has been upgraded since, please re-open if it persists
          Hide
          Maria Odea Ching added a comment -
          Btw, I was able to run svn merge without encountering this problem using Subversion 1.4.2 on Linux.
          Show
          Maria Odea Ching added a comment - Btw, I was able to run svn merge without encountering this problem using Subversion 1.4.2 on Linux.
          Hide
          Maria Odea Ching added a comment -
          I'm using Subversion 1.6.2 (Mac) btw. I haven't tried on my linux box though.
          Show
          Maria Odea Ching added a comment - I'm using Subversion 1.6.2 (Mac) btw. I haven't tried on my linux box though.
          Hide
          Maria Odea Ching added a comment - - edited
          I'm encountering the same issue when i tried to do svn merge -c between 2 branches in continuum project.
          Show
          Maria Odea Ching added a comment - - edited I'm encountering the same issue when i tried to do svn merge -c between 2 branches in continuum project.
          Brett Porter created issue -

            People

            • Assignee:
              Unassigned
              Reporter:
              Brett Porter
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development