Infrastructure
  1. Infrastructure
  2. INFRA-2177

people.apache.org httpd MIME type bug: .tgz.sha1 => 'Content-Type: application/x-gzip'

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Fix Version/s: Initial Clearing
    • Component/s: Dists
    • Labels:
      None

      Description

      hi guys. from offlist mail about a proposed-release tarball (and accompanying signatures):

      > >> - The files like Mail-SpamAssassin-rules-3.3.0-alpha2.r802600.tgz.md5
      > >> and Mail-SpamAssassin-rules-3.3.0-alpha2.r802600.tgz.sha1 are
      > >> served by [people.apache.org] as 'Content-Type: application/x-gzip',
      > >> and subsequently the web browsers that I tried (opera and lynx)
      > >> both name the resulting file with a .gz appended, which is then
      > >> very wrong - they can't be gunzipped as they are not really
      > >> compressed, and need to be renamed to let 'sa-update --install'
      > >> find them.

      sure enough,

      : 25...; HEAD http://people.apache.org/~jm/devel/Mail-SpamAssassin-rules-3.3.0-alpha2.r802600.tgz.sha1
      200 OK
      Connection: close
      Date: Mon, 10 Aug 2009 14:33:57 GMT
      Accept-Ranges: bytes
      ETag: "7a5715-5b-470bbe23286c0"
      Server: Apache/2.2.11 (Unix) mod_ssl/2.2.11 OpenSSL/0.9.8e DAV/2
      Content-Length: 91
      Content-Type: application/x-gzip
      Last-Modified: Sun, 09 Aug 2009 21:09:23 GMT
      Client-Date: Mon, 10 Aug 2009 14:34:04 GMT
      Client-Peer: 140.211.11.9:80
      Client-Response-Num: 1


      Could someone check this out? cheers.
      1. INFRA-2177.patch
        0.4 kB
        Todd Volkert

        Activity

        Justin Mason created issue -
        Brett Porter made changes -
        Field Original Value New Value
        Component/s Dists [ 12312864 ]
        Mark Martinec added a comment -
        This is still unresolved. As we are approaching a new release of SpamAssassin, the issue is again hot.


        $ HEAD http://people.apache.org/~wtogami/devel/Mail-SpamAssassin-3.3.0-beta1.tar.gz.md5
        200 OK
        [...]
        Content-Type: application/x-gzip

        $ HEAD http://people.apache.org/~wtogami/devel/Mail-SpamAssassin-3.3.0-beta1.tar.gz.sha1
        200 OK
        [...]
        Content-Type: application/x-gzip


        Files ending in .md5 or .sha1 SHOULD NOT have a Content-Type of application/x-gzip (inherited
        from a 'gz' in the middle of their names). I'm not sure what is the most appropriate MIME type
        for ascii digest files, but something like text/plain would be just fine (or perhaps text/x-hash or
        application/x-signature).

        Adding something like the following to the httpd configuration helps:

          AddType text/plain .md5
          AddType text/plain .sha1
        Mark Martinec added a comment -
        Btw, the test case has changed meanwhile:

        HEAD http://people.apache.org/~wtogami/devel/3.3.0-rc1.proposed2/Mail-SpamAssassin-3.3.0-rc1.proposed2.tar.bz2.md5
        HEAD http://people.apache.org/~wtogami/devel/3.3.0-rc1.proposed2/Mail-SpamAssassin-3.3.0-rc1.proposed2.tar.bz2.sha1

        but the result is still the incorrect:
          Content-Type: application/x-bzip2

        Any chance of adding these two AddType lines to the httpd config file on minotaur?
        Todd Volkert added a comment -
        Can you not put the AddType line in /home/wtogami/public_html/devel/.htaccess?

        AddType text/plain .asc .md5 .sha1
        Mark Martinec added a comment -
        > Can you not put the AddType line in /home/wtogami/public_html/devel/.htaccess?

        I prefer general solutions that solve a problem for all users / for future cases too,
        but I guess we can live with an ad-hoc fix. Thanks.
        Todd Volkert added a comment -
        Agreed that solutions that help all are desirable. The attached patch might do the trick.
        Todd Volkert made changes -
        Attachment INFRA-2177.patch [ 12428859 ]
        #asfinfra IRC Bot added a comment -
        <pgollucci> done
        #asfinfra IRC Bot made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Resolution Fixed [ 1 ]
        Mark Martinec added a comment -
        Thanks for fixing the mime type on .md5 and .sha1 !

        As for .asc, this was not incorrect previously, it was returning application/pgp-signature
        if I remember correctly. While text/plain is not strictly incorrect, I think the .asc
        should be better left as it was.
        #asfinfra IRC Bot added a comment -
        <pgollucci> .asc reverted
        Tony Stevenson made changes -
        Workflow jira [ 12472826 ] INFRA Workflow [ 12716021 ]
        Gavin made changes -
        Fix Version/s Initial Clearing [ 12325964 ]

          People

          • Assignee:
            Unassigned
            Reporter:
            Justin Mason
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development